(address . guix-patches@gnu.org)
Hi guix,
The github.com/golang/protobuf module contains several packages.
Only proto is currently packaged. This change updates the module from
1.3.1 to 1.5.2 and packages the entire module.
This is needed as I am preparing to package lxd (github.com/lxc/lxd),
which depends on the unpackaged packages from golang/protobuf.
This change replaces go-github-com-golang-protobuf-proto with
go-github-com-golang-protobuf.
There are currently two packages that depend on
go-github-com-golang-protobuf-proto. I have tested this changeset by
building both of these packages.
go-github-com-lucas-clemente-quic-go: this is a source only package that
no other package uses.
syncthing: depends on go-github-com-golang-protobuf-proto via several
intermediary packages. After building, I've run some of the syncthing
executables and they appear to work.
From 47de2a85a1ae1f0502a89d0097d3b36da7d20649 Mon Sep 17 00:00:00 2001
From: Dion Mendel <guix@dm9.info>
Date: Thu, 6 May 2021 23:25:22 +0800
Subject: [PATCH 1/2] gnu: Add go-golang-org-protobuf.
* gnu/packages/golang.scm (go-golang-org-protobuf): New variable.
---
gnu/packages/golang.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)
Toggle diff (50 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8c3c81ceda..f0fa0e1d36 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2021 Dion Mendel <guix@dm9.info>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4832,6 +4833,35 @@ data serialization format.")
(home-page "https://github.com/golang/protobuf")
(license license:bsd-3)))
+(define-public go-golang-org-protobuf
+ (package
+ (name "go-golang-org-protobuf")
+ (version "1.26.0")
+ (home-page "https://github.com/protocolbuffers/protobuf-go")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0xq6phaps6d0vcv13ga59gzj4306l0ki9kikhmb52h6pq0iwfqlz"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "google.golang.org/protobuf"
+ ; Source-only package
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'build))))
+ (propagated-inputs
+ `(("go-github-com-google-go-cmp-cmp" ,go-github-com-google-go-cmp-cmp)))
+ (synopsis "Go support for Protocol Buffers")
+ (description "This project hosts the Go implementation for protocol buffers, which is a
+language-neutral, platform-neutral, extensible mechanism for serializing
+structured data.")
+ (license license:bsd-3)))
+
(define-public go-github-com-mattn-go-zglob
(package
(name "go-github-com-mattn-go-zglob")
--
2.31.1