[PATCH] gnu: Add python-fb-re2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Björn Höfling
  • Xinglu Chen
Owner
unassigned
Submitted by
Xinglu Chen
Severity
normal
X
X
Xinglu Chen wrote on 5 May 2021 22:06
(address . guix-patches@gnu.org)
6d596226b303921f5b1b7a2c2757cdfb94f6b2e5.1620245148.git.public@yoctocell.xyz
* gnu/packages/python-xyz.scm (python-fb-re2): New variable.
---
gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 38ed1bc19e..32a4acc75f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -99,6 +99,7 @@
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Ellis Keny? <me@elken.dev>
;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
+;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -181,6 +182,7 @@
#:use-module (gnu packages qt)
#:use-module (gnu packages rdf)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages regex)
#:use-module (gnu packages sdl)
#:use-module (gnu packages search)
#:use-module (gnu packages scanner)
@@ -1271,6 +1273,29 @@ conventions and aliases in the same expression.")
API for locking files.")
(license license:expat)))
+(define-public python-fb-re2
+ (package
+ (name "python-fb-re2")
+ (version "1.0.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "fb-re2" version))
+ (sha256
+ (base32
+ "1kr6xwjfl3h15gwq00g5d4cwwmqs5z7z8k3q79p4x1ykb36w5cl3"))))
+ (build-system python-build-system)
+ (arguments
+ ;; No tests in PyPI tarball.
+ `(#:tests? #f))
+ (inputs
+ `(("re2" ,re2)))
+ (home-page "https://github.com/facebook/pyre2")
+ (synopsis "Python wrapper for RE2")
+ (description "This package provides a Python extension that wraps Google's
+RE2 regular expression library. It implements many of the features of
+Python's built-in @code{re} module with compatible interfaces.")
+ (license license:bsd-3)))
+
(define-public python-filelock
(package
(name "python-filelock")

base-commit: f47b8b332b3adaab8743775b9e45638dcd381e78
--
2.31.1
B
B
Björn Höfling wrote on 14 May 2021 22:30
(name . Xinglu Chen)(address . public@yoctocell.xyz)(address . 48244-done@debbugs.gnu.org)
20210514223017.30232387@alma-ubu.fritz.box
Pushed as

e026b226cda7e6513cf34ee80b278f60fdc7fbf4

Thanks.

With two slight changes:

On Wed, 05 May 2021 22:06:36 +0200
Xinglu Chen <public@yoctocell.xyz> wrote:

Toggle quote (8 lines)
> * gnu/packages/python-xyz.scm (python-fb-re2): New variable.

> + (source (origin
> + (method url-fetch)
> + (uri (pypi-uri "fb-re2" version))
> + (sha256
> + (base32

I used git-fetch instead using the github repo....

Toggle quote (4 lines)
> + (arguments
> + ;; No tests in PyPI tarball.
> + `(#:tests? #f))

... then I can enable the tests.

Björn
-----BEGIN PGP SIGNATURE-----

iF0EAREKAB0WIQQiGUP0np8nb5SZM4K/KGy2WT5f/QUCYJ7d2QAKCRC/KGy2WT5f
/bBeAJ4zy9H+1/Jb4avGHfbb2TXxB+ol3wCgryBmvKYShLKnSgl5ZV8o+ahgUvc=
=/0wC
-----END PGP SIGNATURE-----


Closed
?