[PATCH 0/1] Fix broken crm114 package

  • Done
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • Leo Prikler
Owner
unassigned
Submitted by
Arun Isaac
Severity
normal
A
A
Arun Isaac wrote on 4 May 2021 07:01
(address . guix-patches@gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
20210504050103.6998-1-arunisaac@systemreboot.net
Hi,

Our crm114 package broke due to the recent change in the emacs-build-system
installing emacs lisp files in their own subdirectories. This patch fixes the
build and makes it more robust to any future changes in the
emacs-build-system.

Arun Isaac (1):
gnu: crm114: Install emacs mode using emacs-build-system install
phase.

gnu/packages/mail.scm | 9 ++++-----
1 file changed, 4 insertions(+), 5 deletions(-)

--
2.31.0
A
A
Arun Isaac wrote on 4 May 2021 07:06
[PATCH] gnu: crm114: Use emacs-build-system install phase.
(address . 48215@debbugs.gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
20210504050651.7643-1-arunisaac@systemreboot.net
* gnu/packages/mail.scm (crm114)[arguments]: Install the crm114 emacs mode
using the install phase from emacs-build-system, instead of in the custom
pre-install phase. Run the make-autoloads phase after this new
install-emacs-mode phase.
---
gnu/packages/mail.scm | 9 ++++-----
1 file changed, 4 insertions(+), 5 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index e4ddf5ee9b..ea5a3d2b1e 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -4432,12 +4432,11 @@ score.")
;; Install mail related crm scripts.
(for-each (lambda (file)
(install-file file (string-append out "/bin")))
- (list "mailfilter.crm" "mailreaver.crm" "mailtrainer.crm"))
- ;; Create emacs site-lisp directory so that the install phase
- ;; can install crm-mode.
- (mkdir-p (string-append out "/share/emacs/site-lisp")))))
+ (list "mailfilter.crm" "mailreaver.crm" "mailtrainer.crm")))))
+ (add-after 'install 'install-emacs-mode
+ (assoc-ref emacs:%standard-phases 'install))
;; Run phases from the emacs build system.
- (add-after 'install 'make-autoloads
+ (add-after 'install-emacs-mode 'make-autoloads
(assoc-ref emacs:%standard-phases 'make-autoloads))
(add-after 'make-autoloads 'enable-autoloads-compilation
(assoc-ref emacs:%standard-phases 'enable-autoloads-compilation))
--
2.31.0
L
L
Leo Prikler wrote on 5 May 2021 10:11
1856881cfa643cf4b7b2d13868d995b2450731c5.camel@student.tugraz.at
Pushed as c1036042a52ea25fa833b5b30d18b9f198b74727.
Thanks!
Closed
?