[PATCH 1/2]: gnu: Add 3d-vectors

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5oUB7eqSTxeEmv=CnLp7+iVtb3PZw9qcARBqfLLvmK=Bw@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From d9820207d9ced944693e8e350eeecc944becfe68 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Mon, 3 May 2021 22:53:40 +0100
Subject: [PATCH 1/2] gnu: Add 3d-vectors

* gnu/packages/lisp-xyz.scm (sbcl-3d-vectors, ecl-3d-vectors,
cl-3d-vectors): New variables
---
gnu/packages/lisp-xyz.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 6f2666608f..d7001d4c9b 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -16371,3 +16371,40 @@ for Common Lisp.")
(define-public cl-bknr-datastore
(sbcl-package->cl-source-package sbcl-bknr-datastore))
+
+(define-public sbcl-3d-vectors
+ (let ((commit "29bb9684df803590deed344af63dbf7b712aabc0")
+ (revision "1"))
+ (package
+ (name "sbcl-3d-vectors")
+ (version (git-version "3.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shinmera/3d-vectors")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0qc7m5brhpwi531rgmlaj1c609by533a1ia5hv8f90ilm8ksmw3l"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:asd-files '("3d-vectors.asd")
+ #:asd-systems '("3d-vectors")))
+ (native-inputs
+ `(("parachute" ,sbcl-parachute)))
+ (inputs
+ `(("documentation-utils" ,sbcl-documentation-utils)))
+ (home-page "https://shinmera.github.io/3d-vectors/")
+ (synopsis "Utility library implementing 2D, 3D, and 4D vector functionality")
+ (description
+ "@code{3D-VECTORS} is a library for vector math in 3D space. It contains
+most of the vector operations one would usually expect out of such a library and
+offers them both in non-modifying and modifying versions where applicable.")
+ (license license:zlib))))
+
+(define-public ecl-3d-vectors
+ (sbcl-package->ecl-package sbcl-3d-vectors))
+
+(define-public cl-3d-vectors
+ (sbcl-package->cl-source-package sbcl-3d-vectors))
--
2.31.1
Sharlatan Hellseher wrote 4 years ago
[PATCH 2/2]: gnu: Add 3d-matricies
(address . 48208@debbugs.gnu.org)
CAO+9K5p7jbeqR+RwypyUAm0cD1Hh+aJERcd3qboK5FwESczUjg@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
Guillaume Le Vaillant wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 48208@debbugs.gnu.org)
87lf8uy5kw.fsf@yamatai
Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (7 lines)
> Subject: [PATCH 2/2] gnu: Add 3d-matrices
>
> Draft
>
> I'm not sure where is the source of this issue, it looks like the
> problem in the naming of the package which includes '-3d-' in the name.

Yes, there is a bug in the function separating the name and the version
of a package.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYJFQPw8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+M5gD/YcdGnOdgaVGAsPSDR8wp2YClLhVSeQkGvPQ2
SXggtsgA/R82PtOl7P1dWp+ckrs+Fz1B4UoQk9TUcgrawMjTTdB+
=Fqyd
-----END PGP SIGNATURE-----

Guillaume Le Vaillant wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 48208-done@debbugs.gnu.org)
87lf8pie7h.fsf@kitej
Patches pushed as e961f15083e71abfd16b74a10331c9297960370d and
following.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYJaIkg8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j83iQEAmnqtrd5SnKYH19t3s2D9J1YRCZOqr0ALkKTS
uVfjr8AA/1x5/FPSTok+Y5l8qoY/lR1f6ZRFYblOmBNpknofCKkU
=TDrZ
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48208@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48208
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help