[PATCH 1/2]: gnu: Update cl-environments to v0.4

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5oyhzM-Y91VGyeLT+h8KSV_e2w6xkLwLoGd=Ym6+DMe9w@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From ca412d4f25fc986aa4f5d6532de9147d9a5bb4c0 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Mon, 3 May 2021 19:57:16 +0100
Subject: [PATCH 1/2] gnu: cl-environments: Update to v0.4

* gnu/package/lisp-xyz.scm (sbcl-cl-environments)
[version]: use annotated tag instead of direct commit, there is
upstream releases available now
---
gnu/packages/lisp-xyz.scm | 59 +++++++++++++++++++--------------------
1 file changed, 29 insertions(+), 30 deletions(-)

Toggle diff (72 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 57b4abf067..b2de6965e0 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -13135,36 +13135,35 @@ collecting values easier.")
(sbcl-package->ecl-package sbcl-collectors))
(define-public sbcl-cl-environments
- (let ((commit "0b22154c5afefef23d1eba9a4fae11d73580ef41")) ; No version in 2 years.
- (package
- (name "sbcl-cl-environments")
- (version (git-version "0.2.3" "1" commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/alex-gutev/cl-environments")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "18r3wfarr7lgn78m6c66r0r9aazirv07gy7xgvqkl9pmrz1bc47m"))))
- (build-system asdf-build-system/sbcl)
- (inputs
- `(("alexandria" ,sbcl-alexandria)
- ("anaphora" ,sbcl-anaphora)
- ("collectors" ,sbcl-collectors)
- ("optima" ,sbcl-optima)))
- (native-inputs
- `(("prove" ,sbcl-prove)))
- (home-page "https://github.com/alex-gutev/cl-environments")
- (synopsis "Implements the Common Lisp standard environment access API")
- (description "This library provides a uniform API, as specified in Common
-Lisp the Language 2, for accessing information about variable and function
-bindings from implementation-defined lexical environment objects. All major
-Common Lisp implementations are supported, even those which don't support the
-CLTL2 environment access API.")
- (license license:expat))))
+ (package
+ (name "sbcl-cl-environments")
+ (version "0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alex-gutev/cl-environments")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10jxj043d2dw5vc0i0lz0lsa4qszn8him5is8jdhl4nsyfcazmky"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("alexandria" ,sbcl-alexandria)
+ ("anaphora" ,sbcl-anaphora)
+ ("collectors" ,sbcl-collectors)
+ ("optima" ,sbcl-optima)))
+ (native-inputs
+ `(("prove" ,sbcl-prove)))
+ (home-page "https://github.com/alex-gutev/cl-environments")
+ (synopsis "Implements the Common Lisp standard environment access API")
+ (description
+ "This library provides a uniform API, as specified in Common Lisp the
+Language 2, for accessing information about variable and function bindings
+from implementation-defined lexical environment objects. All major Common
+Lisp implementations are supported, even those which don't support the CLTL2
+environment access API.")
+ (license license:expat)))
(define-public cl-environments
(sbcl-package->cl-source-package sbcl-cl-environments))
--
2.31.1
Sharlatan Hellseher wrote 4 years ago
[PATCH 2/2]: gnu: static-dispatch: Update to v0.5
(address . 48203@debbugs.gnu.org)
CAO+9K5piCePZ0rXJDESq0nZHL640gWTptEc5EmZqF8U686jNSQ@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 9d1b8c1f420afd3a18731747d45f305590f5b8c7 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Mon, 3 May 2021 20:26:17 +0100
Subject: [PATCH 2/2] gnu: static-dispatch: Update to v0.5

* gnu/packages/lisp-xyz.scm (sbcl-static-dispatch)
[version]: Use annotated tag of the latest release in upstream
[native-inputs]: prove -> fiveam resolving
---
gnu/packages/lisp-xyz.scm | 58 +++++++++++++++++++--------------------
1 file changed, 28 insertions(+), 30 deletions(-)

Toggle diff (78 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index b2de6965e0..a38edac1eb 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -13172,35 +13172,33 @@ environment access API.")
(sbcl-package->ecl-package sbcl-cl-environments))
(define-public sbcl-static-dispatch
- (let ((commit "6243afcd152854c52ba33daef7394367b657d9c6")
- (revision "1"))
- (package
- (name "sbcl-static-dispatch")
- (version (git-version "0.3" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/alex-gutev/static-dispatch")
- (commit commit)))
- (file-name (git-file-name "static-dispatch" version))
- (sha256
- (base32 "1lli9ar1xbnhkgb5d01rlw4pvfylg2arrw68np2c07fpkkafimg7"))))
- (build-system asdf-build-system/sbcl)
- (native-inputs
- `(("prove" ,sbcl-prove)))
- (inputs
- `(("agutil" ,sbcl-agutil)
- ("alexandria" ,sbcl-alexandria)
- ("anaphora" ,sbcl-anaphora)
- ("arrows" ,sbcl-arrows)
- ("cl-environments" ,sbcl-cl-environments)
- ("closer-mop" ,sbcl-closer-mop)
- ("iterate" ,sbcl-iterate)
- ("trivia" ,sbcl-trivia)))
- (home-page "https://github.com/alex-gutev/static-dispatch")
- (synopsis "Static generic function dispatch for Common Lisp")
- (description "Static dispatch is a Common Lisp library, inspired by
+ (package
+ (name "sbcl-static-dispatch")
+ (version "0.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alex-gutev/static-dispatch")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "static-dispatch" version))
+ (sha256
+ (base32 "1a4vgfcn6qnpdkxxv93rri7zf3c92alixp6nyqwpz8mg2xmvy1j3"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ `(("fiveam" ,sbcl-fiveam)))
+ (inputs
+ `(("agutil" ,sbcl-agutil)
+ ("alexandria" ,sbcl-alexandria)
+ ("anaphora" ,sbcl-anaphora)
+ ("arrows" ,sbcl-arrows)
+ ("cl-environments" ,sbcl-cl-environments)
+ ("closer-mop" ,sbcl-closer-mop)
+ ("iterate" ,sbcl-iterate)
+ ("trivia" ,sbcl-trivia)))
+ (home-page "https://github.com/alex-gutev/static-dispatch")
+ (synopsis "Static generic function dispatch for Common Lisp")
+ (description "Static dispatch is a Common Lisp library, inspired by
@code{inlined-generic-function}, which allows standard Common Lisp generic
function dispatch to be performed statically (at compile time) rather than
dynamically (runtime). This is similar to what is known as \"overloading\" in
@@ -13212,7 +13210,7 @@ functions, such as adding/removing methods at runtime are not required. An
example of such a case is a generic equality comparison function. Currently
generic functions are considered far too slow to implement generic arithmetic
and comparison operations when used heavily in numeric code.")
- (license license:expat))))
+ (license license:expat)))
(define-public cl-static-dispatch
(sbcl-package->cl-source-package sbcl-static-dispatch))
--
2.31.1
Guillaume Le Vaillant wrote 4 years ago
Re: [bug#48203] [PATCH 1/2]: gnu: Update cl-environments to v0.4
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 48203-done@debbugs.gnu.org)
87wnsey82h.fsf@yamatai
Patches pushed as 36d4877041e0651d1af56b47127b8566c0fd0259 and
following.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYJFDpg8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/8jQD/QAPLlrQUBr3tIdN2tXo7qHPpvndkrQtQDVIm
Tdw8BZQBAIupVaU4xbcTQ9kzZs9H9TdAGddt2MMr1Oiez7h4RZhy
=IBmi
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48203@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48203
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help