[PATCH] gnu: vcsh: Update to 1.20190621.

  • Done
  • quality assurance status badge
Details
2 participants
  • Tobias Geerinckx-Rice
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 4 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20210503155417.2523-1-mike@rohleder.de
* gnu/packages/version-control.scm (vcsh): Update to 1.20190621.
[arguments]: Add phase install-bash-completion.
---
gnu/packages/version-control.scm | 15 +++++++++++----
1 file changed, 11 insertions(+), 4 deletions(-)

Toggle diff (49 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 8df7cc8d14..859083aa07 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -31,7 +31,7 @@
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
-;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Chris Marusich <cmmarusich@gmail.com>
@@ -1316,7 +1316,7 @@ manipulate them in various ways.")
(define-public vcsh
(package
(name "vcsh")
- (version "1.20151229")
+ (version "1.20190621")
(source
(origin
(method git-fetch)
@@ -1325,7 +1325,7 @@ manipulate them in various ways.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1grpj45nbpv4j60vd2kg4rj53zrm0bc0h9l4pfd3c2mwbvywm6ab"))))
+ (base32 "1s9l47wm9r7sndcgc778mq60wkzkhvfv7rkrwci5kjvw8vsddvcc"))))
(build-system gnu-build-system)
(native-inputs
`(("which" ,which)))
@@ -1338,7 +1338,14 @@ manipulate them in various ways.")
(arguments
'(#:phases (modify-phases %standard-phases
(delete 'configure)
- (delete 'build))
+ (delete 'build)
+ (add-after 'install 'install-bash-completion
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (completions (string-append out "/etc/bash_completion.d")))
+ (mkdir-p completions)
+ (copy-file "_vcsh_bash" (string-append completions "/vcsh"))
+ #t))))
#:make-flags (list (string-append "PREFIX="
(assoc-ref %outputs "out")))
#:test-target "test"))
--
2.31.1
Tobias Geerinckx-Rice wrote 4 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)
87a6pb4vhc.fsf@nckx
Michael,

Michael Rohleder 写道:
Toggle quote (2 lines)
> * gnu/packages/version-control.scm (vcsh): Update to 1.20190621.

Thanks!

Toggle quote (2 lines)
> [arguments]: Add phase install-bash-completion.

Since this isn't new in this release, I think it should be a
separate commit. Do you agree?

Toggle quote (2 lines)
> + #t))))

You can (finally!) omit this now.

Ignore the lint warning, which is still there only because its
removal needs to pass through core-updates.

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCYJAonw0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15RdIBAKBfK8dbdPuzBNR53CbcYaSu7LP0lW0p0lfLa3sd
6K5OAP9UacVwh8ORb9MyoZVlUuORN7BPzV4AkW3dwTXd+WFbAg==
=VF5D
-----END PGP SIGNATURE-----

Michael Rohleder wrote 4 years ago
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)(address . 48198@debbugs.gnu.org)
87y2cvvjvg.fsf@rohleder.de
Hey Tobias,

Thanks for reviewing!

Tobias Geerinckx-Rice <me@tobias.gr> writes:
Toggle quote (5 lines)
>> [arguments]: Add phase install-bash-completion.
>
> Since this isn't new in this release, I think it should be a separate
> commit. Do you agree?

No, I don't agree.
I think it is new (at least, compared to the version we had/I made
before)

Toggle quote (8 lines)
>
>> + #t))))
>
> You can (finally!) omit this now.
>
> Ignore the lint warning, which is still there only because its removal
> needs to pass through core-updates.

Ah, ok. I was wondering about the warning.

Thank you!

--
Der menschliche Geist waechst mit dem Raum in dem er sich bewegt.
-----BEGIN PGP SIGNATURE-----

iQFFBAEBCAAvFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAmCQKqMRHG1pa2VAcm9o
bGVkZXIuZGUACgkQfHr/vv7yyyU6vgf/cJxryOlKmI8LEwoosDzcMAfmGgPhOV3+
yeaxDFfjylVMyXIL3Vsna7CD3XbrNza7bEv1WixxFkuXQ7dgUzEQZC7b5ZZdm/J8
V1me6et4XKWV8PpnVt0x3HBvLVLGiaCDj9m0AJNCDSkI7hK70AO+lR29jsIWeVr7
vW2t4S2h6fLWgjadKqvlYbYqpYSOJvPDvAPu9ySTZcdPBgE83UFFLPJYRW+oZelj
PkPhZdxV0C7e/Uu+bxJyKP3pcBLzHj2hFibJALDZxvH4crQjkPhJnvYAX2Y8Nx9B
Yf0WsMIJSC60pxbi1pcbY1204x2CfhMGp3Jjye8JKw9s8ARvAB1jEA==
=hvJv
-----END PGP SIGNATURE-----

Tobias Geerinckx-Rice wrote 4 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 48198-done@debbugs.gnu.org)
877dkfo8d1.fsf@nckx
Michael,

Michael Rohleder 写道:
Toggle quote (5 lines)
> No, I don't agree.
> I think it is new (at least, compared to the version we had/I
> made
> before)

You're right--and what an ancient version it was!

I was looking at zsh completion, not bash. I wonder why that's
installed by default whilst bash is not. Shrug.

I de-indented #:phases as it made your new lines exceed 80
characters for no good reason.

Pushed as 2c09755a7a07a971d7c2ad6dbe991689837fd29c.

Thanks!

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCYJBgqg0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15wmgBAKpsoEw2g/ddwEuOzJcfatr79RV/0L21ju5/qzIV
5uWSAQDfiShlcFoFi4UJQPmypFYLpFvi1weC/69LMd3IXLh2Aw==
=8p0n
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48198@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48198
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help