Hey Ludo!
Thanks for the ping and sorry for the delay!
I hope, this patch is better/pushable ;)
Toggle quote (1 lines)
>From 7e998af5b498388e5ffcf2491c6c934bf49b5c98 Mon Sep 17 00:00:00 2001
* gnu/packages/video.scm (libmediainfo): Fix usage of libcurl and libtinyxml2.
[arguments]: Add configure-flags.
[native-inputs]: Move zlib, tinyxml2, curl, libzen to ...
[propagated-inputs]: ... Here.
(mediainfo):
[native-inputs]: Remove zlib, libzen. Move libmediainfo to ...
[inputs]: ... Here.
---
gnu/packages/video.scm | 16 +++++++++-------
1 file changed, 9 insertions(+), 7 deletions(-)
Toggle diff (41 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index a694d4bb43..5c028016cf 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3850,14 +3850,17 @@ practically any type of media.")
`(("autoconf" ,autoconf)
("automake" ,automake)
("libtool" ,libtool)
- ("pkg-config" ,pkg-config)
- ("zlib" ,zlib)
+ ("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("zlib" ,zlib)
("tinyxml2" ,tinyxml2)
- ("curl" ,curl)
+ ("curl" ,curl) ; In Requires.private of libmediainfo.pc.
("libzen" ,libzen)))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; see above TODO
+ #:configure-flags
+ (list "--with-libcurl" "--with-libtinyxml2")
#:phases
;; build scripts not in root of archive
(modify-phases %standard-phases
@@ -3910,10 +3913,9 @@ MPEG-2, MPEG-4, DVD (VOB)...
`(("autoconf" ,autoconf)
("automake" ,automake)
("libtool" ,libtool)
- ("pkg-config" ,pkg-config)
- ("zlib" ,zlib)
- ("libmediainfo" ,libmediainfo)
- ("libzen" ,libzen)))
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libmediainfo" ,libmediainfo)))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; lacks tests
--
2.32.0
--
I've finally learned what "upward compatible" means. It means we get to
keep all our old mistakes. Dennie van Tassel
-----BEGIN PGP SIGNATURE-----
iQFFBAEBCAAvFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAmDAX2gRHG1pa2VAcm9o
bGVkZXIuZGUACgkQfHr/vv7yyyWd+gf9EcLLVzfyG/DQ0iBFJEm+1ZW/if9kqya3
g32GLex3IwM9wj6Uc5hH4ZlqRGbadJ7tflwaThlL0e1ESFBF4vG2IIpQx79+1D+Y
fXjx/4Zt9NpiIF5VqLtpL90EeV4FEJQYveGOXaKWOsULHkmRGA9bQF4vaXCDgI7s
9JRXl88uVFzJafSytDJWz56pcjMV9rOygu3pUmBpYkvfA4GC40/Xse46iVIFLJQI
mjJOQ3PPeigxEwZL7z9Z1Yg9iGrj1f3LkoTBrkD1XhzfmRvabsG6cKyhdze4g3tK
xveNj/IWfOxQ+JKj1MQgvpU2TR7zXK8V98TCizh8EzeM/pgm77fE/A==
=krOg
-----END PGP SIGNATURE-----