[PATCH] gnu: libmediainfo: Fix usage of libcurl and libtinyxml2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal
M
M
Michael Rohleder wrote on 3 May 2021 17:20
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20210503152034.31389-1-mike@rohleder.de
* gnu/packages/video.scm (libmediainfo)[arguments]: Add configure-flags.
---
gnu/packages/video.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (15 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 481ab46b6e..1052351357 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3834,6 +3834,8 @@ practically any type of media.")
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; see above TODO
+ #:configure-flags
+ (list "--with-libcurl" "--with-libtinyxml2")
#:phases
;; build scripts not in root of archive
(modify-phases %standard-phases
--
2.31.1
L
L
Ludovic Courtès wrote on 11 May 2021 12:31
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 48194-done@debbugs.gnu.org)
878s4l36k7.fsf@gnu.org
Hi,

Michael Rohleder <mike@rohleder.de> skribis:

Toggle quote (2 lines)
> * gnu/packages/video.scm (libmediainfo)[arguments]: Add configure-flags.

Applied, thanks!
Closed
L
L
Ludovic Courtès wrote on 11 May 2021 12:51
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 48194@debbugs.gnu.org)
87h7j91r2r.fsf@gnu.org
Michael Rohleder <mike@rohleder.de> skribis:

Toggle quote (2 lines)
> * gnu/packages/video.scm (libmediainfo)[arguments]: Add configure-flags.

Actually no, this one appears to break ‘mediainfo’ as I wrote in my
other message.
L
L
Ludovic Courtès wrote on 11 May 2021 12:50
control message for bug #48194
(address . control@debbugs.gnu.org)
87lf8l1r3h.fsf@gnu.org
reopen 48194
tags 48194 - fixed patch
quit
M
M
Michael Rohleder wrote on 11 May 2021 14:14
Re: bug#48194: [PATCH] gnu: libmediainfo: Fix usage of libcurl and libtinyxml2.
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 48194@debbugs.gnu.org)
874kf979i1.fsf_-_@rohleder.de
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (7 lines)
> Michael Rohleder <mike@rohleder.de> skribis:
>
>> * gnu/packages/video.scm (libmediainfo)[arguments]: Add configure-flags.
>
> Actually no, this one appears to break ‘mediainfo’ as I wrote in my
> other message.

The consumer (mediainfo) needs curl and tinyxml2 inputs:
Toggle quote (1 lines)
>From 6612d1189263cc4670b820e26f5e75d4df9c68b0 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Tue, 11 May 2021 14:05:13 +0200
Subject: [PATCH] gnu: mediainfo: Fix usage of libcurl and tinyxml2.

* gnu/packages/video.scm (mediainfo): Fix usage of libcurl and tinyxml2.
---
gnu/packages/video.scm | 4 ++++
1 file changed, 4 insertions(+)

Toggle diff (24 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 481ab46b6e..630edf49b6 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3834,6 +3834,8 @@ practically any type of media.")
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; see above TODO
+ #:configure-flags
+ (list "--with-libcurl" "--with-libtinyxml2")
#:phases
;; build scripts not in root of archive
(modify-phases %standard-phases
@@ -3888,6 +3890,8 @@ MPEG-2, MPEG-4, DVD (VOB)...
("libtool" ,libtool)
("pkg-config" ,pkg-config)
("zlib" ,zlib)
+ ("curl" ,curl) ;; In Requires.private of libmediainfo pkg-config files.
+ ("tinyxml2" ,tinyxml2)
("libmediainfo" ,libmediainfo)
("libzen" ,libzen)))
(build-system gnu-build-system)
--
2.31.1
--
A million monkeys pounding on a million typewriters will never produce
Shakespeare. The experiment's been tried; we got USENET instead.
-----BEGIN PGP SIGNATURE-----

iQFFBAEBCAAvFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAmCadSYRHG1pa2VAcm9o
bGVkZXIuZGUACgkQfHr/vv7yyyXKYQf9HIfJs+q0roR1SgURZPXk+dK3tZGk/frx
nDnSe9IzQn9MANFQTzi3db+h22Ws9wDcmnZfjSt0QqW58W7ehclT20W0hcQuupBJ
6MBZaZmN9MAX+492D0dTDGLeWSOV2KoJnAichnkX9yWBUYG3mD/V+D07dWkSXWoS
DMIakukKxYVqANzLr9Z1oWhMVWSg8Dw0Wd2WiGh4EdopTMRxRWpvKmWRxWuDH3SW
wwPprjuvfEwFhbV3IASTK1LTy7cEaIIKR9dihrwdc4NnNk27kCT0at5cploGXIsa
hOEUz7NcgrlyJEkzEQR1Aq1nsX8yfJaYKb2KeyvM8Q+VhcZ+6EZPcg==
=RUGZ
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 11 May 2021 14:30
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 48194@debbugs.gnu.org)
87v97pzc41.fsf@gnu.org
Michael Rohleder <mike@rohleder.de> skribis:

Toggle quote (7 lines)
>>From 6612d1189263cc4670b820e26f5e75d4df9c68b0 Mon Sep 17 00:00:00 2001
> From: Michael Rohleder <mike@rohleder.de>
> Date: Tue, 11 May 2021 14:05:13 +0200
> Subject: [PATCH] gnu: mediainfo: Fix usage of libcurl and tinyxml2.
>
> * gnu/packages/video.scm (mediainfo): Fix usage of libcurl and tinyxml2.

Please mention [arguments] and [propagated-inputs].


Toggle quote (23 lines)
> gnu/packages/video.scm | 4 ++++
> 1 file changed, 4 insertions(+)
>
> diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
> index 481ab46b6e..630edf49b6 100644
> --- a/gnu/packages/video.scm
> +++ b/gnu/packages/video.scm
> @@ -3834,6 +3834,8 @@ practically any type of media.")
> (build-system gnu-build-system)
> (arguments
> '(#:tests? #f ; see above TODO
> + #:configure-flags
> + (list "--with-libcurl" "--with-libtinyxml2")
> #:phases
> ;; build scripts not in root of archive
> (modify-phases %standard-phases
> @@ -3888,6 +3890,8 @@ MPEG-2, MPEG-4, DVD (VOB)...
> ("libtool" ,libtool)
> ("pkg-config" ,pkg-config)
> ("zlib" ,zlib)
> + ("curl" ,curl) ;; In Requires.private of libmediainfo pkg-config files.
> + ("tinyxml2" ,tinyxml2)

Shouldn’t we also remove them from ‘native-inputs’, which looks bogus
anyway?

Thanks,
Ludo’.
L
L
Ludovic Courtès wrote on 6 Jun 2021 15:17
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 48194@debbugs.gnu.org)
875yyrku96.fsf_-_@gnu.org
Ping! :-)

Ludovic Courtès <ludo@gnu.org> skribis:

Toggle quote (40 lines)
> Michael Rohleder <mike@rohleder.de> skribis:
>
>>>>From 6612d1189263cc4670b820e26f5e75d4df9c68b0 Mon Sep 17 00:00:00 2001
>> From: Michael Rohleder <mike@rohleder.de>
>> Date: Tue, 11 May 2021 14:05:13 +0200
>> Subject: [PATCH] gnu: mediainfo: Fix usage of libcurl and tinyxml2.
>>
>> * gnu/packages/video.scm (mediainfo): Fix usage of libcurl and tinyxml2.
>
> Please mention [arguments] and [propagated-inputs].
>
>
>> gnu/packages/video.scm | 4 ++++
>> 1 file changed, 4 insertions(+)
>>
>> diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
>> index 481ab46b6e..630edf49b6 100644
>> --- a/gnu/packages/video.scm
>> +++ b/gnu/packages/video.scm
>> @@ -3834,6 +3834,8 @@ practically any type of media.")
>> (build-system gnu-build-system)
>> (arguments
>> '(#:tests? #f ; see above TODO
>> + #:configure-flags
>> + (list "--with-libcurl" "--with-libtinyxml2")
>> #:phases
>> ;; build scripts not in root of archive
>> (modify-phases %standard-phases
>> @@ -3888,6 +3890,8 @@ MPEG-2, MPEG-4, DVD (VOB)...
>> ("libtool" ,libtool)
>> ("pkg-config" ,pkg-config)
>> ("zlib" ,zlib)
>> + ("curl" ,curl) ;; In Requires.private of libmediainfo pkg-config files.
>> + ("tinyxml2" ,tinyxml2)
>
> Shouldn’t we also remove them from ‘native-inputs’, which looks bogus
> anyway?
>
> Thanks,
> Ludo’.
M
M
Michael Rohleder wrote on 9 Jun 2021 08:27
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 48194@debbugs.gnu.org)
87im2n7dsn.fsf@rohleder.de
Hey Ludo!

Thanks for the ping and sorry for the delay!

I hope, this patch is better/pushable ;)
Toggle quote (1 lines)
>From 7e998af5b498388e5ffcf2491c6c934bf49b5c98 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Wed, 9 Jun 2021 08:12:40 +0200
Subject: [PATCH] gnu: libmediainfo: Fix usage of libcurl and libtinyxml2.

* gnu/packages/video.scm (libmediainfo): Fix usage of libcurl and libtinyxml2.
[arguments]: Add configure-flags.
[native-inputs]: Move zlib, tinyxml2, curl, libzen to ...
[propagated-inputs]: ... Here.
(mediainfo):
[native-inputs]: Remove zlib, libzen. Move libmediainfo to ...
[inputs]: ... Here.
---
gnu/packages/video.scm | 16 +++++++++-------
1 file changed, 9 insertions(+), 7 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index a694d4bb43..5c028016cf 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3850,14 +3850,17 @@ practically any type of media.")
`(("autoconf" ,autoconf)
("automake" ,automake)
("libtool" ,libtool)
- ("pkg-config" ,pkg-config)
- ("zlib" ,zlib)
+ ("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("zlib" ,zlib)
("tinyxml2" ,tinyxml2)
- ("curl" ,curl)
+ ("curl" ,curl) ; In Requires.private of libmediainfo.pc.
("libzen" ,libzen)))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; see above TODO
+ #:configure-flags
+ (list "--with-libcurl" "--with-libtinyxml2")
#:phases
;; build scripts not in root of archive
(modify-phases %standard-phases
@@ -3910,10 +3913,9 @@ MPEG-2, MPEG-4, DVD (VOB)...
`(("autoconf" ,autoconf)
("automake" ,automake)
("libtool" ,libtool)
- ("pkg-config" ,pkg-config)
- ("zlib" ,zlib)
- ("libmediainfo" ,libmediainfo)
- ("libzen" ,libzen)))
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libmediainfo" ,libmediainfo)))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; lacks tests
--
2.32.0
--
I've finally learned what "upward compatible" means. It means we get to
keep all our old mistakes. Dennie van Tassel
-----BEGIN PGP SIGNATURE-----

iQFFBAEBCAAvFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAmDAX2gRHG1pa2VAcm9o
bGVkZXIuZGUACgkQfHr/vv7yyyWd+gf9EcLLVzfyG/DQ0iBFJEm+1ZW/if9kqya3
g32GLex3IwM9wj6Uc5hH4ZlqRGbadJ7tflwaThlL0e1ESFBF4vG2IIpQx79+1D+Y
fXjx/4Zt9NpiIF5VqLtpL90EeV4FEJQYveGOXaKWOsULHkmRGA9bQF4vaXCDgI7s
9JRXl88uVFzJafSytDJWz56pcjMV9rOygu3pUmBpYkvfA4GC40/Xse46iVIFLJQI
mjJOQ3PPeigxEwZL7z9Z1Yg9iGrj1f3LkoTBrkD1XhzfmRvabsG6cKyhdze4g3tK
xveNj/IWfOxQ+JKj1MQgvpU2TR7zXK8V98TCizh8EzeM/pgm77fE/A==
=krOg
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 12 Jun 2021 00:40
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 48194-done@debbugs.gnu.org)
87k0n03u0q.fsf@gnu.org
Hi,

Michael Rohleder <mike@rohleder.de> skribis:

Toggle quote (13 lines)
>>From 7e998af5b498388e5ffcf2491c6c934bf49b5c98 Mon Sep 17 00:00:00 2001
> From: Michael Rohleder <mike@rohleder.de>
> Date: Wed, 9 Jun 2021 08:12:40 +0200
> Subject: [PATCH] gnu: libmediainfo: Fix usage of libcurl and libtinyxml2.
>
> * gnu/packages/video.scm (libmediainfo): Fix usage of libcurl and libtinyxml2.
> [arguments]: Add configure-flags.
> [native-inputs]: Move zlib, tinyxml2, curl, libzen to ...
> [propagated-inputs]: ... Here.
> (mediainfo):
> [native-inputs]: Remove zlib, libzen. Move libmediainfo to ...
> [inputs]: ... Here.

Applied, thanks!

Ludo’.
Closed
?