[PATCH] gnu: emacs-rime: Adjust to changes in emacs-build-system.

  • Done
  • quality assurance status badge
Details
4 participants
  • Z572
  • Leo Prikler
  • Liliana Marie Prikler
  • luhui
Owner
unassigned
Submitted by
luhui
Severity
normal
L
L
luhui wrote on 3 May 2021 15:43
(address . guix-patches@gnu.org)
YI/+DhCQmYG/DMnv@thinkpad-x230-luhui
Because of the update of emacs-build-system it cannot run correctly, fix it.
From 10b339344ac01724a19d8efa137425f4eba83cad Mon Sep 17 00:00:00 2001
From: luhui <luhuins@163.com>
Date: Mon, 3 May 2021 20:22:43 +0800
Subject: [PATCH] gnu: emacs-rime: Adjust to changes in emacs-build-system.

* gnu/packages/emacs-xyz.scm (emacs-rime):
[#:phases]: add patch-rime-module-path, change install-emacs-module
---
gnu/packages/emacs-xyz.scm | 10 +++++++++-
1 file changed, 9 insertions(+), 1 deletion(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index dbeab25b39..9afe343a14 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -97,6 +97,7 @@
;;; Copyright � 2021 Stefan Reich�r <stefan@xsteve.at>
;;; Copyright � 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright � 2021 Eugene Klimov <lipklim@mailbox.org>
+;;; Copyright � 2021 lu hui <luhuins@163.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25706,6 +25707,13 @@ REPL appropriate to the current major mode.")
(arguments
'(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-rime-module-path
+ (lambda* (#:key outputs #:allow-other-keys)
+ (make-file-writable "rime.el")
+ (emacs-substitute-variables "rime.el"
+ ("rime--module-path"
+ (string-append (assoc-ref outputs "out") "/lib/librime-emacs.so")))
+ #t))
(add-after 'unpack 'patch-rime-data-path
(lambda* (#:key inputs #:allow-other-keys)
(make-file-writable "rime.el")
@@ -25721,7 +25729,7 @@ REPL appropriate to the current major mode.")
(lambda* (#:key outputs #:allow-other-keys)
(install-file "librime-emacs.so"
(string-append (assoc-ref outputs "out")
- "/share/emacs/site-lisp"))
+ "/lib/"))
#t)))))
(inputs
`(("librime" ,librime)
--
2.31.1
Z
(name . luhui)(address . luhuins@163.com)(address . 48186@debbugs.gnu.org)
tencent_5B48E7A97CB924B9166FD329B5364BF9EF05@qq.com
I think #:include is better.
From 3e4c22f82ad038e89de866198dccc7e793d185b6 Mon Sep 17 00:00:00 2001
From: Zheng junjie <873216071@qq.com>
Date: Tue, 11 May 2021 23:44:44 +0800
Subject: [PATCH] gnu: emacs-rime: Adjust to changes in emacs-build-system.

* gnu/packages/emacs-xyz.scm (emacs-rime):[arguments]: Use #:include rather
than #:phases to add librime-emacs.so.
---
gnu/packages/emacs-xyz.scm | 12 ++++--------
1 file changed, 4 insertions(+), 8 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index fc4c03965e..ff90c6bd3a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -97,6 +97,7 @@
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2021 Eugene Klimov <lipklim@mailbox.org>
+;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25720,7 +25721,8 @@ REPL appropriate to the current major mode.")
(base32 "1a50cziwg7lpgh26yvwxs46jfyfq1m0l6igbg5g5m288mz4d3an9"))))
(build-system emacs-build-system)
(arguments
- '(#:phases
+ '(#:include (cons "\\.so$" %default-include)
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-rime-data-path
(lambda* (#:key inputs #:allow-other-keys)
@@ -25732,13 +25734,7 @@ REPL appropriate to the current major mode.")
#t))
(add-before 'install 'build-emacs-module
(lambda _
- (invoke "make" "lib")))
- (add-after 'install 'install-emacs-module
- (lambda* (#:key outputs #:allow-other-keys)
- (install-file "librime-emacs.so"
- (string-append (assoc-ref outputs "out")
- "/share/emacs/site-lisp"))
- #t)))))
+ (invoke "make" "lib"))))))
(inputs
`(("librime" ,librime)
("rime-data" ,rime-data)))
--
2.31.1
--
over
L
L
Leo Prikler wrote on 11 May 2021 19:32
(address . 48186@debbugs.gnu.org)
46b5921a9577cba24f40f5b76dd9c08eb8360d9c.camel@student.tugraz.at
Am Mittwoch, den 12.05.2021, 00:16 +0800 schrieb Z572:
Toggle quote (1 lines)
> I think #:include is better.
So do I. Pushed as bb29c2657281dd2bc76c2fdb643bff4f3e4caed4.
Thanks.
L
L
Liliana Marie Prikler wrote on 1 Dec 2021 18:50
(address . control@debbugs.gnu.org)
a376a7bd5e82bf5d7d11d71a5a9fa7d0ed843805.camel@gmail.com
close 48186
thanks
?