Simon Josefsson wrote 4 years ago
(address . guix-patches@gnu.org)
Hi! I'm trying to make the OATH Toolkit recipe for Guix build the PSKC
parts. Unfortunately I realized that the GnuTLS backend of xmlsec is
lacking some functionality that is required [1] [2], and that linking
against xmlsec-openssl solves this. However, Guix doesn't have
xmlsec-openssl, so this patch is necessary before I can suggest a patch
for PSKC support in OATH Toolkit for Guix.
/Simon
From a6e17a786497881f1eb8b9cff2fafba8034790db Mon Sep 17 00:00:00 2001
From: Simon Josefsson <simon@josefsson.org>
Date: Mon, 3 May 2021 13:49:33 +0200
Subject: [PATCH] gnu: Add xmlsec-openssl.
* gnu/packages/xml.scm (xmlsec-openssl): New variable.
---
gnu/packages/xml.scm | 8 ++++++++
1 file changed, 8 insertions(+)
Toggle diff (21 lines)
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 04cb09779b..931698a575 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1253,6 +1253,14 @@ Libxml2).")
'(#:configure-flags '("--disable-md5")))
(synopsis "XML Security Library (using NSS instead of GnuTLS)")))
+(define-public xmlsec-openssl
+ (package/inherit xmlsec
+ (name "xmlsec-openssl")
+ (inputs
+ `(("openssl" ,openssl)
+ ("libltdl" ,libltdl)))
+ (synopsis "XML Security Library (using OpenSSL instead of GnuTLS)")))
+
(define-public minixml
(package
(name "minixml")
--
2.20.1
-----BEGIN PGP SIGNATURE-----
iHUEARYIAB0WIQSjzJyHC50xCrrUzy9RcisI/kdFogUCYI/lEwAKCRBRcisI/kdF
ovUfAPoD60hVwE7yLmRosIh0bNZYPitFNOCDj+xt7Y2SBr0bGAEAkolF8WtuwUTC
IkznLi7QsyxPEzfjDwdnR9e67fryVAo=
=X6aG
-----END PGP SIGNATURE-----