[PATCH] gnu: Add xmlsec-openssl.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Simon Josefsson
Owner
unassigned
Submitted by
Simon Josefsson
Severity
normal

Debbugs page

Simon Josefsson wrote 4 years ago
(address . guix-patches@gnu.org)
87fsz4uj1o.fsf@latte.josefsson.org
Hi! I'm trying to make the OATH Toolkit recipe for Guix build the PSKC
parts. Unfortunately I realized that the GnuTLS backend of xmlsec is
lacking some functionality that is required [1] [2], and that linking
against xmlsec-openssl solves this. However, Guix doesn't have
xmlsec-openssl, so this patch is necessary before I can suggest a patch
for PSKC support in OATH Toolkit for Guix.

/Simon
From a6e17a786497881f1eb8b9cff2fafba8034790db Mon Sep 17 00:00:00 2001
From: Simon Josefsson <simon@josefsson.org>
Date: Mon, 3 May 2021 13:49:33 +0200
Subject: [PATCH] gnu: Add xmlsec-openssl.

* gnu/packages/xml.scm (xmlsec-openssl): New variable.
---
gnu/packages/xml.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (21 lines)
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 04cb09779b..931698a575 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1253,6 +1253,14 @@ Libxml2).")
'(#:configure-flags '("--disable-md5")))
(synopsis "XML Security Library (using NSS instead of GnuTLS)")))
+(define-public xmlsec-openssl
+ (package/inherit xmlsec
+ (name "xmlsec-openssl")
+ (inputs
+ `(("openssl" ,openssl)
+ ("libltdl" ,libltdl)))
+ (synopsis "XML Security Library (using OpenSSL instead of GnuTLS)")))
+
(define-public minixml
(package
(name "minixml")
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iHUEARYIAB0WIQSjzJyHC50xCrrUzy9RcisI/kdFogUCYI/lEwAKCRBRcisI/kdF
ovUfAPoD60hVwE7yLmRosIh0bNZYPitFNOCDj+xt7Y2SBr0bGAEAkolF8WtuwUTC
IkznLi7QsyxPEzfjDwdnR9e67fryVAo=
=X6aG
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 4 years ago
(name . Simon Josefsson)(address . simon@josefsson.org)(address . 48185-done@debbugs.gnu.org)
87mtt9johr.fsf@gnu.org
Hi Simon,

Simon Josefsson <simon@josefsson.org> skribis:

Toggle quote (7 lines)
> From a6e17a786497881f1eb8b9cff2fafba8034790db Mon Sep 17 00:00:00 2001
> From: Simon Josefsson <simon@josefsson.org>
> Date: Mon, 3 May 2021 13:49:33 +0200
> Subject: [PATCH] gnu: Add xmlsec-openssl.
>
> * gnu/packages/xml.scm (xmlsec-openssl): New variable.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48185@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48185
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help