Dont stop the upgrade process - Better guix handling when Package failed to build

  • Open
  • quality assurance status badge
Details
4 participants
  • bo0od
  • Julien Lepiller
  • Leo Famulari
  • Ludovic Courtès
Owner
unassigned
Submitted by
bo0od
Severity
normal
B
B
bo0od wrote on 2 May 2021 22:29
(address . bug-guix@gnu.org)
e995e8fc-73cd-f1a2-ad09-d6ea043f61fa@riseup.net
Hi There,

Guix distro is a rolling distro, Packages almost hourly/daily get upgraded.

This is nice but it wont go through without errors due to many factors.

Current situation when there is an error and package failed to build
guix will stop upgrading all the upgrade process e.g:

If you have package x and y in your system

guix upgrade (or guix upgrade x y)

and there is error in x

guix will stop the upgrade process for y as well, even though y package
has no problems with its upgrade.

Current (manual) solution is:

guix package --upgrade . --do-not-upgrade x

Why this is not useful:

- Straight forward bad usability for end user

- Average/New user want guix upgrade to work at 100% percent whenever
possible, Since there is an error possibility then it should work at 90%
or so (depending on how many packages having errors). Current situation
by default either all build fine then upgrade or one error then no
upgrade, Which is below good expectation.

- If user just kept waiting for an upstream/package maintainer fixation
(without reporting the issue or communicate with the support, and i
would expect that from average users) which will take several days if
not more y package will be kept on an outdated stage and this give
security issues as well (because upgrades are not just new features or
fixing bugs many of the upgrades contain fixes for critical security
issues)

Real Example:


Caused to stop the upgrade process for all of guix users (at least who
had icedove installed) and no automatic solutions except the manual one.


Solution:

guix upgrade x y

x contain error cant be upgraded

skip building it due to meow error message

upgrading y from 1.0 to 2.0

upgrade successful without x package couldnt be built due to meow error
message

This will insure all the packages on the distro going to be upgraded
except the one which contain error/couldnt successfully upgraded.


------------------

Faster(?) workaround for current situation:

Note: This is just faster to implement but not better than the previous
solution.


Current error message is:



Better as well to add something like:

Use guix package --upgrade . --do-not-upgrade PackageNameWithError to
build other packages seccessfully.

(Or any better wording message).

ThX!
L
L
Leo Famulari wrote on 2 May 2021 22:55
(name . bo0od)(address . bo0od@riseup.net)(address . 48166@debbugs.gnu.org)
YI8R2C/i+QRKfGI+@jasmine.lan
On Sun, May 02, 2021 at 08:29:31PM +0000, bo0od wrote:
Toggle quote (4 lines)
> Current (manual) solution is:
>
> guix package --upgrade . --do-not-upgrade x

I think you can use `guix package --upgrade . --keep-going`:


--keep-going
-k

Keep going when some of the derivations fail to build; return only once all the builds have either completed or failed.

The default behavior is to stop as soon as one of the specified derivations has failed.
B
B
bo0od wrote on 3 May 2021 03:00
(name . Leo Famulari)(address . leo@famulari.name)(address . 48166@debbugs.gnu.org)
e0b306c2-82bb-438f-cb30-3f9e064e2d96@riseup.net
Toggle quote (2 lines)
> I think you can use `guix package --upgrade . --keep-going`:

Thank you for the hint, sorry i didnt know this command exist.

Currently i cant test this because i dont have a package which has an
error in the building (previous icedove bug should be fixed) to see how
this is going to go.

- First question:

Why this is not default? and what not default should be:

--stop-at-error or --dont-proceed-error ..(or whatever)

- Second question:

Does it show the error at the end or during the upgrade or both (same as
my example before)? So user is aware that one or more of his packages
didnt upgraded.

- If second question is yes then that command can replace
--do-not-upgrade in my previous workaround faster implementation but not
ultimate.




Leo Famulari:
Toggle quote (16 lines)
> On Sun, May 02, 2021 at 08:29:31PM +0000, bo0od wrote:
>> Current (manual) solution is:
>>
>> guix package --upgrade . --do-not-upgrade x
>
> I think you can use `guix package --upgrade . --keep-going`:
>
> https://guix.gnu.org/manual/devel/en/html_node/Common-Build-Options.html
>
> --keep-going
> -k
>
> Keep going when some of the derivations fail to build; return only once all the builds have either completed or failed.
>
> The default behavior is to stop as soon as one of the specified derivations has failed.
>
J
J
Julien Lepiller wrote on 3 May 2021 03:50
(address . 48166@debbugs.gnu.org)
3C1DFBAD-68E9-4B7C-9610-222DAFF8A745@lepiller.eu
I don't think --keep-going works as you expect it to. When you do guix upgrade, guix creates a derivation for your new profile and proceeds to build it. If it has dependents that need to be built (packages that were updated), it builds them as they are needed to build the new profile.

If one of them fails, guix fails early by default. --keep-going will, well, keep going and guix will build the rest of the dependents that are independent from that failure.

However, it will eventually fail (late) when it tries to finally build the derivation for the new derivation: itqdepends on other derivations that already failed. Not sure how it reports the failures, but it might be easier to list all the failures in one try, and apply your workaround.

To do what you want (create a new generations ignoring failures) is not easy to implement. We would have to "change our mind" and build a different derivation for that new profile.

Le 2 mai 2021 21:00:02 GMT-04:00, bo0od <bo0od@riseup.net> a écrit :
Toggle quote (50 lines)
> > I think you can use `guix package --upgrade . --keep-going`:
>
>Thank you for the hint, sorry i didnt know this command exist.
>
>Currently i cant test this because i dont have a package which has an
>error in the building (previous icedove bug should be fixed) to see how
>
>this is going to go.
>
>- First question:
>
>Why this is not default? and what not default should be:
>
>--stop-at-error or --dont-proceed-error ..(or whatever)
>
>- Second question:
>
>Does it show the error at the end or during the upgrade or both (same
>as
>my example before)? So user is aware that one or more of his packages
>didnt upgraded.
>
>- If second question is yes then that command can replace
>--do-not-upgrade in my previous workaround faster implementation but
>not
>ultimate.
>
>
>
>
>Leo Famulari:
>> On Sun, May 02, 2021 at 08:29:31PM +0000, bo0od wrote:
>>> Current (manual) solution is:
>>>
>>> guix package --upgrade . --do-not-upgrade x
>>
>> I think you can use `guix package --upgrade . --keep-going`:
>>
>>
>https://guix.gnu.org/manual/devel/en/html_node/Common-Build-Options.html
>>
>> --keep-going
>> -k
>>
>> Keep going when some of the derivations fail to build; return
>only once all the builds have either completed or failed.
>>
>> The default behavior is to stop as soon as one of the specified
>derivations has failed.
>>
Attachment: file
B
B
bo0od wrote on 3 May 2021 04:25
(address . 48166@debbugs.gnu.org)
7613d55a-d145-1dc7-a64a-1a17d95ed484@riseup.net
Toggle quote (2 lines)
> To do what you want (create a new generations ignoring failures) is not easy to implement. We would have to "change our mind" and build a different derivation for that new profile.

I hope to do so, For better guix usability future.
L
L
Ludovic Courtès wrote on 4 May 2021 21:57
(name . Julien Lepiller)(address . julien@lepiller.eu)
87zgxal1aa.fsf@gnu.org
Hi,

Julien Lepiller <julien@lepiller.eu> skribis:

Toggle quote (2 lines)
> To do what you want (create a new generations ignoring failures) is not easy to implement. We would have to "change our mind" and build a different derivation for that new profile.

It’s also not desirable IMO: the way Guix operates is that either it
succeeds the operation you asked for, or it fails, but it never “changes
its mind” in the middle.

Instead, I think what would improve usability would be to notify the
user upfront when a package is known to fail to build. The build farm
could state that when it replies to narinfo requests, and ‘guix’
commands would print a warning or even stop upfront by default.

Thanks,
Ludo’.
?