[PATCH] gnu: Add castget.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Stefan Reichör
Owner
unassigned
Submitted by
Stefan Reichör
Severity
normal
S
S
Stefan Reichör wrote on 2 May 2021 17:12
(address . guix-patches@gnu.org)(name . Stefan Reichör)(address . stefan@xsteve.at)
20210502151227.385012-1-stefan@xsteve.at
* gnu/packages/gpodder.scm (castget): New variable.
---
gnu/packages/gpodder.scm | 43 +++++++++++++++++++++++++++++++++++++++-
1 file changed, 42 insertions(+), 1 deletion(-)

Toggle diff (80 lines)
diff --git a/gnu/packages/gpodder.scm b/gnu/packages/gpodder.scm
index f185f2e546..a22a2b41cd 100644
--- a/gnu/packages/gpodder.scm
+++ b/gnu/packages/gpodder.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019, 2020, 2021 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,20 +22,27 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix packages)
+ #:use-module (guix utils)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages check)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages groff)
+ #:use-module (gnu packages mp3)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
- #:use-module (gnu packages video))
+ #:use-module (gnu packages video)
+ #:use-module (gnu packages xml))
(define-public gpodder
(package
@@ -203,3 +211,36 @@ downloading episode status changes.")
provide an easy and reliable way of parsing RSS and Atom-based podcast feeds
in Python.")
(license license:isc)))
+
+(define-public castget
+ (package
+ (name "castget")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mlj/castget")
+ (commit (string-append "rel_" (string-replace-substring
+ version "." "_")))))
+ (sha256
+ (base32 "1129x64rw587q3sdpa3lrgs0gni5f0siwbvmfz8ya4zkbhgi2ik7"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("ronn-ng" ,ronn-ng)))
+ (inputs `(("curl" ,curl)
+ ("glib" ,glib)
+ ("id3lib" ,id3lib)
+ ("libxml2" ,libxml2)))
+ (synopsis "Command line podcast downloader")
+ (description
+ "castget is a simple, command-line based RSS enclosure downloader. It is
+primarily intended for automatic, unattended downloading of podcasts. It uses
+libcurl for the download process.")
+ (license license:gpl2)
+ (home-page "https://castget.johndal.com")))
--
2.25.1
L
L
Ludovic Courtès wrote on 5 May 2021 15:36
(name . Stefan Reichör)(address . stefan@xsteve.at)(address . 48161-done@debbugs.gnu.org)
87im3xjo9t.fsf@gnu.org
Hi Stefan,

Stefan Reichör <stefan@xsteve.at> skribis:

Toggle quote (2 lines)
> * gnu/packages/gpodder.scm (castget): New variable.

Applied with the change below: according to source file headers, this code
is under LGPL 2.1 “or any later version”.

Thanks,
Ludo’.
Toggle diff (11 lines)
diff --git a/gnu/packages/gpodder.scm b/gnu/packages/gpodder.scm
index a22a2b41cd..677ec3f33e 100644
--- a/gnu/packages/gpodder.scm
+++ b/gnu/packages/gpodder.scm
@@ -242,5 +242,5 @@ in Python.")
"castget is a simple, command-line based RSS enclosure downloader. It is
primarily intended for automatic, unattended downloading of podcasts. It uses
libcurl for the download process.")
- (license license:gpl2)
+ (license license:lgpl2.1+)
(home-page "https://castget.johndal.com")))
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48161@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48161
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch