(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
* gnu/packages/games.scm (xboard): Patch path to aplay.
[inputs]: Add alsa-utils.
[arguments]: Add phase patch-aplay-path.
---
gnu/packages/games.scm | 13 ++++++++++++-
1 file changed, 12 insertions(+), 1 deletion(-)
Toggle diff (27 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3227b3e6fc..8bd3c95ebb 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3323,8 +3323,19 @@ exec ~a/bin/freedink -refdir ~a/share/dink\n"
(base32
"1mkh36xnnacnz9r00b5f9ld9309k32jv6mcavklbdnca8bl56bib"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Fixes https://issues.guix.gnu.org/47195.
+ (add-after 'unpack 'patch-aplay-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "xboard.conf"
+ (("aplay -q")
+ (string-append (assoc-ref inputs "alsa-utils") "/bin/aplay -q")))
+ #t)))))
(inputs
- `(("gtk+" ,gtk+-2)
+ `(("alsa-utils" ,alsa-utils)
+ ("gtk+" ,gtk+-2)
("librsvg" ,librsvg)))
(native-inputs
`(("texinfo" ,texinfo)
--
2.31.1