[PATCH] gnu: xboard: Patch path to aplay.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal
M
M
Michael Rohleder wrote on 2 May 2021 13:46
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20210502114620.4133-1-mike@rohleder.de

* gnu/packages/games.scm (xboard): Patch path to aplay.
[inputs]: Add alsa-utils.
[arguments]: Add phase patch-aplay-path.
---
gnu/packages/games.scm | 13 ++++++++++++-
1 file changed, 12 insertions(+), 1 deletion(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3227b3e6fc..8bd3c95ebb 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3323,8 +3323,19 @@ exec ~a/bin/freedink -refdir ~a/share/dink\n"
(base32
"1mkh36xnnacnz9r00b5f9ld9309k32jv6mcavklbdnca8bl56bib"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Fixes https://issues.guix.gnu.org/47195.
+ (add-after 'unpack 'patch-aplay-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "xboard.conf"
+ (("aplay -q")
+ (string-append (assoc-ref inputs "alsa-utils") "/bin/aplay -q")))
+ #t)))))
(inputs
- `(("gtk+" ,gtk+-2)
+ `(("alsa-utils" ,alsa-utils)
+ ("gtk+" ,gtk+-2)
("librsvg" ,librsvg)))
(native-inputs
`(("texinfo" ,texinfo)
--
2.31.1
L
L
Ludovic Courtès wrote on 3 May 2021 18:02
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 48158-done@debbugs.gnu.org)
87lf8vyfdg.fsf@gnu.org
Hi,

Michael Rohleder <mike@rohleder.de> skribis:

Toggle quote (6 lines)
>
> * gnu/packages/games.scm (xboard): Patch path to aplay.
> [inputs]: Add alsa-utils.
> [arguments]: Add phase patch-aplay-path.

Applied, thanks!

Incidentally, the following still breaks on the first move:

$ guix environment --ad-hoc xboard -- xboard
[…]
xboard: Error writing to first chess program: Broken pipe

At first sight the reason may be that it doesn’t find ‘fairymax’ (what’s
that?) in $PATH. I’m sure I’m missing something obvious, but I wonder
if we could make it work out of the box.

Thoughts?

Ludo’.
Closed
M
M
Michael Rohleder wrote on 3 May 2021 18:13
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 48158@debbugs.gnu.org)
87bl9rx0b7.fsf@rohleder.de
Hi Ludo,

Thank you for reviewing!

Ludovic Courtès <ludo@gnu.org> writes:
Toggle quote (13 lines)
> Incidentally, the following still breaks on the first move:
>
> $ guix environment --ad-hoc xboard -- xboard
> […]
> xboard: Error writing to first chess program: Broken pipe
>
> At first sight the reason may be that it doesn’t find ‘fairymax’ (what’s
> that?) in $PATH. I’m sure I’m missing something obvious, but I wonder
> if we could make it work out of the box.
>
> Thoughts?
>


fairymax is a (simple) chessengine.

I plan to fix this issue (also via the xboard.conf), so that gnuchess
gets the default configured engine, after this one here is merged...

--
Wenn Du denkst, Abenteuer sind gefährlich, dann versuch´s doch mal mit Routine.
Die ist tödlich. - Paulo Coelho
-----BEGIN PGP SIGNATURE-----

iQFFBAEBCAAvFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAmCQISwRHG1pa2VAcm9o
bGVkZXIuZGUACgkQfHr/vv7yyyVapwf9EpofxchLXXBMOqdGdmo43gLdRnMjn5/A
ex5DlHqqKq5nNqast5bFn2JFeDE30PSmRjdyAZ22MHsb0ziCfnJQsT8Wqvbf8mEf
yvn9k128piKrMJqAuVnpKJ58WbjQRXZb5tN7Lj2dX++DoJL4C2YUGd5xddtIq8VS
J1GsFwiPRLS2YaXOLEdmoLwnOa8Akmiy76gmbgwFF/PB64dqvykDIe+Etu38+OAs
fFcu7CfViEcVjwmTpMnKgV9w5h6UyxR/021sIFmul6ZUfjB7+BiZoK2PCcoLVolv
N33Dl904ZNIxaSBGfFJDapJtASX4llzDMZIyzIqhQMcGWhpj36oBOg==
=7Br8
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 48158@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48158
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch