no code for module (json) on guix upgrade

  • Done
  • quality assurance status badge
Details
4 participants
  • Leo Prikler
  • Nathan Dehnel
  • Mathieu Othacehe
  • Timothy Sample
Owner
unassigned
Submitted by
Nathan Dehnel
Severity
normal
Merged with
N
N
Nathan Dehnel wrote on 2 May 2021 04:17
(name . Tobias Geerinckx-Rice via Bug reports for GNU Guix)(address . bug-guix@gnu.org)
CAEEhgEsdrXRihwwtO6Tn2K4g_Bv2hVDFYp+ijepezXsgOVES-w@mail.gmail.com
bzip2 -dkc
/var/log/guix/drvs/00/1p94i7q8kks3pngjah0b2v4fzl3npr-module-import-compiled.drv.bz2
[ 1/26] Loading './guix/base16.scm'...
[ 2/26] Loading './guix/base64.scm'...
[ 3/26] Loading './guix/build/download-nar.scm'...
[ 4/26] Loading './guix/build/download.scm'...
[ 5/26] Loading './guix/build/hg.scm'...
[ 6/26] Loading './guix/build/syscalls.scm'...
[ 7/26] Loading './guix/build/utils.scm'...
[ 8/26] Loading './guix/combinators.scm'...
[ 9/26] Loading './guix/ftp-client.scm'...
[10/26] Loading './guix/progress.scm'...
[11/26] Loading './guix/records.scm'...
[12/26] Loading './guix/serialization.scm'...
[13/26] Loading './guix/swh.scm'...
;;; Failed to autoload swh-download-directory in (guix swh):
;;; no code for module (json)
Backtrace:
In srfi/srfi-1.scm:
460:18 19 (fold #<procedure 7ffff4c778e0 at ice-9/eval.scm:336:1?> ?)
In ice-9/eval.scm:
619:8 18 (_ #(#(#<directory (guix build utils) 7ffff5194d20>) # ?))
In ice-9/boot-9.scm:
2806:4 17 (save-module-excursion #<procedure 7ffff49dc6e0 at ice-?>)
In unknown file:
16 (primitive-load "./guix/swh.scm")
In ice-9/eval.scm:
721:20 15 (primitive-eval (define-module (guix swh) #:use-module ?))
In ice-9/psyntax.scm:
1241:36 14 (expand-top-sequence ((define-module (guix swh) # # ?)) ?)
1233:19 13 (parse _ (("placeholder" placeholder)) ((top) #(# # ?)) ?)
285:10 12 (parse _ (("placeholder" placeholder)) (()) _ c&e (eval) ?)
In ice-9/eval.scm:
293:34 11 (_ #<directory (guix build utils) 7ffff5194d20>)
In ice-9/boot-9.scm:
3380:4 10 (define-module* _ #:filename _ #:pure _ #:version _ # _ ?)
2565:24 9 (call-with-deferred-observers #<procedure 7ffff4c670f0 ?>)
3393:24 8 (_)
222:29 7 (map1 (((guix base16)) ((guix build utils)) ((# ?) ?) ?))
222:29 6 (map1 (((guix build utils)) ((guix build syscalls) ?) ?))
222:29 5 (map1 (((guix build syscalls) #:select (mkdtemp!)) (#) ?))
222:29 4 (map1 (((web uri)) ((web client)) ((web response)) (#) ?))
222:29 3 (map1 (((web client)) ((web response)) ((json)) ((?)) ?))
222:29 2 (map1 (((web response)) ((json)) ((srfi srfi-1)) ((?)) ?))
222:17 1 (map1 (((json)) ((srfi srfi-1)) ((srfi srfi-9)) ((?)) ?))
3300:6 0 (resolve-interface (json) #:select _ #:hide _ #:prefix _ ?)

ice-9/boot-9.scm:3300:6: In procedure resolve-interface:
no code for module (json)
Attachment: file
L
L
Leo Prikler wrote on 2 May 2021 18:04
(address . samplet@ngyro.com)
3875f012f8d28d04042c08e7c9c9ec727051e982.camel@student.tugraz.at
Am Samstag, den 01.05.2021, 21:17 -0500 schrieb Nathan Dehnel:
Toggle quote (66 lines)
> bzip2 -dkc /var/log/guix/drvs/00/1p94i7q8kks3pngjah0b2v4fzl3npr-
> module-import-compiled.drv.bz2
> [ 1/26] Loading './guix/base16.scm'...
> [ 2/26] Loading './guix/base64.scm'...
> [ 3/26] Loading './guix/build/download-nar.scm'...
> [ 4/26] Loading './guix/build/download.scm'...
> [ 5/26] Loading './guix/build/hg.scm'...
> [ 6/26] Loading './guix/build/syscalls.scm'...
> [ 7/26] Loading './guix/build/utils.scm'...
> [ 8/26] Loading './guix/combinators.scm'...
> [ 9/26] Loading './guix/ftp-client.scm'...
> [10/26] Loading './guix/progress.scm'...
> [11/26] Loading './guix/records.scm'...
> [12/26] Loading './guix/serialization.scm'...
> [13/26] Loading './guix/swh.scm'...
> ;;; Failed to autoload swh-download-directory in (guix swh):
> ;;; no code for module (json)
> Backtrace:
> In srfi/srfi-1.scm:
> 460:18 19 (fold #<procedure 7ffff4c778e0 at ice-9/eval.scm:336:1?>
> ?)
> In ice-9/eval.scm:
> 619:8 18 (_ #(#(#<directory (guix build utils) 7ffff5194d20>) #
> ?))
> In ice-9/boot-9.scm:
> 2806:4 17 (save-module-excursion #<procedure 7ffff49dc6e0 at ice-
> ?>)
> In unknown file:
> 16 (primitive-load "./guix/swh.scm")
> In ice-9/eval.scm:
> 721:20 15 (primitive-eval (define-module (guix swh) #:use-module
> ?))
> In ice-9/psyntax.scm:
> 1241:36 14 (expand-top-sequence ((define-module (guix swh) # # ?))
> ?)
> 1233:19 13 (parse _ (("placeholder" placeholder)) ((top) #(# # ?))
> ?)
> 285:10 12 (parse _ (("placeholder" placeholder)) (()) _ c&e (eval)
> ?)
> In ice-9/eval.scm:
> 293:34 11 (_ #<directory (guix build utils) 7ffff5194d20>)
> In ice-9/boot-9.scm:
> 3380:4 10 (define-module* _ #:filename _ #:pure _ #:version _ # _
> ?)
> 2565:24 9 (call-with-deferred-observers #<procedure 7ffff4c670f0
> ?>)
> 3393:24 8 (_)
> 222:29 7 (map1 (((guix base16)) ((guix build utils)) ((# ?) ?)
> ?))
> 222:29 6 (map1 (((guix build utils)) ((guix build syscalls) ?)
> ?))
> 222:29 5 (map1 (((guix build syscalls) #:select (mkdtemp!)) (#)
> ?))
> 222:29 4 (map1 (((web uri)) ((web client)) ((web response)) (#)
> ?))
> 222:29 3 (map1 (((web client)) ((web response)) ((json)) ((?))
> ?))
> 222:29 2 (map1 (((web response)) ((json)) ((srfi srfi-1)) ((?))
> ?))
> 222:17 1 (map1 (((json)) ((srfi srfi-1)) ((srfi srfi-9)) ((?))
> ?))
> 3300:6 0 (resolve-interface (json) #:select _ #:hide _ #:prefix _
> ?)
>
> ice-9/boot-9.scm:3300:6: In procedure resolve-interface:
> no code for module (json)
I found this stops being an issue after reverting
66b14dccdd0d83c875ce3a8d50ceab8b6f0a3ce2.
@Timothy do you know how we can get guile-json in there for SWH?

Regards,
Leo
L
L
Leo Prikler wrote on 2 May 2021 19:02
(address . control@debbugs.gnu.org)
236a269265f463e1073da4e14ae48735a3b7b8b9.camel@student.tugraz.at
merge 48140 48152
thanks
M
M
Mathieu Othacehe wrote on 2 May 2021 19:03
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)
87lf8xjcfd.fsf@gnu.org
Hello,

Toggle quote (4 lines)
> I found this stops being an issue after reverting
> 66b14dccdd0d83c875ce3a8d50ceab8b6f0a3ce2.
> @Timothy do you know how we can get guile-json in there for SWH?

I think this is fixed with d2b5bb5f9de8dc1a51260e17cd91c3039070a7f2 to
fd5527407ff336c4af1c5511e19c0956720cd7aa. Could you please confirm?

Thanks,

Mathieu
L
L
Leo Prikler wrote on 2 May 2021 19:24
(name . Mathieu Othacehe)(address . othacehe@gnu.org)
bc7b79af7185106f62ee4c8874b1bb552f217c01.camel@student.tugraz.at
Am Sonntag, den 02.05.2021, 19:03 +0200 schrieb Mathieu Othacehe:
Toggle quote (13 lines)
> Hello,
>
> > I found this stops being an issue after reverting
> > 66b14dccdd0d83c875ce3a8d50ceab8b6f0a3ce2.
> > @Timothy do you know how we can get guile-json in there for SWH?
>
> I think this is fixed with d2b5bb5f9de8dc1a51260e17cd91c3039070a7f2
> to
> fd5527407ff336c4af1c5511e19c0956720cd7aa. Could you please confirm?
>
> Thanks,
>
> Mathieu
Thanks for your quick work. At least hg-download seems to work and I'm
currently building linux-libre, which relies on regular download. I
also tested git, which probably already had this. Can someone test the
others?
T
T
Timothy Sample wrote on 2 May 2021 20:51
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)
87eeepdl5a.fsf@ngyro.com
Hi Leo,

Thanks for pinging me.

Leo Prikler <leo.prikler@student.tugraz.at> writes:

Toggle quote (16 lines)
> Am Sonntag, den 02.05.2021, 19:03 +0200 schrieb Mathieu Othacehe:
>> Hello,
>>
>> > I found this stops being an issue after reverting
>> > 66b14dccdd0d83c875ce3a8d50ceab8b6f0a3ce2.
>> > @Timothy do you know how we can get guile-json in there for SWH?
>>
>> I think this is fixed with d2b5bb5f9de8dc1a51260e17cd91c3039070a7f2
>> to
>> fd5527407ff336c4af1c5511e19c0956720cd7aa. Could you please confirm?
>>
> Thanks for your quick work. At least hg-download seems to work and I'm
> currently building linux-libre, which relies on regular download. I
> also tested git, which probably already had this. Can someone test the
> others?

I can confirm that ‘cvs-fetch’ and ‘android-repo-fetch’ work, too. The
‘bzr-fetch’ and ‘svn-fetch’ systems do not pull in ‘(guix build
download)’, so they should be fine (and indeed, they work when I test
them).

Thanks Mathieu!


-- Tim
Closed
N
N
Nathan Dehnel wrote on 2 May 2021 23:22
(name . Timothy Sample)(address . samplet@ngyro.com)
CAEEhgEt3motKXUBUtCnBJg_s0MTVqBkU_oLvF4R3JpoA=fY0Ew@mail.gmail.com
It works now for me, thanks.

On Sun, May 2, 2021, 1:51 PM Timothy Sample <samplet@ngyro.com> wrote:

Toggle quote (32 lines)
> Hi Leo,
>
> Thanks for pinging me.
>
> Leo Prikler <leo.prikler@student.tugraz.at> writes:
>
> > Am Sonntag, den 02.05.2021, 19:03 +0200 schrieb Mathieu Othacehe:
> >> Hello,
> >>
> >> > I found this stops being an issue after reverting
> >> > 66b14dccdd0d83c875ce3a8d50ceab8b6f0a3ce2.
> >> > @Timothy do you know how we can get guile-json in there for SWH?
> >>
> >> I think this is fixed with d2b5bb5f9de8dc1a51260e17cd91c3039070a7f2
> >> to
> >> fd5527407ff336c4af1c5511e19c0956720cd7aa. Could you please confirm?
> >>
> > Thanks for your quick work. At least hg-download seems to work and I'm
> > currently building linux-libre, which relies on regular download. I
> > also tested git, which probably already had this. Can someone test the
> > others?
>
> I can confirm that ‘cvs-fetch’ and ‘android-repo-fetch’ work, too. The
> ‘bzr-fetch’ and ‘svn-fetch’ systems do not pull in ‘(guix build
> download)’, so they should be fine (and indeed, they work when I test
> them).
>
> Thanks Mathieu!
>
>
> -- Tim
>
Attachment: file
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48152@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48152
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch