[PATCH] gnu: chessx: Disable online version check by default.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 4 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20210430232900.30324-1-mike@rohleder.de
* gnu/packages/games.scm (chessx)[arguments]: Add phase to disable
the online version check by default.
---
gnu/packages/games.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (19 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3227b3e6fc..4b0f9d74e0 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -11885,6 +11885,12 @@ and chess engines.")
(lambda _
(setenv "QT_RCC_SOURCE_DATE_OVERRIDE" "1")
#t))
+ (add-after 'make-qt-deterministic 'disable-versioncheck
+ (lambda _
+ (substitute* "src/database/settings.cpp"
+ (("\"/General/onlineVersionCheck\", true")
+ "\"/General/onlineVersionCheck\", false"))
+ #t))
(replace 'configure
(lambda _
(invoke "qmake")
--
2.31.1
Ludovic Courtès wrote 4 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 48130-done@debbugs.gnu.org)
878s4vyf42.fsf@gnu.org
Michael Rohleder <mike@rohleder.de> skribis:

Toggle quote (3 lines)
> * gnu/packages/games.scm (chessx)[arguments]: Add phase to disable
> the online version check by default.

Applied, thanks!

Good that you found about this antifeature.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48130@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48130
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help