(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
Hello, Guix!
This patch adds a package definition for Valve Data File (de)seralizer written in Python.
Regards,
pineapples
From 2ee393320515951ce943b961f05a48f46a4a71ef Mon Sep 17 00:00:00 2001
From: pineapples <guixuser6392@protonmail.com>
Date: Fri, 30 Apr 2021 16:01:01 +0200
Subject: [PATCH] gnu: Add python-vdf.
* gnu/packages/python-xyz.scm (python-vdf): New variable
---
gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
Toggle diff (43 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3fbb7b3366..b9b72c1740 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -99,6 +99,7 @@
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Ellis Keny? <me@elken.dev>
;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
+;;; Copyright © 2021 pineapples <guixuser6392@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25152,6 +25153,28 @@ runs on, such as a reliable machine-readable ID, or version information.")
is the cythonized version of @code{fractions.Fraction}.")
(license license:psfl)))
+(define-public python-vdf
+ (package
+ (name "python-vdf")
+ (version "3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "vdf" version))
+ (sha256
+ (base32
+ "1g3pjmsil2mfbagqgkh0kf9is0nsnls4416mq68q7q0fw8f914wi"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-mock" ,python-mock)
+ ("python-nose" ,python-nose)))
+ (home-page "https://github.com/ValvePython/vdf")
+ (synopsis "@acronym{VDF, Valve Data File} (de)serializer")
+ (description "This package provides a Python module for both deserialization
+and serialization to/from VDF that works just like @code{json}.")
+ (license license:expat)))
+
(define-public python-pathvalidate
(package
(name "python-pathvalidate")
--
2.31.1