[PATCH] gnu: Add python-vdf.

  • Open
  • quality assurance status badge
Details
2 participants
  • guixuser6392
  • Leo Famulari
Owner
unassigned
Submitted by
guixuser6392
Severity
normal
G
G
guixuser6392 wrote on 30 Apr 2021 16:51
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
HCEH9VOqxEiVKa_PKikLu0aJihKSda6hwRlDe6Wxdh7Zh1GMIXyr6mwED6VL2DhVbNBAp0pWZJUE1YzH5_16yEH3sPA7xn1NoY_q4YOZKCU=@protonmail.com
Hello, Guix!

This patch adds a package definition for Valve Data File (de)seralizer written in Python.

Regards,
pineapples
From 2ee393320515951ce943b961f05a48f46a4a71ef Mon Sep 17 00:00:00 2001
From: pineapples <guixuser6392@protonmail.com>
Date: Fri, 30 Apr 2021 16:01:01 +0200
Subject: [PATCH] gnu: Add python-vdf.

* gnu/packages/python-xyz.scm (python-vdf): New variable
---
gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3fbb7b3366..b9b72c1740 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -99,6 +99,7 @@
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Ellis Keny? <me@elken.dev>
;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
+;;; Copyright © 2021 pineapples <guixuser6392@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25152,6 +25153,28 @@ runs on, such as a reliable machine-readable ID, or version information.")
is the cythonized version of @code{fractions.Fraction}.")
(license license:psfl)))
+(define-public python-vdf
+ (package
+ (name "python-vdf")
+ (version "3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "vdf" version))
+ (sha256
+ (base32
+ "1g3pjmsil2mfbagqgkh0kf9is0nsnls4416mq68q7q0fw8f914wi"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-mock" ,python-mock)
+ ("python-nose" ,python-nose)))
+ (home-page "https://github.com/ValvePython/vdf")
+ (synopsis "@acronym{VDF, Valve Data File} (de)serializer")
+ (description "This package provides a Python module for both deserialization
+and serialization to/from VDF that works just like @code{json}.")
+ (license license:expat)))
+
(define-public python-pathvalidate
(package
(name "python-pathvalidate")
--
2.31.1
G
G
guixuser6392 wrote on 1 May 2021 15:20
Re: [PATCH] gnu: Add python-vdf
(name . 48122@debbugs.gnu.org)(address . 48122@debbugs.gnu.org)
rDaKaD8BxeV4l1WXdOQ0n8ydJQMx2xf9rJxAp1S8u7QRGzwvykn_37y_i_m-LZhGIbWw6Y_14qILAKOeR31l2xpjoXzvK3oDTGil5wdtAK4=@protonmail.com
I would like to ask patch reviewers and those with commit access to not accept this patch as-is, as I will be migrating to an email-driven git workflow friendly email provider in the upcoming days, and I want the new email address to be used instead.

I will update the patch as soon as the migration is complete.

Regards,
pineapples
L
L
Leo Famulari wrote on 1 May 2021 18:58
Re: [bug#48122] [PATCH] gnu: Add python-vdf
(name . guixuser6392 via Guix-patches via)(address . guix-patches@gnu.org)(name . 48122@debbugs.gnu.org)(address . 48122@debbugs.gnu.org)
YI2Io5dLXjCwIJGu@jasmine.lan
On Sat, May 01, 2021 at 01:20:03PM +0000, guixuser6392 via Guix-patches via wrote:
Toggle quote (4 lines)
> I would like to ask patch reviewers and those with commit access to not accept this patch as-is, as I will be migrating to an email-driven git workflow friendly email provider in the upcoming days, and I want the new email address to be used instead.
>
> I will update the patch as soon as the migration is complete.

Okay. We can use any email address when applying the patch. If you just
tell us what to use, the committer can make it happen.
?