(address . guix-patches@gnu.org)
* gnu/packages/vim.scm (neovim)[native-search-paths]: New field.
---
gnu/packages/vim.scm | 8 ++++++++
1 file changed, 8 insertions(+)
Toggle diff (21 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 5d2beb531b..453a13eabe 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -676,6 +676,14 @@ are detected, the user is notified.")))
(substitute* "cmake/GetCompileFlags.cmake"
(("\\$\\{CMAKE_C_COMPILER\\}") "/gnu/store/.../bin/gcc"))
#t)))))
+ (native-search-paths
+ ;; Neovim searches the nvim/site subdirectory of each XDG_DATA_DIRS entry
+ ;; for plugins and other addons. In nvim see `:help runtimepath`
+ ;; https://neovim.io/doc/user/options.html#'runtimepath'
+ (list (search-path-specification
+ (variable "XDG_DATA_DIRS")
+ (separator ":")
+ (files '("share")))))
(inputs
`(("libuv" ,libuv)
("msgpack" ,msgpack)
--
2.31.1