[PATCH] gnu: neovim: Add 'XDG_DATA_DIRS' search path spec.

  • Open
  • quality assurance status badge
Details
One participant
  • Jack Hill
Owner
unassigned
Submitted by
Jack Hill
Severity
normal
J
J
Jack Hill wrote on 30 Apr 2021 06:39
(address . guix-patches@gnu.org)
20210430043919.17536-1-jackhill@jackhill.us
* gnu/packages/vim.scm (neovim)[native-search-paths]: New field.
---
gnu/packages/vim.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (21 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 5d2beb531b..453a13eabe 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -676,6 +676,14 @@ are detected, the user is notified.")))
(substitute* "cmake/GetCompileFlags.cmake"
(("\\$\\{CMAKE_C_COMPILER\\}") "/gnu/store/.../bin/gcc"))
#t)))))
+ (native-search-paths
+ ;; Neovim searches the nvim/site subdirectory of each XDG_DATA_DIRS entry
+ ;; for plugins and other addons. In nvim see `:help runtimepath`
+ ;; https://neovim.io/doc/user/options.html#'runtimepath'
+ (list (search-path-specification
+ (variable "XDG_DATA_DIRS")
+ (separator ":")
+ (files '("share")))))
(inputs
`(("libuv" ,libuv)
("msgpack" ,msgpack)
--
2.31.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 48112@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48112
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch