[PATCH] gnu: neovim: Use luajit instead of lua.

  • Open
  • quality assurance status badge
Details
One participant
  • Jack Hill
Owner
unassigned
Submitted by
Jack Hill
Severity
normal
Merged with
J
J
Jack Hill wrote on 30 Apr 2021 00:24
(address . guix-patches@gnu.org)
20210429222445.29724-1-jackhill@jackhill.us
* gnu/packages/vim.scm (neovim)[arguments]: Remove non-default
configure-flags.
[inputs]: Use replace lua-5.1 with luajit.
---

Change to luajit discussed on guix-devel:

gnu/packages/vim.scm | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 3b796fa341..678fa74ab9 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -644,7 +644,6 @@ are detected, the user is notified.")))
`(#:modules ((srfi srfi-26)
(guix build cmake-build-system)
(guix build utils))
- #:configure-flags '("-DPREFER_LUA:BOOL=YES")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'set-lua-paths
@@ -685,7 +684,7 @@ are detected, the user is notified.")))
("unibilium" ,unibilium)
("jemalloc" ,jemalloc)
("libiconv" ,libiconv)
- ("lua" ,lua-5.1)
+ ("lua" ,luajit)
("lua-luv" ,lua5.1-luv)
("lua-lpeg" ,lua5.1-lpeg)
("lua-bitop" ,lua5.1-bitop)
--
2.31.1
J
J
Jack Hill wrote on 1 Nov 2021 05:53
neovim and luajit
(address . control@debbugs.gnu.org)
alpine.DEB.2.21.2111010051380.4243@marsh.hcoop.net
reassign 51537 guix-patches
merge 48109 51537

thanks

The only possible problem I see with using luajit is that it may not be
available on all the platforms that Lua 5.1 is. Perhaps this patch could
be conditioned on architecture.

Best,
Jack
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 48109@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48109
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch