[PATCH] gnu: odamex: Update to 0.9.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • David Pflug
  • Ludovic Courtès
Owner
unassigned
Submitted by
David Pflug
Severity
normal

Debbugs page

David Pflug wrote 4 years ago
(address . guix-patches@gnu.org)(name . David Pflug)(address . david@pflug.io)
20210428030630.1503268-1-david@pflug.io
* gnu/packages/games.scm (odamex): Update to 0.9.0.
---
gnu/packages/games.scm | 14 +++++++++-----
1 file changed, 9 insertions(+), 5 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3227b3e..378ea9a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -59,6 +59,7 @@
;;; Copyright © 2021 Olivier Rojon <o.rojon@posteo.net>
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2021 David Pflug <david@pflug.io>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -7472,22 +7473,25 @@ Strife, Chex Quest, and fan-created games like Harmony, Hacx and Freedoom.")
(define-public odamex
(package
(name "odamex")
- (version "0.8.3")
+ (version "0.9.0")
(source
(origin
(method url-fetch)
(uri (string-append
"mirror://sourceforge/odamex/Odamex/" version "/"
- "odamex-src-" version ".tar.gz"))
+ "odamex-src-" version ".tar.bz2"))
(sha256
- (base32 "0f887g87bmcq4dpcga7xc2mpxs947dkbc934ir9xs55gz6z13q96"))))
+ (base32 "0yfrvx8zb3chy47fyz4nik6gbh0y5608yvld4gz4y8l158qk71y1"))))
(build-system cmake-build-system)
(arguments `(#:tests? #f)) ; no tests
+ (native-inputs
+ `(("deutex" ,deutex)))
(inputs
- `(("sdl" ,sdl)
- ("sdl-mixer" ,sdl-mixer)
+ `(("sdl" ,sdl2)
+ ("sdl-mixer" ,sdl2-mixer)
("zlib" ,zlib)
("libpng" ,libpng)
+ ("curl" ,curl-minimal)
("alsa-lib" ,alsa-lib)))
(home-page "https://odamex.net/")
(synopsis "Multiplayer Doom port")
--
2.31.1
Ludovic Courtès wrote 4 years ago
(name . David Pflug)(address . david@pflug.io)(address . 48076-done@debbugs.gnu.org)
87v97zx00g.fsf@gnu.org
Hi David,

David Pflug <david@pflug.io> skribis:

Toggle quote (2 lines)
> * gnu/packages/games.scm (odamex): Update to 0.9.0.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48076@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48076
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help