(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
Hi,
This series of patches update Nheko messaging client to 0.8.1 version.
There's a newer 0.8.2 version but they make use of different dependencies and we need to deal with them before updating.
Hope they are useful,
Ekaitz
From 5173d76501524c73e9e7ae9c8edc9d2f59c69961 Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Tue, 27 Apr 2021 14:03:21 +0200
Subject: [PATCH 2/2] gnu: nheko: Update to 0.8.1
* gnu/packages/messaging.scm (nheko): Update to 0.8.1.
[inputs]: Add qtkeychain
---
gnu/packages/messaging.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
Toggle diff (32 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 81cb7c7178..f565283672 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2300,7 +2300,7 @@ for the Matrix protocol. It is built on to of @code{Boost.Asio}.")
(define-public nheko
(package
(name "nheko")
- (version "0.7.2")
+ (version "0.8.1")
(source
(origin
(method git-fetch)
@@ -2309,7 +2309,7 @@ for the Matrix protocol. It is built on to of @code{Boost.Asio}.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1cbhgaf9klgxdirrxj571fqwspm0byl75c1xc40l727a6qswvp7s"))))
+ (base32 "1v7k3ifzi05fdr06hmws1wkfl1bmhrnam3dbwahp086vkj0r8524"))))
(arguments
`(#:tests? #f ;no test target
#:configure-flags
@@ -2341,6 +2341,7 @@ for the Matrix protocol. It is built on to of @code{Boost.Asio}.")
("qtbase" ,qtbase)
("qtdeclarative" ,qtdeclarative)
("qtgraphicaleffects" ,qtgraphicaleffects)
+ ("qtkeychain" ,qtkeychain)
("qtmultimedia" ,qtmultimedia)
("qtquickcontrols2" ,qtquickcontrols2)
("qtsvg" ,qtsvg)
--
2.31.0
From 75d69bb5aecdf49f9d1dfddbc0a50815c50a5299 Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Tue, 27 Apr 2021 14:01:32 +0200
Subject: [PATCH 1/2] gnu: mtxclient: Update to 0.4.1
* gnu/packages/messaging.scm (mtxclient): Update to 0.4.1.
---
gnu/packages/messaging.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (24 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index c356498fd2..81cb7c7178 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2250,7 +2250,7 @@ QMatrixClient project.")
(define-public mtxclient
(package
(name "mtxclient")
- (version "0.3.1")
+ (version "0.4.1")
(source
(origin
(method git-fetch)
@@ -2259,7 +2259,7 @@ QMatrixClient project.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1dg4dq20g0ah62j5s3gpsxqq4ny7lxkxdxa9q6g54hdwkrb9ms7x"))))
+ (base32 "1044zil3izhb3whhfjah7w0kg5mr3hys32cjffky681d3mb3wi5n"))))
(arguments
`(#:configure-flags
(list
--
2.31.0