Statically-linked packages fail to build on powerpc64le-linux

  • Open
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Ludovic Courtès
Owner
unassigned
Submitted by
Ludovic Courtès
Severity
normal
L
L
Ludovic Courtès wrote on 27 Apr 2021 09:27
(address . bug-guix@gnu.org)
87k0oo6vbi.fsf@inria.fr
As of current master (d904abe0768293b2322dbf355b6e41d94e769d78),
statically-linked packages required by ‘bootstrap-tarballs’ fail to
build on powerpc64le-linux. For example:

Toggle snippet (19 lines)
gcc -Wall -Winline -O2 -g -D_FILE_OFFSET_BITS=64 -c bzip2.c
gcc -Wall -Winline -O2 -g -D_FILE_OFFSET_BITS=64 -c bzip2recover.c
ar cq libbz2.a blocksort.o huffman.o crctable.o randtable.o compress.o decompress.o bzlib.o
gcc -Wall -Winline -O2 -g -D_FILE_OFFSET_BITS=64 -static -o bzip2recover bzip2recover.o
ld: /gnu/store/gwv2pylmh7qsdqdcf3kpm6g6ghfqr6z1-glibc-2.31-static/lib/../lib/libc.a(printf_fp.o): in function `__printf_fp_l':
(.text+0x93c): undefined reference to `__unordkf2'
ld: (.text+0x978): undefined reference to `__unordkf2'
ld: (.text+0xd18): undefined reference to `__lekf2'
ld: /gnu/store/gwv2pylmh7qsdqdcf3kpm6g6ghfqr6z1-glibc-2.31-static/lib/../lib/libc.a(printf_fphex.o): in function `__printf_fphex':
(.text+0xe8): undefined reference to `__unordkf2'
ld: (.text+0x134): undefined reference to `__unordkf2'
ld: (.text+0x154): undefined reference to `__lekf2'
collect2: error: ld returned 1 exit status
make: *** [Makefile:43: bzip2recover] Error 1
make: *** Waiting for unfinished jobs....
command "make" "-j" "8" "PREFIX=/gnu/store/dbbzbdzyg8sbcvlan6i2zpwbld1a4b41-bzip2-1.0.8" failed with status 2
builder for `/gnu/store/qr6wzh818417zmswip1nlf6jglyp7fh2-bzip2-1.0.8.drv' failed with exit code 1

and:

Toggle snippet (19 lines)
configure flags: ("CONFIG_SHELL=/gnu/store/6ql2s2z4xnsj89zdf4zj6fch2zic0l7k-bash-minimal-5.0.16/bin/bash" "SHELL=/gnu/store/6ql2s2z4xnsj89zdf4zj6fch2zic0l7k-bash-minimal-5.0.16/bin/bash" "--prefix=/gnu/store/rjv42g8djff52z3xka8hpbzk4jjqd5w3-gawk-5.0.1" "--enable-fast-install" "--build=powerpc64le-unknown-linux-gnu" "--disable-shared" "LDFLAGS=-static")
checking for a BSD-compatible install... ./install-sh -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /gnu/store/x5z9z2d06w4yj4kq18i4b5q2yxg0w9dh-coreutils-8.32/bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... no
checking whether make supports nested variables... yes
checking build system type... powerpc64le-unknown-linux-gnu
checking host system type... powerpc64le-unknown-linux-gnu
checking whether make supports the include directive... yes (GNU style)
checking for gcc... gcc
checking whether the C compiler works... no
configure: error: in `/tmp/guix-build-gawk-5.0.1.drv-0/gawk-5.0.1':
configure: error: C compiler cannot create executables
See `config.log' for more details
command "/gnu/store/6ql2s2z4xnsj89zdf4zj6fch2zic0l7k-bash-minimal-5.0.16/bin/bash" "./configure" "CONFIG_SHELL=/gnu/store/6ql2s2z4xnsj89zdf4zj6fch2zic0l7k-bash-minimal-5.0.16/bin/bash" "SHELL=/gnu/store/6ql2s2z4xnsj89zdf4zj6fch2zic0l7k-bash-minimal-5.0.16/bin/bash" "--prefix=/gnu/store/rjv42g8djff52z3xka8hpbzk4jjqd5w3-gawk-5.0.1" "--enable-fast-install" "--build=powerpc64le-unknown-linux-gnu" "--disable-shared" "LDFLAGS=-static" failed with status 77
builder for `/gnu/store/fh64zc3gyhar0l2ndv2azrg5jv30kygl-gawk-5.0.1.drv' failed with exit code 1

Ludo’.
E
E
Efraim Flashner wrote on 27 Apr 2021 10:04
(name . Ludovic Courtès)(address . ludovic.courtes@inria.fr)(address . 48055@debbugs.gnu.org)
YIfFdziokkkC07we@3900XT
On Tue, Apr 27, 2021 at 09:27:45AM +0200, Ludovic Courtès wrote:
Toggle quote (47 lines)
> As of current master (d904abe0768293b2322dbf355b6e41d94e769d78),
> statically-linked packages required by ‘bootstrap-tarballs’ fail to
> build on powerpc64le-linux. For example:
>
> --8<---------------cut here---------------start------------->8---
> gcc -Wall -Winline -O2 -g -D_FILE_OFFSET_BITS=64 -c bzip2.c
> gcc -Wall -Winline -O2 -g -D_FILE_OFFSET_BITS=64 -c bzip2recover.c
> ar cq libbz2.a blocksort.o huffman.o crctable.o randtable.o compress.o decompress.o bzlib.o
> gcc -Wall -Winline -O2 -g -D_FILE_OFFSET_BITS=64 -static -o bzip2recover bzip2recover.o
> ld: /gnu/store/gwv2pylmh7qsdqdcf3kpm6g6ghfqr6z1-glibc-2.31-static/lib/../lib/libc.a(printf_fp.o): in function `__printf_fp_l':
> (.text+0x93c): undefined reference to `__unordkf2'
> ld: (.text+0x978): undefined reference to `__unordkf2'
> ld: (.text+0xd18): undefined reference to `__lekf2'
> ld: /gnu/store/gwv2pylmh7qsdqdcf3kpm6g6ghfqr6z1-glibc-2.31-static/lib/../lib/libc.a(printf_fphex.o): in function `__printf_fphex':
> (.text+0xe8): undefined reference to `__unordkf2'
> ld: (.text+0x134): undefined reference to `__unordkf2'
> ld: (.text+0x154): undefined reference to `__lekf2'
> collect2: error: ld returned 1 exit status
> make: *** [Makefile:43: bzip2recover] Error 1
> make: *** Waiting for unfinished jobs....
> command "make" "-j" "8" "PREFIX=/gnu/store/dbbzbdzyg8sbcvlan6i2zpwbld1a4b41-bzip2-1.0.8" failed with status 2
> builder for `/gnu/store/qr6wzh818417zmswip1nlf6jglyp7fh2-bzip2-1.0.8.drv' failed with exit code 1
> --8<---------------cut here---------------end--------------->8---
>
> and:
>
> --8<---------------cut here---------------start------------->8---
> configure flags: ("CONFIG_SHELL=/gnu/store/6ql2s2z4xnsj89zdf4zj6fch2zic0l7k-bash-minimal-5.0.16/bin/bash" "SHELL=/gnu/store/6ql2s2z4xnsj89zdf4zj6fch2zic0l7k-bash-minimal-5.0.16/bin/bash" "--prefix=/gnu/store/rjv42g8djff52z3xka8hpbzk4jjqd5w3-gawk-5.0.1" "--enable-fast-install" "--build=powerpc64le-unknown-linux-gnu" "--disable-shared" "LDFLAGS=-static")
> checking for a BSD-compatible install... ./install-sh -c
> checking whether build environment is sane... yes
> checking for a thread-safe mkdir -p... /gnu/store/x5z9z2d06w4yj4kq18i4b5q2yxg0w9dh-coreutils-8.32/bin/mkdir -p
> checking for gawk... gawk
> checking whether make sets $(MAKE)... no
> checking whether make supports nested variables... yes
> checking build system type... powerpc64le-unknown-linux-gnu
> checking host system type... powerpc64le-unknown-linux-gnu
> checking whether make supports the include directive... yes (GNU style)
> checking for gcc... gcc
> checking whether the C compiler works... no
> configure: error: in `/tmp/guix-build-gawk-5.0.1.drv-0/gawk-5.0.1':
> configure: error: C compiler cannot create executables
> See `config.log' for more details
> command "/gnu/store/6ql2s2z4xnsj89zdf4zj6fch2zic0l7k-bash-minimal-5.0.16/bin/bash" "./configure" "CONFIG_SHELL=/gnu/store/6ql2s2z4xnsj89zdf4zj6fch2zic0l7k-bash-minimal-5.0.16/bin/bash" "SHELL=/gnu/store/6ql2s2z4xnsj89zdf4zj6fch2zic0l7k-bash-minimal-5.0.16/bin/bash" "--prefix=/gnu/store/rjv42g8djff52z3xka8hpbzk4jjqd5w3-gawk-5.0.1" "--enable-fast-install" "--build=powerpc64le-unknown-linux-gnu" "--disable-shared" "LDFLAGS=-static" failed with status 77
> builder for `/gnu/store/fh64zc3gyhar0l2ndv2azrg5jv30kygl-gawk-5.0.1.drv' failed with exit code 1
> --8<---------------cut here---------------end--------------->8---
>

What version of GCC is being used? Perhaps the gcc in make-bootstrap.scm
needs to be told to use 128-bit long longs.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmCHxXcACgkQQarn3Mo9
g1G15g/+O02V8kfryii5Q6CMTvJRAReEVdtXVX63TsJS478StDWKBNpezpkzWapg
2ItL5JvD4teX3PWGaHfZtj45QHJl7F6BdMB82E6qzyKWKqXEtA1lSb88NdCIEfDb
Z5LLeh0y7+OfNpj/CHyaZKe4bIOfv3UUD6zPEdxf34mSukAVoIttgsBuhP6q4DP8
D/ZCw1HPg0RhSOVB5fAJyjc18LisV2MAtCWwN0uBrK9BFey6UTNYZXsrGwe+V3Ir
eWUCQYn8mKBSmNu7wyGsp/c7FwiMpjhrVEeJz/YpkdHuuYxjjPwIvbkxvQsuMYf1
/CuhX6lFot9NdG9N0ZxijNa5WIfGin6By+h3w/P3P+ss3JMdDSzMc8pmSTtXX5bw
yxqzC8/NAB3j1xqJQ+LEwddksG6QPoVTYruqmLzA8qTawKtn0dgF8JF4aVysNgI/
gZk8A+2fi9cjbvK0Xbq0KCXJWBpVirqfyAZcGSn4ju428J6EAhwTe2Zxa04/Y5J1
vXUsKEvmsFkkCvdkA2O1uUMWx4rIY8XoqU6d/T5qYLEO/U76h5hXqpY9O7Y7o86q
POwnkrBK8xdP7LmRgX0cPpWtBK7Rhe2HlNfKC4mw4saJ0sCTVQ7xkR8qC3NeHLC4
5YkhnkoV+1OACxreJGMBms8h8rlXbwGWqXR0mK1kykYXDGIdckU=
=efb6
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 27 Apr 2021 13:44
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 48055@debbugs.gnu.org)
87sg3c54vw.fsf@inria.fr
Efraim Flashner <efraim@flashner.co.il> skribis:

Toggle quote (5 lines)
> On Tue, Apr 27, 2021 at 09:27:45AM +0200, Ludovic Courtès wrote:
>> As of current master (d904abe0768293b2322dbf355b6e41d94e769d78),
>> statically-linked packages required by ‘bootstrap-tarballs’ fail to
>> build on powerpc64le-linux. For example:

[...]

Toggle quote (3 lines)
> What version of GCC is being used? Perhaps the gcc in make-bootstrap.scm
> needs to be told to use 128-bit long longs.

D’oh, for /gnu/store/qr6wzh818417zmswip1nlf6jglyp7fh2-bzip2-1.0.8.drv
for instance, it’s GCC 5. How come?

Indeed, make-bootstrap.scm refers to ‘gcc-5’ everywhere. We should
change it to match ‘gcc-final’, no? (That probably won’t make it into
‘version-1.3.0’ but we can do that on ‘master’.)

Thanks,
Ludo’.
E
E
Efraim Flashner wrote on 27 Apr 2021 13:59
(name . Ludovic Courtès)(address . ludovic.courtes@inria.fr)(address . 48055@debbugs.gnu.org)
YIf8rbMSOuzQXeWj@3900XT
On Tue, Apr 27, 2021 at 01:44:03PM +0200, Ludovic Courtès wrote:
Toggle quote (15 lines)
> Efraim Flashner <efraim@flashner.co.il> skribis:
>
> > On Tue, Apr 27, 2021 at 09:27:45AM +0200, Ludovic Courtès wrote:
> >> As of current master (d904abe0768293b2322dbf355b6e41d94e769d78),
> >> statically-linked packages required by ‘bootstrap-tarballs’ fail to
> >> build on powerpc64le-linux. For example:
>
> [...]
>
> > What version of GCC is being used? Perhaps the gcc in make-bootstrap.scm
> > needs to be told to use 128-bit long longs.
>
> D’oh, for /gnu/store/qr6wzh818417zmswip1nlf6jglyp7fh2-bzip2-1.0.8.drv
> for instance, it’s GCC 5. How come?

We keep versions that are known to work. I guess we can bump it to
gcc-7, we'll just have to test all the other architectures. Or we can
just bump it for powerpc64le. There's a reason why %guile-static is
still guile-2.0.

Toggle quote (4 lines)
> Indeed, make-bootstrap.scm refers to ‘gcc-5’ everywhere. We should
> change it to match ‘gcc-final’, no? (That probably won’t make it into
> ‘version-1.3.0’ but we can do that on ‘master’.)

Yeah. make-bootstrap is going to come in handy again when we get around
to riscv64. It might just be easier to let whoever ends up working on
that to mess with it then.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmCH/KsACgkQQarn3Mo9
g1HLlBAAqAsOuQkKN0OlY3xLvoon445+iyJLWcqXiOu4Fd8cKwEuHW2AeSWTa2mh
T225KLzzYWErTT6Vis93ft/SdIwbDkcgxwqHrLJ7e/ArJmynZ9zToSTwVMGLXsF6
oeAglwz44ih3xDPpnSFyrEiNaHB0hPHS9hwvm/qIkK5lUmgDZ5LTphlEpPKVwipu
cPVSdOgcFrjtFoXXzgVckQPiSgfLiRMTpXrWJkBJqdGBsZp0F34y/6Y8pam1GLmQ
IOcXE6qDjQbJM+KL6qp4/cYZAmZY/YcvIq3mgap1OTgA+bwePyMEqAOJIS5fXWuf
kTlOhhjgnEbuBSWlnrD0fqBIlIGz0xHQuxeehw34J7h0aT5vcEV+wV9ownBXKjSK
2xPVs/04fEHKg7ipPpYo9R8Ae4nWPa6WHUqT143pINKiBmWBoP6deGEJ3kETG1x3
cdA4MLVA0beB2dYfQwOk0uCrCGDyocxfPJ0pNixH7JhIeCQH49Q93EVDz5woOC2Q
7Gqkpj4PEJ+pZMAp79DlfpoG0RtUdEbSja5pfkzsCiZDbVVALZVd/MIGtLRZkzqm
sMBe5OsG+PJCOc8gZthgsmncTmyD5dDAIO4JrQXjjdrzjp+D4yaeK5WPVVj8yPsW
LJgpw9OKsek6EGGEFXW27ikGx3ja65E4KJQR57wr9/b9nuckM4Y=
=A7oX
-----END PGP SIGNATURE-----


?