Bone Baboon wrote 4 years ago
(address . bug-guix@gnu.org)
On an x86_64 computer when I run `guix challenge` I get this error:
```
...
/gnu/store/5ds5bli4p6gja2yzmzzc0sik1kzrasp9-guix-extra contents differ:
local hash: 0aacxb6n0vrki8lb7f02r3m756cpc650hbihj9dpklkpvlgasqad
https://ci.guix.gnu.org/nar/lzip/5ds5bli4p6gja2yzmzzc0sik1kzrasp9-guix-extra:0anncy58048fvbbi40wbfrd1dc6wk3zshx63p6jn2f03ljwakbkj
ci.guix.gnu.org 2.2MiB 416KiB/s 00:06 [##################] 101.3%
Backtrace:
In srfi/srfi-1.scm:
634:9 19 (for-each #<procedure 7fe80c8c1e40 at guix/scripts/cha…> …)
In guix/scripts/challenge.scm:
299:2 18 (report-differing-files _)
279:2 17 (differing-files #<<comparison-report> item: "/gnu/stor…>)
In srfi/srfi-1.scm:
586:17 16 (map1 (#<<narinfo> path: "/gnu/store/5ds5bli4p6gja2yzm…>))
In guix/scripts/challenge.scm:
262:4 15 (call-with-nar _ _)
In guix/utils.scm:
253:8 14 (call-with-decompressed-port _ _ _)
In guix/serialization.scm:
424:4 13 (fold-archive _ _ _ _)
468:33 12 (read "" _)
468:33 11 (read "/guix" _)
442:24 10 (read "/guix/self.go" _)
In guix/scripts/challenge.scm:
200:4 9 (_ "/guix/self.go" regular _ (("/guix/scripts.go" # …) …))
In guix/serialization.scm:
247:20 8 (dump #<input: string 7fe80d3471c0> #<output: string 7…> …)
In unknown file:
7 (get-bytevector-n! #<input: string 7fe80d3471c0> # 0 #)
In lzlib.scm:
501:4 6 (lzread! #<lz-decoder 7fe80dcef540> #<input: string 7f…> …)
In unknown file:
5 (get-bytevector-n #<input: string 7fe80d347230> 65538)
In guix/progress.scm:
362:23 4 (read! _ _ _)
178:12 3 (display-download-progress _ _ #:tty? _ #:start-time _ # …)
In unknown file:
2 (make-string -1 #\space)
In ice-9/boot-9.scm:
1669:16 1 (raise-exception _ #:continuable? _)
1669:16 0 (raise-exception _ #:continuable? _)
ice-9/boot-9.scm:1669:16: In procedure raise-exception:
Value out of range 0 to 18446744073709551615: -1
Backtrace:
19 (get-bytevector-n! #<closed: string 7fe80d3471c0> # 0 #)
In lzlib.scm:
501:4 18 (lzread! #<lz-decoder 7fe80dcef540> #<closed: string 7…> …)
In unknown file:
17 (get-bytevector-n #<closed: string 7fe80d347230> 65538)
In guix/progress.scm:
362:23 16 (read! _ _ _)
178:12 15 (display-download-progress _ _ #:tty? _ #:start-time _ # …)
In unknown file:
14 (make-string -1 #\space)
In ice-9/boot-9.scm:
1669:16 13 (raise-exception _ #:continuable? _)
1669:16 12 (raise-exception _ #:continuable? _)
1669:16 11 (raise-exception _ #:continuable? _)
In unknown file:
10 (apply-smob/1 #<exception-handler 7fe811315500> #<&comp…>)
In ice-9/boot-9.scm:
1659:16 9 (raise-exception _ #:continuable? _)
In unknown file:
8 (_ (0) #<&compound-exception components: (#<&assertion-…>)
In guix/utils.scm:
255:8 7 (_)
In unknown file:
6 (close-port #<closed: string 7fe80d3471c0>)
5 (close-port #<closed: string 7fe80d347230>)
In guix/progress.scm:
377:42 4 (_)
178:12 3 (display-download-progress _ _ #:tty? _ #:start-time _ # …)
In unknown file:
2 (make-string -1 #\space)
In ice-9/boot-9.scm:
1669:16 1 (raise-exception _ #:continuable? _)
1669:16 0 (raise-exception _ #:continuable? _)
ice-9/boot-9.scm:1669:16: In procedure raise-exception:
Value out of range 0 to 18446744073709551615: -1
```
`echo $?` outputs "1".
`guix describe` outputs:
```
Generation 10 Apr 26 2021 10:36:03 (current)
guix f365d48
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: f365d48909156ad754a2ade45375f45b54b06bbc
```