guix challenge error

  • Done
  • quality assurance status badge
Details
2 participants
  • Bone Baboon
  • Ludovic Courtès
Owner
unassigned
Submitted by
Bone Baboon
Severity
normal

Debbugs page

Bone Baboon wrote 4 years ago
(address . bug-guix@gnu.org)
87pmygc2jm.fsf@disroot.org
On an x86_64 computer when I run `guix challenge` I get this error:

```
...
/gnu/store/5ds5bli4p6gja2yzmzzc0sik1kzrasp9-guix-extra contents differ:
local hash: 0aacxb6n0vrki8lb7f02r3m756cpc650hbihj9dpklkpvlgasqad
https://ci.guix.gnu.org/nar/lzip/5ds5bli4p6gja2yzmzzc0sik1kzrasp9-guix-extra:0anncy58048fvbbi40wbfrd1dc6wk3zshx63p6jn2f03ljwakbkj
ci.guix.gnu.org 2.2MiB 416KiB/s 00:06 [##################] 101.3%
Backtrace:
In srfi/srfi-1.scm:
634:9 19 (for-each #<procedure 7fe80c8c1e40 at guix/scripts/cha…> …)
In guix/scripts/challenge.scm:
299:2 18 (report-differing-files _)
279:2 17 (differing-files #<<comparison-report> item: "/gnu/stor…>)
In srfi/srfi-1.scm:
586:17 16 (map1 (#<<narinfo> path: "/gnu/store/5ds5bli4p6gja2yzm…>))
In guix/scripts/challenge.scm:
262:4 15 (call-with-nar _ _)
In guix/utils.scm:
253:8 14 (call-with-decompressed-port _ _ _)
In guix/serialization.scm:
424:4 13 (fold-archive _ _ _ _)
468:33 12 (read "" _)
468:33 11 (read "/guix" _)
442:24 10 (read "/guix/self.go" _)
In guix/scripts/challenge.scm:
200:4 9 (_ "/guix/self.go" regular _ (("/guix/scripts.go" # …) …))
In guix/serialization.scm:
247:20 8 (dump #<input: string 7fe80d3471c0> #<output: string 7…> …)
In unknown file:
7 (get-bytevector-n! #<input: string 7fe80d3471c0> # 0 #)
In lzlib.scm:
501:4 6 (lzread! #<lz-decoder 7fe80dcef540> #<input: string 7f…> …)
In unknown file:
5 (get-bytevector-n #<input: string 7fe80d347230> 65538)
In guix/progress.scm:
362:23 4 (read! _ _ _)
178:12 3 (display-download-progress _ _ #:tty? _ #:start-time _ # …)
In unknown file:
2 (make-string -1 #\space)
In ice-9/boot-9.scm:
1669:16 1 (raise-exception _ #:continuable? _)
1669:16 0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1669:16: In procedure raise-exception:
Value out of range 0 to 18446744073709551615: -1
Backtrace:
19 (get-bytevector-n! #<closed: string 7fe80d3471c0> # 0 #)
In lzlib.scm:
501:4 18 (lzread! #<lz-decoder 7fe80dcef540> #<closed: string 7…> …)
In unknown file:
17 (get-bytevector-n #<closed: string 7fe80d347230> 65538)
In guix/progress.scm:
362:23 16 (read! _ _ _)
178:12 15 (display-download-progress _ _ #:tty? _ #:start-time _ # …)
In unknown file:
14 (make-string -1 #\space)
In ice-9/boot-9.scm:
1669:16 13 (raise-exception _ #:continuable? _)
1669:16 12 (raise-exception _ #:continuable? _)
1669:16 11 (raise-exception _ #:continuable? _)
In unknown file:
10 (apply-smob/1 #<exception-handler 7fe811315500> #<&comp…>)
In ice-9/boot-9.scm:
1659:16 9 (raise-exception _ #:continuable? _)
In unknown file:
8 (_ (0) #<&compound-exception components: (#<&assertion-…>)
In guix/utils.scm:
255:8 7 (_)
In unknown file:
6 (close-port #<closed: string 7fe80d3471c0>)
5 (close-port #<closed: string 7fe80d347230>)
In guix/progress.scm:
377:42 4 (_)
178:12 3 (display-download-progress _ _ #:tty? _ #:start-time _ # …)
In unknown file:
2 (make-string -1 #\space)
In ice-9/boot-9.scm:
1669:16 1 (raise-exception _ #:continuable? _)
1669:16 0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1669:16: In procedure raise-exception:
Value out of range 0 to 18446744073709551615: -1
```

`echo $?` outputs "1".

`guix describe` outputs:

```
Generation 10 Apr 26 2021 10:36:03 (current)
guix f365d48
branch: master
commit: f365d48909156ad754a2ade45375f45b54b06bbc
```
Ludovic Courtès wrote 4 years ago
(name . Bone Baboon)(address . bone.baboon@disroot.org)(address . 48045@debbugs.gnu.org)
87bl9yqf7h.fsf@gnu.org
Hi,

Bone Baboon <bone.baboon@disroot.org> skribis:

Toggle quote (41 lines)
> On an x86_64 computer when I run `guix challenge` I get this error:
>
> ```
> ...
> /gnu/store/5ds5bli4p6gja2yzmzzc0sik1kzrasp9-guix-extra contents differ:
> local hash: 0aacxb6n0vrki8lb7f02r3m756cpc650hbihj9dpklkpvlgasqad
> https://ci.guix.gnu.org/nar/lzip/5ds5bli4p6gja2yzmzzc0sik1kzrasp9-guix-extra: 0anncy58048fvbbi40wbfrd1dc6wk3zshx63p6jn2f03ljwakbkj
> ci.guix.gnu.org 2.2MiB 416KiB/s 00:06 [##################] 101.3%
> Backtrace:
> In srfi/srfi-1.scm:
> 634:9 19 (for-each #<procedure 7fe80c8c1e40 at guix/scripts/cha…> …)
> In guix/scripts/challenge.scm:
> 299:2 18 (report-differing-files _)
> 279:2 17 (differing-files #<<comparison-report> item: "/gnu/stor…>)
> In srfi/srfi-1.scm:
> 586:17 16 (map1 (#<<narinfo> path: "/gnu/store/5ds5bli4p6gja2yzm…>))
> In guix/scripts/challenge.scm:
> 262:4 15 (call-with-nar _ _)
> In guix/utils.scm:
> 253:8 14 (call-with-decompressed-port _ _ _)
> In guix/serialization.scm:
> 424:4 13 (fold-archive _ _ _ _)
> 468:33 12 (read "" _)
> 468:33 11 (read "/guix" _)
> 442:24 10 (read "/guix/self.go" _)
> In guix/scripts/challenge.scm:
> 200:4 9 (_ "/guix/self.go" regular _ (("/guix/scripts.go" # …) …))
> In guix/serialization.scm:
> 247:20 8 (dump #<input: string 7fe80d3471c0> #<output: string 7…> …)
> In unknown file:
> 7 (get-bytevector-n! #<input: string 7fe80d3471c0> # 0 #)
> In lzlib.scm:
> 501:4 6 (lzread! #<lz-decoder 7fe80dcef540> #<input: string 7f…> …)
> In unknown file:
> 5 (get-bytevector-n #<input: string 7fe80d347230> 65538)
> In guix/progress.scm:
> 362:23 4 (read! _ _ _)
> 178:12 3 (display-download-progress _ _ #:tty? _ #:start-time _ # …)
> In unknown file:
> 2 (make-string -1 #\space)

The bug comes from the fact that it’s gone beyond 100%. We could solve
it by programming more defensively, but it’d be great to see where the
problem comes from.

Can you reproduce it with:

./pre-inst-env guix challenge /gnu/store/5ds5bli4p6gja2yzmzzc0sik1kzrasp9-guix-extra

?

If so, could you apply the patch below and send the output of this
command? We can discuss it on IRC if anything’s unclear.

Thanks,
Ludo’.
Toggle diff (20 lines)
diff --git a/guix/scripts/challenge.scm b/guix/scripts/challenge.scm
index 4ec3be99ca..3cafc478a0 100644
--- a/guix/scripts/challenge.scm
+++ b/guix/scripts/challenge.scm
@@ -252,11 +252,12 @@ taken since we do not import the archives."
"Call PROC with an input port from which it can read the nar pointed to by
NARINFO."
(let*-values (((uri compression size)
- (narinfo-best-uri narinfo))
- ((port response)
+ (narinfo-best-uri narinfo #:fast-decompression? #t))
+ ((port actual-size)
(http-fetch uri)))
(define reporter
- (progress-reporter/file (narinfo-path narinfo) size
+ (progress-reporter/file (narinfo-path narinfo)
+ (max (pk 's size) (pk 'rs actual-size))
#:abbreviation (const (uri-host uri))))
(define result
Bone Baboon wrote 4 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 48045@debbugs.gnu.org)
87eeerlj5o.fsf@disroot.org
Ludovic Courtès writes:
Toggle quote (13 lines)
> The bug comes from the fact that it’s gone beyond 100%. We could solve
> it by programming more defensively, but it’d be great to see where the
> problem comes from.
>
> Can you reproduce it with:
>
> ./pre-inst-env guix challenge /gnu/store/5ds5bli4p6gja2yzmzzc0sik1kzrasp9-guix-extra
>
> ?
>
> If so, could you apply the patch below and send the output of this
> command? We can discuss it on IRC if anything’s unclear.

I can not reproduce this error any more.

I have a new clone of the Guix repository.

I ran `./pre-inst-env guix challenge
/gnu/store/5ds5bli4p6gja2yzmzzc0sik1kzrasp9-guix-extra` 20 times and the
error was no error.

I ran `./pre-inst-env guix challenge` several times and there was no
error.

I tried running `guix challenge
/gnu/store/5ds5bli4p6gja2yzmzzc0sik1kzrasp9-guix-extra` outside of the
Guix repository 20 times and there was no error.
Ludovic Courtès wrote 4 years ago
(name . Bone Baboon)(address . bone.baboon@disroot.org)(address . 48045-done@debbugs.gnu.org)
87cztx4q26.fsf@gnu.org
Hi,

Bone Baboon <bone.baboon@disroot.org> skribis:

Toggle quote (29 lines)
> Ludovic Courtès writes:
>> The bug comes from the fact that it’s gone beyond 100%. We could solve
>> it by programming more defensively, but it’d be great to see where the
>> problem comes from.
>>
>> Can you reproduce it with:
>>
>> ./pre-inst-env guix challenge /gnu/store/5ds5bli4p6gja2yzmzzc0sik1kzrasp9-guix-extra
>>
>> ?
>>
>> If so, could you apply the patch below and send the output of this
>> command? We can discuss it on IRC if anything’s unclear.
>
> I can not reproduce this error any more.
>
> I have a new clone of the Guix repository.
>
> I ran `./pre-inst-env guix challenge
> /gnu/store/5ds5bli4p6gja2yzmzzc0sik1kzrasp9-guix-extra` 20 times and the
> error was no error.
>
> I ran `./pre-inst-env guix challenge` several times and there was no
> error.
>
> I tried running `guix challenge
> /gnu/store/5ds5bli4p6gja2yzmzzc0sik1kzrasp9-guix-extra` outside of the
> Guix repository 20 times and there was no error.

Thanks for checking. I’m closing it, but please do reopen if you
stumble upon it again.

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 48045@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 48045
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help