[PATCH] gnu: Add siggen.

  • Done
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Arun Isaac
Severity
normal
A
A
Arun Isaac wrote on 24 Apr 2021 19:12
(address . guix-patches@gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
20210424171234.28651-1-arunisaac@systemreboot.net
* gnu/packages/audio.scm (siggen): New variable.
---
gnu/packages/audio.scm | 51 +++++++++++++++++++++++++++++++++++++++++-
1 file changed, 50 insertions(+), 1 deletion(-)

Toggle diff (82 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index a866492558..5f95268af2 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -21,7 +21,7 @@
;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019, 2021 Leo Famulari <leo@famulari.name>
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
-;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2019, 2021 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2019, 2020 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2019 Christopher Lemmer Webber <cwebber@dustycloud.org>
@@ -78,6 +78,7 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnunet) ; libmicrohttpd
#:use-module (gnu packages gperf)
+ #:use-module (gnu packages groff)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
@@ -107,6 +108,7 @@
#:use-module (gnu packages serialization)
#:use-module (gnu packages telephony)
#:use-module (gnu packages linphone)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages tls)
#:use-module (gnu packages valgrind)
#:use-module (gnu packages video)
@@ -5190,3 +5192,50 @@ while still staying in time.")
(description "Butt is a tool to stream audio to a ShoutCast or
Icecast server.")
(license license:gpl2+)))
+
+(define-public siggen
+ (package
+ (name "siggen")
+ (version "2.3.10")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bleskodev/siggen")
+ (commit "a407611b59d59c7770bbe62ba9b8e9a948cf3210")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0szhgfd9kddr6qsz0imp0x66jjn6ry236f35vjl82ivc1v2bllcb"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list (string-append "INSDIR=" %output "/bin")
+ (string-append "MANDIR=" %output "/share/man"))
+ #:tests? #f ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ ;; Patch misc.c to prevent a segfault.
+ (add-after 'unpack 'patch-segfault
+ (lambda _
+ (substitute* "misc.c"
+ (("#include <stdio.h>\n" all)
+ (string-append all "#include <string.h>\n")))))
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key make-flags outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (for-each (lambda (dir)
+ (mkdir-p (string-append out dir)))
+ (list "/bin" "/share/man/man1" "/share/man/man5"))
+ (apply invoke "make" "sysinstall" make-flags)))))))
+ (inputs
+ `(("ncurses" ,ncurses)))
+ (native-inputs
+ `(("groff" ,groff-minimal) ; for nroff
+ ("util-linux" ,util-linux))) ; for col
+ (home-page "https://github.com/bleskodev/siggen")
+ (synopsis "Signal generation tools")
+ (description "siggen is a set of tools for imitating a laboratory signal
+generator, generating audio signals out of Linux's /dev/dsp audio
+device. There is support for mono and/or stereo and 8 or 16 bit samples.")
+ (license license:gpl2)))
--
2.31.0
M
M
Mathieu Othacehe wrote on 4 Jun 2021 15:09
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 47998@debbugs.gnu.org)
87wnr9dbep.fsf@gnu.org
Hello Arun,

Toggle quote (2 lines)
> * gnu/packages/audio.scm (siggen): New variable.

This LGTM, please go ahead :)

Thanks,

Mathieu
A
A
Arun Isaac wrote on 9 Jun 2021 19:27
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 47998-done@debbugs.gnu.org)
87h7i7j6dl.fsf@systemreboot.net
Pushed to master, thanks! :-)
-----BEGIN PGP SIGNATURE-----

iQFPBAEBCAA5FiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAmDA+fYbHGFydW5pc2Fh
Y0BzeXN0ZW1yZWJvb3QubmV0AAoJEC4l7othgCuzjS4H/RItgby6WmYhDkb1VIU2
6P928QDVCp8esUHJ4ohFvQ35Ve78aScPqa/zDgKRhDsj+OyKwamBqKw78fp3yV9c
XATP7oj9m1lhrnDf87+KJaH3+5Oix7235H8pMTXtd8tKRQru9djygb29N7UKeSyg
nf4G0Jq/aJSCh64bic3O+CzHL6sl7N4js9E+7I1P1rXcTe3SN5LoHCf87H9nzbgk
JlY4X+N51HkE0eMXUXFNrio3b+JQIqm43L4cinxjOVGzZniflMApPUrFXT//kAHN
zFMpxDy7L9yPcw8aTvqxq8x6R44cewx4EKAv6QGmAj+Co2ulGxcI0TYblgJARSuM
AQQ=
=GGze
-----END PGP SIGNATURE-----

Closed
?