(address . guix-patches@gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
[PATCH 0/2] Add openage
A
[PATCH 2/2] gnu: Add openage.
(address . 47997@debbugs.gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
20210424163926.22301-2-arunisaac@systemreboot.net
* gnu/packages/games.scm (openage): New variable.
---
gnu/packages/games.scm | 73 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 73 insertions(+)
Toggle diff (83 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 4d565395ee..9f4ac40507 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -12450,3 +12450,76 @@ available.")
objects with key-value pairs in a database with the key idea that changes in a
parent affect all children. The main focus is readability and moddability.")
(license license:lgpl3+)))
+
+(define-public openage
+ (package
+ (name "openage")
+ (version "0.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/SFTtech/openage")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "051hy0s0crdavaghwzv9airq5yrhmk2a6b3ckc7dhr1851yanynp"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags
+ (list (string-append "-DCMAKE_PY_INSTALL_PREFIX="
+ %output "/lib/python"
+ ,(version-major+minor (package-version python))
+ "/site-packages")
+ (string-append "-DGLOBAL_CONFIG_DIR=" %output "/etc/openage"))
+ #:modules ((guix build cmake-build-system)
+ ((guix build python-build-system) #:prefix python:)
+ (guix build utils))
+ #:imported-modules (,@%cmake-build-system-modules
+ (guix build python-build-system))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-python
+ (assoc-ref python:%standard-phases 'wrap))
+ (add-after 'wrap-python 'wrap-qt
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-program (string-append (assoc-ref outputs "out") "/bin/openage")
+ `("QML2_IMPORT_PATH" ":" prefix
+ ,(map (lambda (name)
+ (string-append (assoc-ref inputs name)
+ "/lib/qt5/qml"))
+ (list "qtdeclarative" "qtquickcontrols")))))))))
+ (inputs
+ `(("eigen" ,eigen)
+ ("fontconfig" ,fontconfig)
+ ("freetype" ,freetype)
+ ("harfbuzz" ,harfbuzz)
+ ("libepoxy" ,libepoxy)
+ ("nyan" ,nyan)
+ ("opusfile" ,opusfile)
+ ("python" ,python)
+ ("python-jinja2" ,python-jinja2)
+ ("python-numpy" ,python-numpy)
+ ("python-pillow" ,python-pillow)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtquickcontrols" ,qtquickcontrols)
+ ("sdl" ,(sdl-union (list sdl2 sdl2-image)))))
+ (native-inputs
+ `(("python-cython" ,python-cython)
+ ("python-pygments" ,python-pygments)))
+ (home-page "https://openage.sft.mx/")
+ (synopsis "Clone of the Age of Empires II engine")
+ (description "openage is a cross-platform real-time strategy game engine
+that provides the mechanics of Age of Empires. It aims to be a platform for
+the original Age of Empires games providing the same look and feel, but with
+more features for modding and multiplayer.")
+ (license (list license:gpl3+
+ ;; buildsystem/modules/FindSDL2.cmake,
+ ;; buildsystem/modules/FindGPerfTools.cmake,
+ ;; buildsystem/modules/FindOpusfile.cmake
+ license:bsd-3
+ ;; libopenage/util/compress/lzxd.cpp,
+ ;; doc/code/lzx_compression_info
+ license:lgpl2.0))))
--
2.31.0
A
[PATCH 1/2] gnu: Add nyan.
(address . 47997@debbugs.gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
20210424163926.22301-1-arunisaac@systemreboot.net
* gnu/packages/games.scm (nyan): New variable.
---
gnu/packages/games.scm | 33 ++++++++++++++++++++++++++++++++-
1 file changed, 32 insertions(+), 1 deletion(-)
Toggle diff (50 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 5b316f1997..4d565395ee 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -23,7 +23,7 @@
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016 Steve Webber <webber.sl@gmail.com>
;;; Copyright © 2017 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@hyperbola.info>
-;;; Copyright © 2017, 2018, 2020 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2017, 2018, 2020, 2021 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017, 2019 nee <nee-git@hidamari.blue>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
@@ -12419,3 +12419,34 @@ game FPS.")
implemented using ncurses user interface. An SDL graphical version is also
available.")
(license license:gpl3+)))
+
+(define-public nyan
+ (package
+ (name "nyan")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/SFTtech/nyan")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1jx874hmj7102ir4z95np5dgmavnh5dgj5iyz0ga8h4wa82n58dv"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "./nyan/nyancat" "--test-parser"
+ "-f" "../source/test/test.nyan"))))))
+ (native-inputs
+ `(("flex" ,flex)))
+ (home-page "https://github.com/SFTtech/nyan")
+ (synopsis "Data description language for openage")
+ (description "nyan is a data description language. It stores hierarchical
+objects with key-value pairs in a database with the key idea that changes in a
+parent affect all children. The main focus is readability and moddability.")
+ (license license:lgpl3+)))
--
2.31.0
?