[PATCH]: Gnu: Add terrable

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5r5owo0CdibeuigSfG-g4B5=gk7wFG3V5AtC-SbnAq=Eg@mail.gmail.com
Hi Guix team!
One more patch for game engine - Trial
--8<---------------cut here---------------start------------->8---
guix build -L . sbcl-terrable ecl-terrable --rounds=3
/gnu/store/rhlmqswqmixgq4yqxyifpc4sdk4i6mn5-ecl-terrable-1.0.0-1.e4fe23f
/gnu/store/k1wjwbimqnx9499h64dhlinl7dkmm9dr-sbcl-terrable-1.0.0-1.e4fe23f
Toggle snippet (8 lines)
Licensed under Zlib License
https://github.com/Shirakumo/terrable/blob/master/LICENSE
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From f756654767c8d72c1afca3203f3307be58b214e8 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Fri, 23 Apr 2021 00:05:16 +0100
Subject: [PATCH] Gnu: Add terrable

* gnu/packages/lisp-xyz.scm (sbcl-terrable, cl-terrable, ecl-terrable):
New variables
---
gnu/packages/lisp-xyz.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 666e62a4ce..8cc1c04cbc 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -16066,3 +16066,40 @@ handling the accessing of files on the underlying system however.")
(define-public cl-pathname-utils
(sbcl-package->cl-source-package sbcl-pathname-utils))
+
+(define-public sbcl-terrable
+ (let ((commit "e4fe23ffa08e8d53a8168105b413861da59cc786")
+ (revision "1"))
+ (package
+ (name "sbcl-terrable")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shirakumo/terrable.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pnqflgz410zydc1ivwnd8hcl24bgr7x12yjzr7g4lq3ibc8y97b"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("documentation-utils" ,sbcl-documentation-utils)
+ ("fast-io" ,sbcl-fast-io)
+ ("ieee-floats" ,sbcl-ieee-floats)
+ ("static-vectors" ,sbcl-static-vectors)
+ ("trivial-garbage" ,sbcl-trivial-garbage)))
+ (home-page "https://shirakumo.github.io/terrable/")
+ (synopsis "File parser library for Terragen TER terrain files")
+ (description
+ "This package provides Common Lisp support for rendering format Terragen
+@code{.TER}. Format specification could be found here
+@url{https://planetside.co.uk/wiki/index.php?title=Terragen_.TER_Format}")
+ (license license:zlib))))
+
+(define-public ecl-terrable
+ (sbcl-package->ecl-package sbcl-terrable))
+
+(define-public cl-terrable
+ (sbcl-package->cl-source-package sbcl-terrable))
--
2.31.1
Guillaume Le Vaillant wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 47961-done@debbugs.gnu.org)
87h7jxs80y.fsf@yamatai
Patch pushed as 4bef55db1d27aab2775ce2ec2ad11ff58a3c4f4c.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYIKJXQ8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/+LwD+IXX+2lRxNwVn7pK1H2QWhXPmjQtcxqmrrd1T
BEH/0HEBAKO2txa1AyImmJF+cvbqjNGYQhY8fO6y/kjO1Ln1er0F
=k66g
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 47961@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 47961
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help