[PATCH] Gnu: Add pathname-utils

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5qCTW3Jq7B44hn6vUJfDUTeDBOSONCZE3hgcVT7gWJxig@mail.gmail.com
Hi Guix team!
On the way of packing Common Lisp game engine - Trial
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From b4d8253431113b80441a3ee71b53c5b6f52f037e Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Wed, 21 Apr 2021 22:20:07 +0100
Subject: [PATCH] gnu: Add pathname-utils

* gnu/packages/lisp-xyz.scm: (sbcl-pathname-utils, cl-pathname-utils,
ecl-pathname-utils): New variables
---
gnu/packages/lisp-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 0e82f8fc2c..e728697710 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -16034,3 +16034,36 @@ lQuery.")
(define-public cl-clip
(sbcl-package->cl-source-package sbcl-clip))
+
+(define-public sbcl-pathname-utils
+ (let ((commit "70f517e44e13a38e0c8f296613236376d679fa8f")
+ (revision "1"))
+ (package
+ (name "sbcl-pathname-utils")
+ (version (git-version "1.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shinmera/pathname-utils.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zm4bf6gajpgmhr7zwf7600zlaf8fs1fcyzabqsh2ma2crkgqdxq"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ `(("parachute" ,sbcl-parachute)))
+ (home-page "https://shinmera.github.io/pathname-utils")
+ (synopsis "Collection of utilities to help with pathname operations")
+ (description
+ "This package provides Common Lisp system with collection of common tests
+and operations to help handling pathnames. It does not actually deal in handling
+the accessing of files on the underlying system however.")
+ (license license:zlib))))
+
+(define-public ecl-pathname-utils
+ (sbcl-package->ecl-package sbcl-pathname-utils))
+
+(define-public cl-pathname-utils
+ (sbcl-package->cl-source-package sbcl-pathname-utils))
--
2.31.1
Guillaume Le Vaillant wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 47942-done@debbugs.gnu.org)
87zgxqogr0.fsf@yamatai
Patch pushed as 3de01371dc0c5fb0847d8ad64bc508f77396f56b.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYIE2Mw8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/3dwD+McL449z7sUOQfpyqZEi6Y0x4d0qq/dmKAVGk
VSyulqUA/393j9tuRGXlMnWMC/pmptsNtlB9LPqu8S5cZt3i2HEQ
=9UoV
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 47942@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 47942
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help