Package outputs should be described in the UI
(address . bug-guix@gnu.org)
At least once a month I have to help somebody on IRC who didn't notice
that our Git package is split into multiple outputs.
They can't find `git send-email`, and the Guix package UI doesn't make
this clear enough.
I had the idea that package outputs besides 'out' and 'debug' should
have very brief descriptions that are exposed in `guix show` and `guix
search` and the `guix package` equivalents.
So, maybe it would look like this:
------
$ guix show git
name: git
version: 2.31.1
outputs: out send-email svn credential-netrc credential-libsecret subtree gui
* send-email: Tools for an email-based Git workflow
* svn: Provides git-svn, for bidirectional operation between Subversion and Git repositories
* credential-libsecret: Whatever that is
* subtree: Who knows?
* gui: A graphical interface for exploring a Git repository
* etc...
systems: x86_64-linux i686-linux
dependencies: asciidoc-py3@9.0.1 bash-minimal@5.0.16 bash@5.0.16 curl@7.74.0 docbook-xsl@1.79.1 expat@2.2.9 gettext-minimal@0.20.1 glib@2.62.6 libsecret@0.20.4 openssl@1.1.1i pcre2@10.35
+ perl-authen-sasl@2.16 perl-cgi@4.51 perl-io-socket-ssl@2.066 perl-net-smtp-ssl@1.04 perl-term-readkey@2.38 perl@5.30.2 pkg-config@0.29.2 python@3.8.2 subversion@1.14.1 tcl@8.6.10 tk@8.6.10
+ xmlto@0.0.28 zlib@1.2.11
location: gnu/packages/version-control.scm:173:2
homepage: https://git-scm.com/
license: GPL 2
synopsis: Distributed version control system
description: Git is a free distributed version control system designed to handle everything from small to very large projects with speed and efficiency.
------
The output of `guix show` and `guix search` are in recutils format, and
we'd need to make sure that these new UI elements continued that
valuable tradition.