(address . guix-patches@gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
* gnu/packages/tls.scm (desec-certbot-hook): New variable.
---
gnu/packages/tls.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)
Toggle diff (52 lines)
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 25493cc7ca..e7e50d7f53 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -42,6 +42,7 @@
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system trivial)
#:use-module (gnu packages compression)
#:use-module (gnu packages)
@@ -70,6 +71,37 @@
#:use-module (gnu packages base)
#:use-module (srfi srfi-1))
+(define-public desec-certbot-hook
+ (let ((commit "68da7abc0793602fd336962a7e2348b57c5d6fd6")
+ (revision "21"))
+ (package
+ (name "desec-certbot-hook")
+ (version
+ (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/desec-io/desec-certbot-hook")
+ (commit commit)))
+ (file-name
+ (git-file-name name version))
+ (sha256
+ (base32 "0qjqk6i85b1y7fgzcx74r4gn2i4dkjza34hkzp6kyn9hrb8f2gv2"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan
+ '(("." "etc/desec" #:include ("hook.sh")))))
+ (synopsis "deSEC's certbot DNS challenge automatization")
+ (description "Use deSEC to obtain certificates with certbot DNS ownership
+verification. With the help of this hook script, you can obtain your Let's
+Encrypt certificate using certbot with authorization provided by the DNS
+challenge mechanism, that is, you will not need a running web server or any port
+forwarding to your local machine.")
+ (home-page "https://desec.io")
+ (license license:expat))))
+
(define-public libtasn1
(package
(name "libtasn1")
--
2.31.1