[PATCH] gnu: Add collectl.

  • Open
  • quality assurance status badge
Details
3 participants
  • phodina
  • Roel Janssen
  • zimoun
Owner
unassigned
Submitted by
Roel Janssen
Severity
normal
R
R
Roel Janssen wrote on 15 Apr 2021 15:40
(address . guix-patches@gnu.org)
4270400a-fcf1-aec6-3dd6-9dbccca03cc5@gnu.org
Hi Guix,

Here's a patch to add collectl.

Cheers,
Roel
From b03d5b84bb8c68b08d25a2e243b405b58ac4c047 Mon Sep 17 00:00:00 2001
From: Roel Janssen <roel@gnu.org>
Date: Thu, 15 Apr 2021 15:38:37 +0200
Subject: [PATCH] gnu: Add collectl.

* gnu/packages/admin.scm (collectl): New variable.
---
gnu/packages/admin.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (62 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 512ac320e6..90b0bd5059 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -40,6 +40,7 @@
;;; Copyright © 2021 qblade <qblade@protonmail.com>
;;; Copyright © 2021 Hyunseok Kim <lasnesne@lagunposprasihopre.org>
;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
+;;; Copyright © 2021 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -423,6 +424,47 @@ environments:
@end itemize")
(license license:gpl3)))
+(define-public collectl
+ (package
+ (name "collectl")
+ (version "4.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/collectl/collectl/collectl-" version
+ "/collectl-" version ".src.tar.gz"))
+ (sha256
+ (base32
+ "1wc9k3rmhqzh6cx5dcpqhlc3xcpadsn2ic54r19scdjbjx6jd1r1"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'build) ; There's nothing to build.
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "INSTALL"
+ (("DESTDIR:=\"/\"") (format #f "DESTDIR:=~s"
+ (assoc-ref outputs "out")))
+ (("DESTDIR/usr") "DESTDIR"))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "collectl"
+ (("\\$configFile='';")
+ (string-append "$configFile='"
+ (assoc-ref outputs "out")
+ "/etc';")))
+ (invoke "./INSTALL"))))))
+ (inputs
+ `(("perl" ,perl)))
+ (home-page "http://collectl.sourceforge.net")
+ (synopsis "Performance data collector")
+ (description "This package provides a program that collects various
+performance measurement data like CPU, memory, disk and network performance
+numbers.")
+ (license license:artistic2.0)))
+
(define-public daemontools
(package
(name "daemontools")
--
2.30.2
Z
Z
zimoun wrote on 3 Nov 2021 11:16
(name . Roel Janssen)(address . roel@gnu.org)(address . 47798@debbugs.gnu.org)
871r3xtugq.fsf@gmail.com
Hi Roel,

On Thu, 15 Apr 2021 at 15:40, Roel Janssen <roel@gnu.org> wrote:

Toggle quote (10 lines)
>>From b03d5b84bb8c68b08d25a2e243b405b58ac4c047 Mon Sep 17 00:00:00 2001
> From: Roel Janssen <roel@gnu.org>
> Date: Thu, 15 Apr 2021 15:38:37 +0200
> Subject: [PATCH] gnu: Add collectl.
>
> * gnu/packages/admin.scm (collectl): New variable.
> ---
> gnu/packages/admin.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 42 insertions(+)

I have not built this patch myself but it LGTM. If it builds fine for
you and “guix lint” does not report, feel free to push. :-)

Cheers,
simon
P
P
phodina wrote on 5 Nov 2021 07:05
[PATCH v2] gnu: Add collectl.
(name . 47798@debbugs.gnu.org)(address . 47798@debbugs.gnu.org)
i6nQ6QXtW1o_8fnyF6uN-ASENGrGvqEmS7cSn_U_FI4GX6RREsq2IGnZ35yF4IpffNDPDtu-cP8Zgh21I7ZGADVVRw74ribkAEoZkP6yXyE=@protonmail.com
Hi zimoun and Roel,

I've build and used the package. The only issue was with the copyright line, therefore I'm sending this patch.

Petr

----8>------------cut here------------------->8-----------

* gnu/packages/admin.scm (collectl): New variable.

Toggle diff (60 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 86b6b7ce50..33aebfecfe 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -44,6 +44,7 @@
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2021 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -430,6 +431,47 @@ (define-public cloud-utils
@end itemize")
(license license:gpl3)))

+(define-public collectl
+ (package
+ (name "collectl")
+ (version "4.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/collectl/collectl/collectl-" version
+ "/collectl-" version ".src.tar.gz"))
+ (sha256
+ (base32
+ "1wc9k3rmhqzh6cx5dcpqhlc3xcpadsn2ic54r19scdjbjx6jd1r1"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'build) ; There's nothing to build.
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "INSTALL"
+ (("DESTDIR:=\"/\"") (format #f "DESTDIR:=~s"
+ (assoc-ref outputs "out")))
+ (("DESTDIR/usr") "DESTDIR"))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "collectl"
+ (("\\$configFile='';")
+ (string-append "$configFile='"
+ (assoc-ref outputs "out")
+ "/etc';")))
+ (invoke "./INSTALL"))))))
+ (inputs
+ `(("perl" ,perl)))
+ (home-page "http://collectl.sourceforge.net")
+ (synopsis "Performance data collector")
+ (description "This package provides a program that collects various
+performance measurement data like CPU, memory, disk and network performance
+numbers.")
+ (license license:artistic2.0)))
+
(define-public daemontools
(package
(name "daemontools")
--
2.33.1
?