(address . guix-patches@gnu.org)
Hi Guix,
Here's a patch to add collectl.
Cheers,
Roel
From b03d5b84bb8c68b08d25a2e243b405b58ac4c047 Mon Sep 17 00:00:00 2001
From: Roel Janssen <roel@gnu.org>
Date: Thu, 15 Apr 2021 15:38:37 +0200
Subject: [PATCH] gnu: Add collectl.
* gnu/packages/admin.scm (collectl): New variable.
---
gnu/packages/admin.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)
Toggle diff (62 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 512ac320e6..90b0bd5059 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -40,6 +40,7 @@
;;; Copyright © 2021 qblade <qblade@protonmail.com>
;;; Copyright © 2021 Hyunseok Kim <lasnesne@lagunposprasihopre.org>
;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
+;;; Copyright © 2021 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -423,6 +424,47 @@ environments:
@end itemize")
(license license:gpl3)))
+(define-public collectl
+ (package
+ (name "collectl")
+ (version "4.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/collectl/collectl/collectl-" version
+ "/collectl-" version ".src.tar.gz"))
+ (sha256
+ (base32
+ "1wc9k3rmhqzh6cx5dcpqhlc3xcpadsn2ic54r19scdjbjx6jd1r1"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'build) ; There's nothing to build.
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "INSTALL"
+ (("DESTDIR:=\"/\"") (format #f "DESTDIR:=~s"
+ (assoc-ref outputs "out")))
+ (("DESTDIR/usr") "DESTDIR"))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "collectl"
+ (("\\$configFile='';")
+ (string-append "$configFile='"
+ (assoc-ref outputs "out")
+ "/etc';")))
+ (invoke "./INSTALL"))))))
+ (inputs
+ `(("perl" ,perl)))
+ (home-page "http://collectl.sourceforge.net")
+ (synopsis "Performance data collector")
+ (description "This package provides a program that collects various
+performance measurement data like CPU, memory, disk and network performance
+numbers.")
+ (license license:artistic2.0)))
+
(define-public daemontools
(package
(name "daemontools")
--
2.30.2