[PATCH] import: go: Fix goproxy option argument's format.

  • Done
  • quality assurance status badge
Details
2 participants
  • Z572
  • Ludovic Courtès
Owner
unassigned
Submitted by
Z572
Severity
normal
Z
(address . guix-patches@gnu.org)
tencent_6F94BF96A0D4FE6EDAA41A6541FE55EB380A@qq.com
From e34f281d39f9b1e247fa649a15657da70f2b548d Mon Sep 17 00:00:00 2001
From: Zheng Junjie <873216071@qq.com>
Date: Wed, 14 Apr 2021 22:37:50 +0800
Subject: [PATCH] import: go: Fix goproxy option argument's format.

Commit a8b927a562 Added new procedure go-module-available-versions use
'string-append' to GOPROXY, but 'string->symbol' let GOPROXY is a symbol (it
must be a string), which would lead to wrong-type-arg errors in the
'string-append' procedure.

* guix/scripts/import/go.scm (%options)[goproxy]: Remove call to
'string->symbol'.
---
guix/scripts/import/go.scm | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)

Toggle diff (25 lines)
diff --git a/guix/scripts/import/go.scm b/guix/scripts/import/go.scm
index 04b07f80cc..74e8e60cce 100644
--- a/guix/scripts/import/go.scm
+++ b/guix/scripts/import/go.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -68,9 +69,7 @@ that are not yet in Guix"))
(alist-cons 'recursive #t result)))
(option '(#\p "goproxy") #t #f
(lambda (opt name arg result)
- (alist-cons 'goproxy
- (string->symbol arg)
- (alist-delete 'goproxy result))))
+ (alist-cons 'goproxy arg (alist-delete 'goproxy result))))
(option '("pin-versions") #f #f
(lambda (opt name arg result)
(alist-cons 'pin-versions? #t result)))
--
2.31.1
L
L
Ludovic Courtès wrote on 14 May 2021 12:41
(name . Z572)(address . 873216071@qq.com)(address . 47776-done@debbugs.gnu.org)
878s4hoawd.fsf@gnu.org
Hi,

Z572 <873216071@qq.com> skribis:

Toggle quote (13 lines)
>>From e34f281d39f9b1e247fa649a15657da70f2b548d Mon Sep 17 00:00:00 2001
> From: Zheng Junjie <873216071@qq.com>
> Date: Wed, 14 Apr 2021 22:37:50 +0800
> Subject: [PATCH] import: go: Fix goproxy option argument's format.
>
> Commit a8b927a562 Added new procedure go-module-available-versions use
> 'string-append' to GOPROXY, but 'string->symbol' let GOPROXY is a symbol (it
> must be a string), which would lead to wrong-type-arg errors in the
> 'string-append' procedure.
>
> * guix/scripts/import/go.scm (%options)[goproxy]: Remove call to
> 'string->symbol'.

Applied, thanks!

Ludo’.
Closed
?