[PATCH 0/1] Update emacs-counsel-projectile (api change)

  • Done
  • quality assurance status badge
Details
2 participants
  • David Dashyan
  • Nicolas Goaziou
Owner
unassigned
Submitted by
David Dashyan
Severity
normal
D
D
David Dashyan wrote on 12 Apr 2021 15:17
(address . guix-patches@gnu.org)(name . David Dashyan)(address . mail@davie.li)
20210412131705.30725-1-mail@davie.li
Hello Guix!

Recently my counsel-projectile stopped working because of swiper update I
guess.

Problem was in ivy api change, more specifically
ivy--display-transformers-list function which is missing in recent version of
swiper.

counsel-projectile upstream commit fixing this issue:

I'm using updated version now.

David Dashyan (1):
gnu: emacs-counsel-projectile: Update to 0.3.1-0.06b03c1

gnu/packages/emacs-xyz.scm | 45 ++++++++++++++++++++------------------
1 file changed, 24 insertions(+), 21 deletions(-)


base-commit: 8615e21a8cfb01882b4785c950ccb89edc9c4bcc
--
2.31.1
D
D
David Dashyan wrote on 12 Apr 2021 15:19
[PATCH 1/1] gnu: emacs-counsel-projectile: Update to 0.3.1-0.06b03c1
(address . 47725@debbugs.gnu.org)(name . David Dashyan)(address . mail@davie.li)
20210412131953.30891-1-mail@davie.li
---
gnu/packages/emacs-xyz.scm | 45 ++++++++++++++++++++------------------
1 file changed, 24 insertions(+), 21 deletions(-)

Toggle diff (66 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ca1daaeb82..19b61e721d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -96,6 +96,7 @@
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2021 David Dashyan <mail@davie.li>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8491,28 +8492,30 @@ asynchronously, with Counsel and Ivy. Simply call
(license license:gpl3+))))
(define-public emacs-counsel-projectile
- (package
- (name "emacs-counsel-projectile")
- (version "0.3.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ericdanan/counsel-projectile")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1k4n5lw6wwbgpwv0dg9dw0bjzi0hvbgkzrs1zmq36yhfz6y8gwnh"))))
- (build-system emacs-build-system)
- (propagated-inputs
- `(("emacs-counsel" ,emacs-counsel)
- ("emacs-projectile" ,emacs-projectile)))
- (home-page "https://github.com/ericdanan/counsel-projectile")
- (synopsis "Enhance Projectile with Ivy")
- (description
- "This package uses Ivy to provide additional actions for Projectile
+ (let ((commit "06b03c1080d3ccc3fa9b9c41b1ccbcf13f058e4b")
+ (revision "0"))
+ (package
+ (name "emacs-counsel-projectile")
+ (version (git-version "0.3.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ericdanan/counsel-projectile")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "10afil6grwxj1x8fxd3ar7ikw3s3hzrkjsjin8wzchbz04389l7s"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-counsel" ,emacs-counsel)
+ ("emacs-projectile" ,emacs-projectile)))
+ (home-page "https://github.com/ericdanan/counsel-projectile")
+ (synopsis "Enhance Projectile with Ivy")
+ (description
+ "This package uses Ivy to provide additional actions for Projectile
commands and replacements for existing functions.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-qml-mode
(package
--
2.31.1
N
N
Nicolas Goaziou wrote on 26 Apr 2021 21:09
(name . David Dashyan)(address . mail@davie.li)(address . 47725-done@debbugs.gnu.org)
87k0oox3qf.fsf@nicolasgoaziou.fr
Hello,

David Dashyan <mail@davie.li> writes:

Toggle quote (6 lines)
> + (let ((commit "06b03c1080d3ccc3fa9b9c41b1ccbcf13f058e4b")
> + (revision "0"))
> + (package
> + (name "emacs-counsel-projectile")
> + (version (git-version "0.3.1" revision commit))

Thank you.

I added a proper commit message to the patch, and a comment explaining
why we're not using stable release anymore.

Applied.

Regards,
--
Nicolas Goaziou
Closed
D
D
David Dashyan wrote on 27 Apr 2021 17:57
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 47725-done@debbugs.gnu.org)
87mttjoh4i.fsf@davie.li
Thanks! I'll include comments next time :)

Nicolas Goaziou writes:

Toggle quote (20 lines)
> Hello,
>
> David Dashyan <mail@davie.li> writes:
>
>> + (let ((commit "06b03c1080d3ccc3fa9b9c41b1ccbcf13f058e4b")
>> + (revision "0"))
>> + (package
>> + (name "emacs-counsel-projectile")
>> + (version (git-version "0.3.1" revision commit))
>
> Thank you.
>
> I added a proper commit message to the patch, and a comment explaining
> why we're not using stable release anymore.
>
> Applied.
>
> Regards,


--
David aka zzappie
Closed
?