[PATCH] guix: scripts: system: Realign action docstrings

  • Open
  • quality assurance status badge
Details
One participant
  • Andrew Tropin
Owner
unassigned
Submitted by
Andrew Tropin
Severity
normal
A
A
Andrew Tropin wrote on 12 Apr 2021 09:32
(address . guix-patches@gnu.org)
87wnt86iyv.fsf@trop.in
Long actions like switch-generations and delete-generations make actions help
table from `guix system --help` to be missaligned. This commit alignes all
the action docstrings to the longest action name (delete-generations).
---

guix/scripts/system.scm | 28 ++++++++++++++--------------
1 file changed, 14 insertions(+), 14 deletions(-)

Toggle diff (56 lines)
diff --git a/guix/scripts/system.scm b/guix/scripts/system.scm
index 0a051ee4e3..45e849b00e 100644
--- a/guix/scripts/system.scm
+++ b/guix/scripts/system.scm
@@ -939,35 +939,35 @@ Some ACTIONS support additional ARGS.\n"))
(display (G_ "The valid values for ACTION are:\n"))
(newline)
(display (G_ "\
- search search for existing service types\n"))
+ search search for existing service types\n"))
(display (G_ "\
- reconfigure switch to a new operating system configuration\n"))
+ reconfigure switch to a new operating system configuration\n"))
(display (G_ "\
- roll-back switch to the previous operating system configuration\n"))
+ roll-back switch to the previous operating system configuration\n"))
(display (G_ "\
- describe describe the current system\n"))
+ describe describe the current system\n"))
(display (G_ "\
- list-generations list the system generations\n"))
+ list-generations list the system generations\n"))
(display (G_ "\
- switch-generation switch to an existing operating system configuration\n"))
+ switch-generation switch to an existing operating system configuration\n"))
(display (G_ "\
delete-generations delete old system generations\n"))
(display (G_ "\
- build build the operating system without installing anything\n"))
+ build build the operating system without installing anything\n"))
(display (G_ "\
- container build a container that shares the host's store\n"))
+ container build a container that shares the host's store\n"))
(display (G_ "\
- vm build a virtual machine image that shares the host's store\n"))
+ vm build a virtual machine image that shares the host's store\n"))
(display (G_ "\
- image build a Guix System image\n"))
+ image build a Guix System image\n"))
(display (G_ "\
- docker-image build a Docker image\n"))
+ docker-image build a Docker image\n"))
(display (G_ "\
- init initialize a root file system to run GNU\n"))
+ init initialize a root file system to run GNU\n"))
(display (G_ "\
- extension-graph emit the service extension graph in Dot format\n"))
+ extension-graph emit the service extension graph in Dot format\n"))
(display (G_ "\
- shepherd-graph emit the graph of shepherd services in Dot format\n"))
+ shepherd-graph emit the graph of shepherd services in Dot format\n"))
(show-build-options-help)
(display (G_ "
--
2.31.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 47719@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 47719
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch