gio mount broken, again.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • raingloom
Owner
unassigned
Submitted by
raingloom
Severity
normal
R
R
raingloom wrote on 11 Apr 2021 20:29
(name . Guix Bugs)(address . bug-guix@gnu.org)
20210411202901.2fc0f998@riseup.net
```
$ gio mount sftp://whatever
$ ls /run/user/$UID/gvfs/
```
prints nothing.

Same thing happens if I mount it from the Nautilus file manager.

This bug has appeared before and I still have no idea how it was fixed,
which is not great. I'll do a bisect soon. Should probably add a system
test for it so it doesn't break again.

In the meantime, if whoever fixed it the last time could look into it
again, I'd be very thankful. Using sshfs manually works but isn't great.
M
M
Maxim Cournoyer wrote on 12 Jul 2022 17:29
(name . raingloom)(address . raingloom@riseup.net)(address . 47716@debbugs.gnu.org)
87k08i73j9.fsf@gmail.com
Hi,

raingloom <raingloom@riseup.net> writes:

Toggle quote (15 lines)
> ```
> $ gio mount sftp://whatever
> $ ls /run/user/$UID/gvfs/
> ```
> prints nothing.
>
> Same thing happens if I mount it from the Nautilus file manager.
>
> This bug has appeared before and I still have no idea how it was fixed,
> which is not great. I'll do a bisect soon. Should probably add a system
> test for it so it doesn't break again.
>
> In the meantime, if whoever fixed it the last time could look into it
> again, I'd be very thankful. Using sshfs manually works but isn't great.

glib has seen 3 ugrades in Guix since you reported this issue (2.68.3
then 2.70 then 2.70.2). Do you still have the issue?

How do you setup the server; is a running OpenSSH server sufficient?

Thanks,

Maxim
M
M
Maxim Cournoyer wrote on 12 Jul 2022 17:29
control message for bug #47716
(address . control@debbugs.gnu.org)
87ilo273j3.fsf@gmail.com
tags 47716 + moreinfo
quit
C
Re: bug#47716: gio mount broken, again.
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
874jzmksci.fsf@riseup.net
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (28 lines)
> Hi,
>
> raingloom <raingloom@riseup.net> writes:
>
>> ```
>> $ gio mount sftp://whatever
>> $ ls /run/user/$UID/gvfs/
>> ```
>> prints nothing.
>>
>> Same thing happens if I mount it from the Nautilus file manager.
>>
>> This bug has appeared before and I still have no idea how it was fixed,
>> which is not great. I'll do a bisect soon. Should probably add a system
>> test for it so it doesn't break again.
>>
>> In the meantime, if whoever fixed it the last time could look into it
>> again, I'd be very thankful. Using sshfs manually works but isn't great.
>
> glib has seen 3 ugrades in Guix since you reported this issue (2.68.3
> then 2.70 then 2.70.2). Do you still have the issue?
>
> How do you setup the server; is a running OpenSSH server sufficient?
>
> Thanks,
>
> Maxim

I haven't done the bisect yet (ugh, why is time), but yes, the problem
still persists. Mostly same system config. gvfs is included in system
profile.
Yep, running OpenSSH is enough.
The system I'm currently writing from very much has the issue and is
about... okay, so it's from june 21, so not as fresh as I thought, but
relatively fresh.
C
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
877d4fc162.fsf@riseup.net
Csepp <raingloom@riseup.net> writes:

Toggle quote (38 lines)
> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>
>> Hi,
>>
>> raingloom <raingloom@riseup.net> writes:
>>
>>> ```
>>> $ gio mount sftp://whatever
>>> $ ls /run/user/$UID/gvfs/
>>> ```
>>> prints nothing.
>>>
>>> Same thing happens if I mount it from the Nautilus file manager.
>>>
>>> This bug has appeared before and I still have no idea how it was fixed,
>>> which is not great. I'll do a bisect soon. Should probably add a system
>>> test for it so it doesn't break again.
>>>
>>> In the meantime, if whoever fixed it the last time could look into it
>>> again, I'd be very thankful. Using sshfs manually works but isn't great.
>>
>> glib has seen 3 ugrades in Guix since you reported this issue (2.68.3
>> then 2.70 then 2.70.2). Do you still have the issue?
>>
>> How do you setup the server; is a running OpenSSH server sufficient?
>>
>> Thanks,
>>
>> Maxim
>
> I haven't done the bisect yet (ugh, why is time), but yes, the problem
> still persists. Mostly same system config. gvfs is included in system
> profile.
> Yep, running OpenSSH is enough.
> The system I'm currently writing from very much has the issue and is
> about... okay, so it's from june 21, so not as fresh as I thought, but
> relatively fresh.

Upgraded system and user profiles and the issue is still present.
M
M
Maxim Cournoyer wrote on 14 Jul 2022 22:05
(name . raingloom)(address . raingloom@riseup.net)(address . 47716-done@debbugs.gnu.org)
878rovwjcy.fsf@gmail.com
Hi,

raingloom <raingloom@riseup.net> writes:

Toggle quote (6 lines)
> ```
> $ gio mount sftp://whatever
> $ ls /run/user/$UID/gvfs/
> ```
> prints nothing.

Note that it seem to work if you are using the GNOME desktop.

Toggle quote (9 lines)
> Same thing happens if I mount it from the Nautilus file manager.
>
> This bug has appeared before and I still have no idea how it was fixed,
> which is not great. I'll do a bisect soon. Should probably add a system
> test for it so it doesn't break again.
>
> In the meantime, if whoever fixed it the last time could look into it
> again, I'd be very thankful. Using sshfs manually works but isn't great.

gvfs is now using fusermount3, but we were only adding 'fusermount' as a
setuid-program by default.

After adding fusermount3 from fuse@3 to /run/setuid-programs, it appears
to work:

$ guix shell glib:bin gvfs dbus fuse gnome-keyring
[env] PATH=/run/setuid-programs:$PATH dbus-run-session bash
[env] gio mount sftp://some-host:2345
( prompts for credentials )
ls /run/user/1000/gvfs/sftp:host=some-host,port=2345/
bin/ dev/ gnu/ [...]

I've pushed this as commit cbdfa54c77.

Closing.

Maxim
Closed
?