Toggle quote (101 lines)
> bo0od <bo0od@riseup.net> skribis:
>
>> Tell me any command you want the output for (or package to install) to
>> help solving this issue i will post it here.
>>
>> I have posted how my guix system configured/built here:
>>
>> https://issues.guix.gnu.org/47687
>
> I found <https://issues.guix.gnu.org/43293>, which was about the same
> issue; the solution was to install ‘font-dejavu’.
>
> I can reproduce the problem with the OS config you posted at
> <https://issues.guix.gnu.org/47687>. With that Xfce-only config,
> /run/current-system/profile lacks ‘font-dejavu’, hence the problem.
>
> The config in ‘vm-image.tmpl’ does not provide ‘font-dejavu’ but it
> provides ‘font-bitstream-vera’, which does the job.
>
> ‘font-dejavu’ is propagated by the ‘gnome’ package, which is why there’s
> no such problem when using ‘gnome-desktop-service-type’. The solution
> is to make sure one of these fonts is always installed by default.
>
> The attached patch does that. I’ll go ahead and push it if there are no
> objections.
>
> Thanks for reporting the issue!
>
> Ludo’.
>
>
> diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
> index 15ea89454f..079d60e45a 100644
> --- a/gnu/packages/enlightenment.scm
> +++ b/gnu/packages/enlightenment.scm
> @@ -36,6 +36,7 @@
> #:use-module (gnu packages code)
> #:use-module (gnu packages compression)
> #:use-module (gnu packages curl)
> + #:use-module (gnu packages fonts)
> #:use-module (gnu packages fontutils)
> #:use-module (gnu packages freedesktop)
> #:use-module (gnu packages fribidi)
> @@ -370,7 +371,10 @@ Libraries with some extra bells and whistles.")
> (propagated-inputs
> `(("efl" ,efl)
> ("libxkbcommon" ,libxkbcommon)
> - ("wayland-protocols" ,wayland-protocols)))
> + ("wayland-protocols" ,wayland-protocols)
> +
> + ;; Default font that applications such as IceCat require.
> + ("font-dejavu" ,font-dejavu)))
> (home-page "https://www.enlightenment.org/about-enlightenment")
> (synopsis "Lightweight desktop environment")
> (description
> diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
> index 44420147a3..82b2d6e0fd 100644
> --- a/gnu/packages/mate.scm
> +++ b/gnu/packages/mate.scm
> @@ -3,7 +3,7 @@
> ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
> ;;; Copyright © 2017 Nikita <nikita@n0.is>
> ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
> -;;; Copyright © 2019, 2020 Ludovic Courtès <ludo@gnu.org>
> +;;; Copyright © 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
> ;;; Copyright © 2019 Guy Fleury Iteriteka <hoonandon@gmail.com>
> ;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
> ;;; Copyright © 2020 Mathieu Othacehe <m.othacehe@gmail.com>
> @@ -1580,6 +1580,9 @@ used to bring up authentication dialogs.")
> ("shared-mime-info" ,shared-mime-info)
> ("yelp" ,yelp)
> ("zenity" ,zenity)))
> + (propagated-inputs
> + ;; Default font that applications such as IceCat require.
> + `(("font-dejavu" ,font-dejavu)))
> (synopsis "The MATE desktop environment")
> (home-page "https://mate-desktop.org/")
> (description
> diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
> index 5782fa9eac..299e39115a 100644
> --- a/gnu/packages/xfce.scm
> +++ b/gnu/packages/xfce.scm
> @@ -37,6 +37,7 @@
> #:use-module (gnu packages base)
> #:use-module (gnu packages calendar)
> #:use-module (gnu packages cdrom)
> + #:use-module (gnu packages fonts)
> #:use-module (gnu packages fontutils)
> #:use-module (gnu packages freedesktop)
> #:use-module (gnu packages gettext)
> @@ -1011,6 +1012,9 @@ on your desktop.")
> ("xfce4-clipman-plugin" ,xfce4-clipman-plugin)
> ("xfce4-pulseaudio-plugin" ,xfce4-pulseaudio-plugin)
> ("xfce4-xkb-plugin" ,xfce4-xkb-plugin)))
> + (propagated-inputs
> + ;; Default font that applications such as IceCat require.
> + `(("font-dejavu" ,font-dejavu)))
> (native-search-paths
> ;; For finding panel plugins.
> (package-native-search-paths xfce4-panel))
>