owncloud-client : "Could not read system exclude file"

  • Done
  • quality assurance status badge
Details
4 participants
  • Daniel Meißner
  • Daniel Meißner
  • Fulbert
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Fulbert
Severity
normal
F
F
Fulbert wrote on 9 Apr 2021 13:21
(address . bug-guix@gnu.org)
YHA4yGUCkIOVDEnb@bluewin.ch
Hello !

After setting up an account to a davs server, the synchronisation
fails with messages :

* On the GUI : "Could not read system exclude file"

* In log file :
20210409_1235_owncloud.log.0.gz:04-09 12:35:55:294 [ info sync.configfile ]: Adding system ignore list to csync: "/home/fulbert/etc/ownCloud/sync-exclude.lst"
20210409_1235_owncloud.log.0.gz:04-09 12:35:55:294 [ info sync.configfile ]: Adding user defined ignore list to csync: "/home/fulbert/.config/ownCloud/sync-exclude.lst"
20210409_1235_owncloud.log.0.gz:04-09 12:35:55:295 [ warning gui.folder ]: Could not read system exclude file

After a little web search, I have not found a way to change the
path to the *system* `sync-exclude.lst` file, whether through GUI,
configuration file or environement variable.

brutal workaround :
$ mkdir $HOME/etc/ownCloud
$ ln -s $HOME/.guix-profile/etc/ownCloud/sync-exclude.lst $HOME/etc/ownCloud

Thanks and best regards.
D
D
Daniel Meißner wrote on 16 Jun 2021 15:03
(address . 47672@debbugs.gnu.org)
87v96eufkw.fsf@ruhr-uni-bochum.de
Hi,

I have also noticed this issue and found the basis for my fix here:


The attached patch fixes this behaviour.

Best regards
Daniel
From 84b103e261ed1473cdd456b70dbf58626bb9f7ee Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Daniel=20Mei=C3=9Fner?=
<daniel.meissner-i4k@ruhr-uni-bochum.de>
Date: Wed, 16 Jun 2021 14:16:10 +0200
Subject: [PATCH] gnu: owncloud-client: Fix sysconfdir path

Somehow sysconfdir was not set correctly so that owncloud searched for
sync-exclude.lst in the relative path etc/ownCloud/sync-exclude.lst instead
of the /gnu/store/...-owncloud-client/etc/ownCloud/sync-exclude.lst.

* gnu/packages/sync.scm(owncloud-client): Add -DSYSCONF_INSTALL_DIR flag to
configure flags.
---
gnu/packages/sync.scm | 14 ++++++++++----
1 file changed, 10 insertions(+), 4 deletions(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index 2b64117dc6..f9c3855e08 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -341,10 +341,16 @@ See also: megacmd, the official tool set by MEGA.")
(("QCoreApplication::applicationFilePath\\()") "\"owncloud\""))
#t))
(delete 'patch-dot-desktop-files))
- #:configure-flags '("-DUNIT_TESTING=ON"
- ;; build without qtwebkit, which causes the
- ;; package to FTBFS while looking for QWebView.
- "-DNO_SHIBBOLETH=1")))
+ #:configure-flags `("-DUNIT_TESTING=ON"
+ ;; build without qtwebkit, which causes the
+ ;; package to FTBFS while looking for QWebView.
+ "-DNO_SHIBBOLETH=1"
+ ;; Fix sync-exclude.list problem
+ ;; See: https://github.com/owncloud/client/issues/8373
+ ;; See: https://issues.guix.gnu.org/47672
+ ,(string-append "-DSYSCONF_INSTALL_DIR="
+ (assoc-ref %outputs "out")
+ "/etc"))))
(native-inputs
`(("cmocka" ,cmocka)
("extra-cmake-modules" ,extra-cmake-modules)
--
2.32.0
D
D
Daniel Meißner wrote on 16 Jun 2021 14:16
[PATCH] gnu: owncloud-client: Fix sysconfdir path
(address . 47672@debbugs.gnu.org)
87k0muuhb8.fsf@ruhr-uni-bochum.de
Hi,

I have also noticed this issue and found a fix here:


Somehow sysconfdir is not set correctly so that owncloud searched for
sync-exclude.lst in the relative path etc/ownCloud/sync-exclude.lst instead
of the /gnu/store/...-owncloud-client/etc/ownCloud/sync-exclude.lst.

The following patch fixes this behaviour:

* gnu/packages/sync.scm(owncloud-client): Add -DSYSCONF_INSTALL_DIR flag to
configure flags.
---
gnu/packages/sync.scm | 14 ++++++++++----
1 file changed, 10 insertions(+), 4 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index 2b64117dc6..f9c3855e08 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -341,10 +341,16 @@ See also: megacmd, the official tool set by MEGA.")
(("QCoreApplication::applicationFilePath\\()") "\"owncloud\""))
#t))
(delete 'patch-dot-desktop-files))
- #:configure-flags '("-DUNIT_TESTING=ON"
- ;; build without qtwebkit, which causes the
- ;; package to FTBFS while looking for QWebView.
- "-DNO_SHIBBOLETH=1")))
+ #:configure-flags `("-DUNIT_TESTING=ON"
+ ;; build without qtwebkit, which causes the
+ ;; package to FTBFS while looking for QWebView.
+ "-DNO_SHIBBOLETH=1"
+ ;; Fix sync-exclude.list problem
+ ;; See: https://github.com/owncloud/client/issues/8373
+ ;; See: https://issues.guix.gnu.org/47672
+ ,(string-append "-DSYSCONF_INSTALL_DIR="
+ (assoc-ref %outputs "out")
+ "/etc"))))
(native-inputs
`(("cmocka" ,cmocka)
("extra-cmake-modules" ,extra-cmake-modules)
--
2.32.0

Best regards
Daniel
L
L
Liliana Marie Prikler wrote on 11 Oct 2021 15:28
Re: [PATCH] gnu: owncloud-client: Update to 2.9.0.5150.
(name . Daniel Meißner)(address . daniel.meissner-i4k@ruhr-uni-bochum.de)
abf2eb998ea1760023f2dd840f13240c60378872.camel@gmail.com
Am Montag, den 11.10.2021, 14:24 +0200 schrieb Daniel Meißner:
Toggle quote (9 lines)
> > Thanks for checking. Your workaround LGTM aside from indentation
> > which I can fix. If the updater is still patched away as intended,
> > I could apply it on top of this one. Did you check that as well?
>
> Cool, thanks, that would be great. I have not found any updater
> widgets in the GUI and the client did not seem to attempt any auto-
> updates. However, I have never used the owncloud-client outside Guix
> so I do not really know where the updater widget was in the first
> place. Sorry :/
Sounds good enough to me. Pushed both.

Thanks
Closed
?