CRAN importer does not parse “Remotes” field.

  • Open
  • quality assurance status badge
Details
One participant
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Ricardo Wurmus
Severity
normal
R
R
Ricardo Wurmus wrote on 8 Apr 2021 22:42
(address . bug-guix@gnu.org)
87a6q8y0cz.fsf@elephly.net
The CRAN importer can be used to import packages from CRAN and
Bioconductor, but also from arbitrary git and hg repositories.
Especially for code published as a git/hg repository the “Remotes” field
of the DESCRIPTION file can be important.

The bedtorch[1] package, for example, has a DESCRIPTION file like this:

Toggle snippet (44 lines)
Package: bedtorch
Type: Package
Title: R package for fast BED-file manipulation
Version: 0.1.8
Authors@R:
person(given = "Haizi",
family = "Zheng",
role = c("aut", "cre"),
email = "haizi.zh@gmail.com")
Description: The goal of bedtorch is to provide a fast BED file manipulation tool suite native in R.
License: MIT + file LICENSE
Encoding: UTF-8
LazyData: true
Roxygen: list(markdown = TRUE)
RoxygenNote: 7.1.1
Depends:
R (>= 4.0)
Imports:
stringr,
dplyr,
purrr,
tidyr,
data.table,
R.utils,
assertthat,
Rcpp,
Rhtslib12,
RCurl
Suggests:
testthat (>= 3.0.0),
devtools (>= 2.3.0),
zoo
Config/testthat/edition: 3
URL: https://github.com/haizi-zh/bedtorch
BugRePORTS: https://github.com/haizi-zh/bedtorch/issues
BiocType: Software
Remotes:
haizi-zh/Rhtslib12
LinkingTo:
Rcpp,
Rhtslib12
SystemRequirements: GNU make

The “Remotes” field specifies the origin for the Rhtslib fork. The
importer should probably try to import the packages from the “Remotes”
field first.

--
Ricardo
?