[PATCH 0/5] Update emacs-geiser

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Leo Prikler
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 4 years ago
(address . guix-patches@gnu.org)
BYAPR05MB4023349403C379CA3DB8AB7DC5769@BYAPR05MB4023.namprd05.prod.outlook.com
So emacs-geiser no longer bundles all the scheme stubs with the main install. That why I had to add emacs-geiser-guile to a bunch of inputs. I used guix refresh to check all the dependencies and it turned out I had to also update emacs-guix or it wouldn't build.

[PATCH 1/5] gnu: emacs-geiser: Update to 0.13.
[PATCH 2/5] gnu: Add emacs-geiser-guile.
[PATCH 3/5] gnu: emacs-guix: Update to 0.5.2-4.8ce6d21
[PATCH 4/5] gnu: emacs-flycheck-guile: Add missing input
[PATCH 5/5] gnu: guile-studio: Add missing input
Morgan.J.Smith wrote 4 years ago
[PATCH 1/5] gnu: emacs-geiser: Update to 0.13.
(address . 47626@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
BYAPR05MB4023153D9E4E6FFE76BFA09DC5769@BYAPR05MB4023.namprd05.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-geiser): Update to 0.13.
[source]: Change upstream URL
[build-system]: Change to emacs-build-system
[arguments]: Change phases completely
[native-inputs]: Remove emacs, autoconf, and automake
[description]: State that other packages are needed for geiser to be useful
---
gnu/packages/emacs-xyz.scm | 51 +++++++++++++++++++-------------------
1 file changed, 26 insertions(+), 25 deletions(-)

Toggle diff (76 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8e80ccbb56..1756f0cdec 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -217,43 +217,44 @@ (define-module (gnu packages emacs-xyz)
(define-public emacs-geiser
(package
(name "emacs-geiser")
- (version "0.12")
+ (version "0.13")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://gitlab.com/jaor/geiser/")
+ (url "https://gitlab.com/emacs-geiser/geiser.git")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0n718xpys7v94zaf9lpmsx97qgn6qxif1acr718wyvpmfr4hiv08"))))
- (build-system gnu-build-system)
+ (base32 "0bwjcfmcyv6z0i5ivqirgcibxdkrlf5vyxcbj7k8dk7flwg1fpd9"))))
+ (build-system emacs-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-after 'install 'post-install
- (lambda* (#:key outputs #:allow-other-keys)
- (symlink "geiser-install.el"
- (string-append (assoc-ref outputs "out")
- "/share/emacs/site-lisp/"
- "geiser-autoloads.el"))
- #t)))))
- (inputs
- `(("guile" ,guile-2.2)))
+ ;; Move the source files to the top level, which is included in
+ ;; the EMACSLOADPATH.
+ (add-after 'unpack 'move-source-files
+ (lambda _
+ (let ((el-files (find-files "./elisp" ".*\\.el$")))
+ (for-each (lambda (f)
+ (rename-file f (basename f)))
+ el-files))
+ #t))
+ (add-before 'install 'make-info
+ (lambda _
+ (with-directory-excursion "doc"
+ (invoke "makeinfo" "--no-split"
+ "-o" "geiser.info" "geiser.texi")))))))
(native-inputs
- `(("emacs" ,emacs-minimal)
- ("autoconf" ,autoconf)
- ("automake" ,automake)
- ("texinfo" ,texinfo)))
+ `(("texinfo" ,texinfo)))
(home-page "https://nongnu.org/geiser/")
- (synopsis "Collection of Emacs modes for Guile and Racket hacking")
- (description
- "Geiser is a collection of Emacs major and minor modes that conspire with
-one or more Scheme implementations to keep the Lisp Machine Spirit alive. The
-continuously running Scheme interpreter takes the center of the stage in
-Geiser. A bundle of Elisp shims orchestrates the dialog between the Scheme
-implementation, Emacs and, ultimately, the schemer, giving them access to live
-metadata.")
+ (synopsis "Collection of Emacs modes for Scheme hacking")
+ (description
+ "Geiser is a generic Scheme interaction mode that requires extra Scheme
+specific packages to be useful. The continuously running Scheme interpreter
+takes the center of the stage in Geiser. A bundle of Elisp shims orchestrates
+the dialog between the Scheme implementation, Emacs and, ultimately, the
+schemer, giving them access to live metadata.")
(license license:bsd-3)))
(define-public emacs-ac-geiser
--
2.31.1
Morgan.J.Smith wrote 4 years ago
[PATCH 2/5] gnu: Add emacs-geiser-guile.
(address . 47626@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
BYAPR05MB40237F19B96F06A7D828B8C5C5769@BYAPR05MB4023.namprd05.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-geiser-guile): New variable.
---
gnu/packages/emacs-xyz.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1756f0cdec..4d271c16cd 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -257,6 +257,44 @@ (define-public emacs-geiser
schemer, giving them access to live metadata.")
(license license:bsd-3)))
+(define-public emacs-geiser-guile
+ (package
+ (name "emacs-geiser-guile")
+ (version "0.13")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/emacs-geiser/guile.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0w264pjwlxna31260ll6gd0n77jlynhzf3h2dws5wr7jflns5mbc"))))
+ (build-system emacs-build-system)
+ (arguments
+ '(#:include (cons "^src/" %default-include)
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'move-elisp-files 'set-src-path
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (file "geiser-guile.el"))
+ (make-file-writable file)
+ (emacs-substitute-variables file
+ ("geiser-guile-scheme-dir"
+ (string-append out "/share/emacs/site-lisp/src/geiser")))
+ #t))))))
+ (inputs
+ `(("guile" ,guile-2.2)))
+ (propagated-inputs
+ `(("geiser" ,emacs-geiser)))
+ (home-page "https://nongnu.org/geiser/")
+ (synopsis "Guile Scheme support for Geiser")
+ (description
+ "This package adds support for the Guile Scheme implementation to Geiser,
+a generic Scheme interaction mode for the GNU Emacs editor.")
+ (license license:bsd-3)))
+
(define-public emacs-ac-geiser
(let ((commit "93818c936ee7e2f1ba1b315578bde363a7d43d05")
(revision "0"))
--
2.31.1
Morgan.J.Smith wrote 4 years ago
[PATCH 3/5] gnu: emacs-guix: Update to 0.5.2-4.8ce6d21
(address . 47626@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
BYAPR05MB4023D2A541ECB0A6B0E94C7DC5769@BYAPR05MB4023.namprd05.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-guix): Update to 0.5.2-4.8ce6d21
[source]: Update upstream URL
[propagated-inputs]: Add emacs-geiser-guile
---
gnu/packages/emacs-xyz.scm | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4d271c16cd..8c6d4c24bc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3032,8 +3032,8 @@ (define-public emacs-bui
(license license:gpl3+)))
(define-public emacs-guix
- (let* ((commit "a694fdbcedb6edd2239a31d326e475c763ee32f8")
- (revision "3"))
+ (let ((commit "8ce6d219e87c5097abff9ce6f1f5a4293cdfcb31")
+ (revision "4"))
(package
(name "emacs-guix")
(version (git-version "0.5.2" revision commit))
@@ -3041,12 +3041,12 @@ (define-public emacs-guix
(method git-fetch)
(uri (git-reference
;; TODO: Use the official version when it has a new home
- (url "https://github.com/jsoo1/guix.el")
+ (url "https://github.com/alezost/guix.el")
(commit commit)))
(file-name (git-file-name name version))
(sha256
(base32
- "1pqw7zbgxzwpig4xr0izc3z8h80c72i6bl5yi12br0d7aq6dbkvj"))))
+ "0awbd8x154c4dk4av7inpgd63n07xzng84vvc8qckmgljknc0j7k"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
@@ -3060,6 +3060,7 @@ (define-public emacs-guix
("guix" ,guix)))
(propagated-inputs
`(("geiser" ,emacs-geiser)
+ ("geiser-guile" ,emacs-geiser-guile)
("guile-gcrypt" ,guile-gcrypt)
("dash" ,emacs-dash)
("bui" ,emacs-bui)
--
2.31.1
Morgan.J.Smith wrote 4 years ago
[PATCH 4/5] gnu: emacs-flycheck-guile: Add missing input
(address . 47626@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
BYAPR05MB4023E5FD8C1285C4D4886179C5769@BYAPR05MB4023.namprd05.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-flycheck-guile)[propagated-inputs]:
Add emacs-geiser-guile
---
gnu/packages/emacs-xyz.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8c6d4c24bc..7ae58b7644 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5020,7 +5020,8 @@ (define-public emacs-flycheck-guile
(base32 "0cs5r0ik6a3bl1k3imjl0r8y1i69kx9x9m9cgxj470qk34brwyj5"))))
(propagated-inputs
`(("emacs-flycheck" ,emacs-flycheck)
- ("emacs-geiser" ,emacs-geiser)))
+ ("emacs-geiser" ,emacs-geiser)
+ ("emacs-geiser-guile" ,emacs-geiser-guile)))
(build-system emacs-build-system)
(home-page "https://github.com/flatwhatson/flycheck-guile")
(synopsis "GNU Guile support for Flycheck")
--
2.31.1
Morgan.J.Smith wrote 4 years ago
[PATCH 5/5] gnu: guile-studio: Add missing input
(address . 47626@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
BYAPR05MB40237AB3143C95DF2546F45BC5769@BYAPR05MB4023.namprd05.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/guile-xyz.scm (guile-studio)[inputs]:
Add emacs-geiser-guile
---
gnu/packages/guile-xyz.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index e2ee5454a0..9bfb19c333 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2750,6 +2750,7 @@ (define-public guile-studio
("emacs-doom-modeline" ,emacs-doom-modeline)
("emacs-modus-themes" ,emacs-modus-themes)
("emacs-geiser" ,emacs-geiser)
+ ("emacs-geiser-guile" ,emacs-geiser-guile)
("emacs-company" ,emacs-company)
("emacs-ivy" ,emacs-ivy)
("emacs-flycheck" ,emacs-flycheck)
--
2.31.1
Leo Prikler wrote 4 years ago
Re: [PATCH 2/5] gnu: Add emacs-geiser-guile.
1199133f9c89150e0893401c4444d2a0ffc327cb.camel@student.tugraz.at
Hi Morgan,

just a heads up, that this patch, which you've submitted for review,
will break with upcoming changes in emacs-build-system. Check out the
wip-emacs branch for more information.

Am Dienstag, den 06.04.2021, 17:33 -0400 schrieb
Morgan.J.Smith@outlook.com:
Toggle quote (45 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/emacs-xyz.scm (emacs-geiser-guile): New variable.
> ---
> gnu/packages/emacs-xyz.scm | 38
> ++++++++++++++++++++++++++++++++++++++
> 1 file changed, 38 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 1756f0cdec..4d271c16cd 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -257,6 +257,44 @@ (define-public emacs-geiser
> schemer, giving them access to live metadata.")
> (license license:bsd-3)))
>
> +(define-public emacs-geiser-guile
> + (package
> + (name "emacs-geiser-guile")
> + (version "0.13")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://gitlab.com/emacs-geiser/guile.git")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> "0w264pjwlxna31260ll6gd0n77jlynhzf3h2dws5wr7jflns5mbc"))))
> + (build-system emacs-build-system)
> + (arguments
> + '(#:include (cons "^src/" %default-include)
> + #:phases
> + (modify-phases %standard-phases
> + (add-after 'move-elisp-files 'set-src-path
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let ((out (assoc-ref outputs "out"))
> + (file "geiser-guile.el"))
> + (make-file-writable file)
> + (emacs-substitute-variables file
> + ("geiser-guile-scheme-dir"
> + (string-append out "/share/emacs/site-
> lisp/src/geiser")))
> + #t))))))
The site-lisp/src path is no longer valid, it should instead be
site-lisp/guile-geiser-<guile-geiser-version>/src.
Toggle quote (16 lines)
> + (inputs
> + `(("guile" ,guile-2.2)))
> + (propagated-inputs
> + `(("geiser" ,emacs-geiser)))
> + (home-page "https://nongnu.org/geiser/")
> + (synopsis "Guile Scheme support for Geiser")
> + (description
> + "This package adds support for the Guile Scheme implementation
> to Geiser,
> +a generic Scheme interaction mode for the GNU Emacs editor.")
> + (license license:bsd-3)))
> +
> (define-public emacs-ac-geiser
> (let ((commit "93818c936ee7e2f1ba1b315578bde363a7d43d05")
> (revision "0"))

Regards,
Leo
Leo Prikler wrote 4 years ago
e1cdb843ac8550d4f8ac49f197588034cc91a315.camel@student.tugraz.at
Hi again,

after the debugging we did together in IRC, some short exchange with
jaor and a bit of hacking, I pushed a working variant to wip-emacs.
I'm therefore going to mark this as done.

Am Mittwoch, den 07.04.2021, 12:24 +0200 schrieb Leo Prikler:
Toggle quote (76 lines)
> Hi Morgan,
>
> just a heads up, that this patch, which you've submitted for review,
> will break with upcoming changes in emacs-build-system. Check out
> the
> wip-emacs branch for more information.
>
> Am Dienstag, den 06.04.2021, 17:33 -0400 schrieb
> Morgan.J.Smith@outlook.com:
> > From: Morgan Smith <Morgan.J.Smith@outlook.com>
> >
> > * gnu/packages/emacs-xyz.scm (emacs-geiser-guile): New variable.
> > ---
> > gnu/packages/emacs-xyz.scm | 38
> > ++++++++++++++++++++++++++++++++++++++
> > 1 file changed, 38 insertions(+)
> >
> > diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-
> > xyz.scm
> > index 1756f0cdec..4d271c16cd 100644
> > --- a/gnu/packages/emacs-xyz.scm
> > +++ b/gnu/packages/emacs-xyz.scm
> > @@ -257,6 +257,44 @@ (define-public emacs-geiser
> > schemer, giving them access to live metadata.")
> > (license license:bsd-3)))
> >
> > +(define-public emacs-geiser-guile
> > + (package
> > + (name "emacs-geiser-guile")
> > + (version "0.13")
> > + (source
> > + (origin
> > + (method git-fetch)
> > + (uri (git-reference
> > + (url "https://gitlab.com/emacs-geiser/guile.git")
> > + (commit version)))
> > + (file-name (git-file-name name version))
> > + (sha256
> > + (base32
> > "0w264pjwlxna31260ll6gd0n77jlynhzf3h2dws5wr7jflns5mbc"))))
> > + (build-system emacs-build-system)
> > + (arguments
> > + '(#:include (cons "^src/" %default-include)
> > + #:phases
> > + (modify-phases %standard-phases
> > + (add-after 'move-elisp-files 'set-src-path
> > + (lambda* (#:key outputs #:allow-other-keys)
> > + (let ((out (assoc-ref outputs "out"))
> > + (file "geiser-guile.el"))
> > + (make-file-writable file)
> > + (emacs-substitute-variables file
> > + ("geiser-guile-scheme-dir"
> > + (string-append out "/share/emacs/site-
> > lisp/src/geiser")))
> > + #t))))))
> The site-lisp/src path is no longer valid, it should instead be
> site-lisp/guile-geiser-<guile-geiser-version>/src.
> > + (inputs
> > + `(("guile" ,guile-2.2)))
> > + (propagated-inputs
> > + `(("geiser" ,emacs-geiser)))
> > + (home-page "https://nongnu.org/geiser/")
> > + (synopsis "Guile Scheme support for Geiser")
> > + (description
> > + "This package adds support for the Guile Scheme
> > implementation
> > to Geiser,
> > +a generic Scheme interaction mode for the GNU Emacs editor.")
> > + (license license:bsd-3)))
> > +
> > (define-public emacs-ac-geiser
> > (let ((commit "93818c936ee7e2f1ba1b315578bde363a7d43d05")
> > (revision "0"))
>
> Regards,
> Leo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 47626@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 47626
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help