adds emacs-lockstep

  • Open
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • rdes
Owner
unassigned
Submitted by
rdes
Severity
normal
R
(name . rdes via Guix-patches via)(address . guix-patches@gnu.org)
9mcgTSrn2rNFyA9Pf_V8_dMVTY7brHQTHqGiBo-fKqnjT5UbR8jmj2Y3Q0lEAv6dX9JuFLRiTLMEXqtjSQxERh2zutObssHHl0uj7DJ42CU=@protonmail.com
Hello,

The attached patch adds emacs-lockstep.

Sent with [ProtonMail](https://protonmail.com) Secure Email.
Attachment: file
From 94d1c51adcef16ee8fe1b6e20938a34323363173 Mon Sep 17 00:00:00 2001
From: Ryan Desfosses <ryan.desfo@gmail.com>
Date: Mon, 5 Apr 2021 22:12:30 -0400
Subject: [PATCH] gnu/packages/emacs-xyz.scm (emacs-lockstep): New variable.

---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 239915fffe..2e277eb6b6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27566,3 +27566,31 @@ and prefered services can easily be configured.")
quasi-prefix map, with many useful bindings. These bindings are
shorter than usual, using mostly unprefixed keys.")
(license license:gpl3+)))
+
+(define-public emacs-lockstep
+ (let ((commit "5fe78e94533c4a050d3fce23685040ac754c2e54"))
+ (package
+ (name "emacs-lockstep")
+ (version "0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tjim/lockstep")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "16c5qq0zkzc7g444kmv88kly8g4xmwy6rfac4ndgfvxwfq5r7jj6"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/tjim/lockstep")
+ (synopsis
+ "Pair program in Emacs")
+ (description
+ "Lockstep is a package for pair programming in Emacs. It synchronizes
+the windows and points of two or more Emacs frames, so that a team of
+programmers can share an editing session.
+
+BE CAREFUL: any programmer in the session will be able to control the Emacs
+process running as the user who started the Emacs server.")
+ (license license:gpl3+))))
--
2.31.1
N
N
Nicolas Goaziou wrote on 11 Apr 2021 11:00
(name . rdes via Guix-patches via)(address . guix-patches@gnu.org)
871rbhrya7.fsf@nicolasgoaziou.fr
Hello,

rdes via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> The attached patch adds emacs-lockstep.

Thank you. Some comments follow.

Toggle quote (3 lines)
> +(define-public emacs-lockstep
> + (let ((commit "5fe78e94533c4a050d3fce23685040ac754c2e54"))

A comment should explain why we're using a commit hash instead of a tag.

Toggle quote (4 lines)
> + (package
> + (name "emacs-lockstep")
> + (version "0.1")

This is not the correct version. Actually, I couldn't find any reference
to a version at all in the file, so it should be "0", with a comment.

Toggle quote (3 lines)
> + (synopsis
> + "Pair program in Emacs")

Nitpick: Pair programming in Emacs

Toggle quote (8 lines)
> + (description
> + "Lockstep is a package for pair programming in Emacs. It synchronizes
> +the windows and points of two or more Emacs frames, so that a team of
> +programmers can share an editing session.
> +
> +BE CAREFUL: any programmer in the session will be able to control the Emacs
> +process running as the user who started the Emacs server.")

Nitpick:

Be careful! All programmers see the same buffers and live edits, and
any programmer can take over the editing session.

Toggle quote (2 lines)
> + (license license:gpl3+))))

Unfortunately, I see no reference whatsoever to a license in the code
base. I don't think we can infer this is GPL3+. What makes you think so?

Regards,
--
Nicolas Goaziou
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 47608@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 47608
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch