(name . rdes via Guix-patches via)(address . guix-patches@gnu.org)
Hello,
The attached patch adds emacs-lockstep.
Sent with [ProtonMail](https://protonmail.com) Secure Email.
From 94d1c51adcef16ee8fe1b6e20938a34323363173 Mon Sep 17 00:00:00 2001
From: Ryan Desfosses <ryan.desfo@gmail.com>
Date: Mon, 5 Apr 2021 22:12:30 -0400
Subject: [PATCH] gnu/packages/emacs-xyz.scm (emacs-lockstep): New variable.
---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)
Toggle diff (38 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 239915fffe..2e277eb6b6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27566,3 +27566,31 @@ and prefered services can easily be configured.")
quasi-prefix map, with many useful bindings. These bindings are
shorter than usual, using mostly unprefixed keys.")
(license license:gpl3+)))
+
+(define-public emacs-lockstep
+ (let ((commit "5fe78e94533c4a050d3fce23685040ac754c2e54"))
+ (package
+ (name "emacs-lockstep")
+ (version "0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tjim/lockstep")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "16c5qq0zkzc7g444kmv88kly8g4xmwy6rfac4ndgfvxwfq5r7jj6"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/tjim/lockstep")
+ (synopsis
+ "Pair program in Emacs")
+ (description
+ "Lockstep is a package for pair programming in Emacs. It synchronizes
+the windows and points of two or more Emacs frames, so that a team of
+programmers can share an editing session.
+
+BE CAREFUL: any programmer in the session will be able to control the Emacs
+process running as the user who started the Emacs server.")
+ (license license:gpl3+))))
--
2.31.1