[PATCH] gnu: Add emacs-mode-line-idle.

  • Done
  • quality assurance status badge
Details
2 participants
  • Eugene Klimov
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Eugene Klimov
Severity
normal
E
E
Eugene Klimov wrote on 5 Apr 2021 22:08
(address . guix-patches@gnu.org)(name . Eugene Klimov)(address . lipklim@mailbox.org)
20210405200807.30111-1-lipklim@mailbox.org
* gnu/packages/emacs-xyz.scm (emacs-mode-line-idle): New variable.
---
gnu/packages/emacs-xyz.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 239915fffe..ea9f3bfcd1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -96,6 +96,7 @@
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2021 Eugene Klimov <lipklim@mailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27566,3 +27567,34 @@ and prefered services can easily be configured.")
quasi-prefix map, with many useful bindings. These bindings are
shorter than usual, using mostly unprefixed keys.")
(license license:gpl3+)))
+
+(define-public emacs-mode-line-idle
+ ;; Package has no release. Version is extracted from "Version:" keyword in
+ ;; main file.
+ (let ((commit "02b1da6278e43cc9cc0356110cc6bfbb37eb8241")
+ (revision "1"))
+ (package
+ (name "emacs-mode-line-idle")
+ (version (git-version "0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/ideasman42/emacs-mode-line-idle.git")
+ (commit commit)))
+ (sha256 (base32 "0ky330b2sfbzkbxbfp9b21hdywsjw26bllspglz08hrbni7jmry8"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (home-page "https://gitlab.com/ideasman42/emacs-mode-line-idle")
+ (synopsis "Simple delayed text evaluation for the mode-line")
+ (description
+ "Mode Line Idle (mode-line-idle.el) is a minor mode that
+provides a convenient way to defer text evaluation in a way that can
+be easily integrated into existing mode-line's without requiring a
+minor mode or configuration.
+
+Mode Line Idle helps to add useful information into the mode-line
+without slowing down Emacs performance. While delaying updates is not
+so difficult, having multiple timers can become awkward when mixed in
+with the mode-lines configuration. Instead of avoiding expensive
+information in the mode-line, it can be calculated when idle.")
+ (license license:gpl3+))))
--
2.31.1
N
N
Nicolas Goaziou wrote on 11 Apr 2021 11:11
(name . Eugene Klimov via Guix-patches via)(address . guix-patches@gnu.org)
87wnt9qj81.fsf@nicolasgoaziou.fr
Hello,

Eugene Klimov via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-mode-line-idle): New variable.

Thank you. I applied the patch with the tweaks below.

Toggle quote (5 lines)
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://gitlab.com/ideasman42/emacs-mode-line-idle.git")

I removed the ".git" suffix

Toggle quote (6 lines)
> + (description
> + "Mode Line Idle (mode-line-idle.el) is a minor mode that
> +provides a convenient way to defer text evaluation in a way that can
> +be easily integrated into existing mode-line's without requiring a
> +minor mode or configuration.

I slightly reworded this part, which looks very odd, to say the least.

Toggle quote (6 lines)
> +Mode Line Idle helps to add useful information into the mode-line
> +without slowing down Emacs performance. While delaying updates is not
> +so difficult, having multiple timers can become awkward when mixed in
> +with the mode-lines configuration. Instead of avoiding expensive
> +information in the mode-line, it can be calculated when idle.")

I removed this part of the description, since it is a detail of
implementation.

For future patches, please avoid inserting the package definition at the
end of the file, as this is more likely to introduce merge conflicts.
You wouldn't want to make my life miserable, would you ? ;)

Regards,
--
Nicolas Goaziou
?