[PATCH]: gnu: Add umbra, shadow, cpus; golden-utils Upgrade to 0.0.0-2.62a5cb9.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 years ago
(address . guix-patches@gnu.org)
CAO+9K5qVRkVF6XkwsgjNa98cOBEK2buBwxm=okQV3tyaxfcU2w@mail.gmail.com
Hi Guix team!
Few more patches from a list of inputs for ViraliiEngine
shadows requires upgrade of golden-utils
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 6847059c1e584b4689b34c0b92a7e907250aed67 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sat, 3 Apr 2021 22:09:41 +0100
Subject: [PATCH] gnu: Add umbra

* gnu/packages/lisp-xyz.scm: (sbcl-umbra, cl-umbra, ecl-umbra): New variables
---
gnu/packages/lisp-xyz.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 23de14c2de..86c7dae366 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -15652,3 +15652,35 @@ OpenGL (Mesa), GLU and GLUT (FreeGLUT) APIs using CFFI.")
(define-public cl-shadow
(sbcl-package->cl-source-package sbcl-shadow))
+
+(define-public sbcl-umbra
+ (let ((commit "d6ef2f6cbfa26180929061129eaf325bf17f73d8")
+ (revision "1"))
+ (package
+ (name "sbcl-umbra")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.mfiano.net/mfiano/umbra")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04vyh2j00zdpb8ryxr8g81wjcmqlz9wrn55r3cypcj4qg970r5wi"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("golden-utils" ,sbcl-golden-utils)
+ ("shadow" ,sbcl-shadow)
+ ("varjo" ,sbcl-varjo)))
+ (home-page "https://git.mfiano.net/mfiano/umbra")
+ (synopsis "Common Lisp library of reusable GPU shader functions")
+ (description
+ "Common Lisp library of reusable GPU shader functions")
+ (license license:expat))))
+
+(define-public ecl-umbra
+ (sbcl-package->ecl-package sbcl-umbra))
+
+(define-public cl-umbra
+ (sbcl-package->cl-source-package sbcl-umbra))
--
2.29.2
From d2c976dd5e5d7be41a7f5b66278283093296ef9d Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sat, 3 Apr 2021 22:22:29 +0100
Subject: [PATCH] gnu: Add cl-cpus

* gnu/packages/lisp-xyz.scm: (sbcl-cl-cpus, cl-cpus, ecl-cl-cpus): New variables
---
gnu/packages/lisp-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 86c7dae366..f5cece4ed5 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -15335,6 +15335,35 @@ line tool @code{df} and get disk space information using @code{statvfs}.")
(define-public cl-diskspace
(sbcl-package->cl-source-package sbcl-cl-diskspace))
+(define-public sbcl-cl-cpus
+ (package
+ (name "sbcl-cl-cpus")
+ (version "0.0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/muyinliu/cl-cpus")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0sdaff9hpsx7bpkkkqavmxmrrlc2d61gmqjjgn8xchncng4a0rf8"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("cffi" ,sbcl-cffi)))
+ (home-page "https://github.com/muyinliu/cl-cpus")
+ (synopsis "Common Lisp feature to get number of CPUs")
+ (description
+ "This package provides Common Lisp system which has only one function to
+returns CPU count of the current system.")
+ (license license:isc)))
+
+(define-public ecl-cl-cpus
+ (sbcl-package->ecl-package sbcl-cl-cpus))
+
+(define-public cl-cpus
+ (sbcl-package->cl-source-package sbcl-cl-cpus))
+
(define-public sbcl-fof
(package
(name "sbcl-fof")
--
2.29.2
From f59764fdd3fc44e45c5bcbb50e26930f617a1bba Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sat, 3 Apr 2021 21:57:54 +0100
Subject: [PATCH] gnu: Add shadow (Common Lisp)

* gnu/packages/lisp-xyz.scm: (sbcl-shadow, cl-shadow, ecl-shadow): New variables.
---
gnu/packages/lisp-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 0a1dd7504e..23de14c2de 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -15617,3 +15617,38 @@ OpenGL (Mesa), GLU and GLUT (FreeGLUT) APIs using CFFI.")
(define-public cl-opengl
(sbcl-package->cl-source-package sbcl-cl-opengl))
+
+(define-public sbcl-shadow
+ (let ((commit "b2031adbfba3579b48c9d39ad997e19b79b6852f")
+ (revision "1"))
+ (package
+ (name "sbcl-shadow")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.mfiano.net/mfiano/shadow")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0w1i734gkdkziin74ql2nhx7jdjxx02ylssaa6qdrvnj4br1124a"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("cffi" ,sbcl-cffi)
+ ("cl-opengl" ,sbcl-cl-opengl)
+ ("glsl-packing" ,sbcl-glsl-packing)
+ ("golden-utils" ,sbcl-golden-utils)
+ ("varjo" ,sbcl-varjo)
+ ("static-vectors" ,sbcl-static-vectors)))
+ (home-page "https://git.mfiano.net/mfiano/shadow")
+ (synopsis "Management system for OpenGL shader programs and associated buffer objects")
+ (description
+ "Management system for OpenGL shader programs and associated buffer objects")
+ (license license:expat))))
+
+(define-public ecl-shadow
+ (sbcl-package->ecl-package sbcl-shadow))
+
+(define-public cl-shadow
+ (sbcl-package->cl-source-package sbcl-shadow))
--
2.29.2
From ffc0292912e435406228e8560b3495d382036374 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sat, 3 Apr 2021 21:39:56 +0100
Subject: [PATCH] gnu: golden-utils: Update to 0.0.0-2.62a5cb9

---
gnu/packages/lisp-xyz.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 9eb937314e..0a1dd7504e 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -161,8 +161,8 @@ collection.")
(sbcl-package->cl-source-package sbcl-bodge-utilities))
(define-public sbcl-golden-utils
- (let ((commit "9424419d867d5c2f819196ee41667a818a5058e7")
- (revision "1"))
+ (let ((commit "62a5cb948a011eb26e7a89f56d5839a3334b4100")
+ (revision "2"))
(package
(name "sbcl-golden-utils")
(version (git-version "0.0.0" revision commit))
@@ -174,7 +174,7 @@ collection.")
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "15x0phm6820yj3h37ibi06gjyh6z45sd2nz2n8lcbfflwm086q0h"))))
+ (base32 "13mvxqwd1nmpq8h5hb1s60wyqdj7ji4haxrqr0sy3csyqa8aq2j8"))))
(build-system asdf-build-system/sbcl)
(inputs
`(("alexandria" ,sbcl-alexandria)))
--
2.29.2
Guillaume Le Vaillant wrote 4 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 47586-done@debbugs.gnu.org)
877dlgj4n1.fsf@yamatai
Patches pushed as b54fc8f54ed77341dd64d983cbcb66cc642acbc2 and following
with a few modifications to some synopsis, descriptions or commit
messages.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYGsCwg8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8h3AD/UgtFc8GjSG84KFsOyHo00fidoNqzItU3MjkO
34rdhWEA/3OqCwUQsS6GD7TUOEa/rpIB9dRrPjHpRa2G52lms5t1
=GXIN
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 47586@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 47586
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help