MIA 2.4.6 fails to build

  • Open
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Ludovic Courtès
Owner
unassigned
Submitted by
Ludovic Courtès
Severity
normal
L
L
Ludovic Courtès wrote on 2 Apr 2021 09:09
(address . bug-guix@gnu.org)
87a6qh40yq.fsf@inria.fr
MIA 2.4.6 fails to build as of 9098745b181b3022587a35afd255f7ff1d41ac86
presumably due to CMake shenanigans as reported here:


Build failure looks like this:

Toggle snippet (16 lines)
[ 13%] Building CXX object mia/core/CMakeFiles/test-core.dir/test_core_combined.cc.o
cd /tmp/guix-build-mia-2.4.6.drv-0/build/mia/core && /gnu/store/rn75fm7adgx3pw5j8pg3bczfqq1y17lk-gcc-7.5.0/bin/c++ -DBOOST_ALL_DYN_LINK -DBOOST_ALL_NO_LIB -DBOOST_FILESYSTEM_DYN_LINK -DBOOST_FILESYSTEM_VERSION=3 -DBOOST_SYSTEM_DYN_LINK -DBOOST_UNIT_TEST_FRAMEWORK_DYN_LINK -DHAVE_CONFIG_H -I/gnu/store/n50ikpnyzdda0zklwnmqasklcrif2csg-eigen-3.3.8/include/eigen3 -I/gnu/store/c8w9z48vvx2a3q3k44ch9yn00wk1qwhb-libxml2-2.9.10/include/libxml2 -I/tmp/guix-build-mia-2.4.6.drv-0/build -I/tmp/guix-build-mia-2.4.6.drv-0/mia-2.4.6 -fpermissive -fvisibility=hidden -O2 -g -DNDEBUG -o CMakeFiles/test-core.dir/test_core_combined.cc.o -c /tmp/guix-build-mia-2.4.6.drv-0/mia-2.4.6/mia/core/test_core_combined.cc
/tmp/guix-build-mia-2.4.6.drv-0/mia-2.4.6/addons/vtk/vtkmesh.cc: In function ‘void vtkmia::read_normals(mia::CTriangleMesh&, vtkPointData&)’:
/tmp/guix-build-mia-2.4.6.drv-0/mia-2.4.6/addons/vtk/vtkmesh.cc:179:12: error: ‘class vtkFloatArray’ has no member named ‘GetTupleValue’; did you mean ‘GetValue’?
normals->GetTupleValue(i, &is->x);
^~~~~~~~~~~~~
GetValue
/tmp/guix-build-mia-2.4.6.drv-0/mia-2.4.6/addons/vtk/vtkmesh.cc: In function ‘void vtkmia::read_colors(mia::CTriangleMesh&, vtkPointData&)’:
/tmp/guix-build-mia-2.4.6.drv-0/mia-2.4.6/addons/vtk/vtkmesh.cc:211:11: error: ‘class vtkFloatArray’ has no member named ‘GetTupleValue’; did you mean ‘GetValue’?
colors->GetTupleValue(i, &is->x);
^~~~~~~~~~~~~
GetValue
make[2]: *** [addons/vtk/CMakeFiles/mesh-io-vtkmesh-common.dir/build.make:66: addons/vtk/CMakeFiles/mesh-io-vtkmesh-common.dir/vtkmesh.cc.o] Error 1
make[2]: Leaving directory '/tmp/guix-build-mia-2.4.6.drv-0/build'

The problem here is what we’re missing -I flags for VTK, which might be
a CMake incompatibility issue.

Thoughts?

Ludo’.
E
E
Efraim Flashner wrote on 6 May 2021 13:51
(name . Ludovic Courtès)(address . ludovic.courtes@inria.fr)(address . 47561@debbugs.gnu.org)
YJPYOUCGTk+hfNKJ@3900XT
On Fri, Apr 02, 2021 at 09:09:17AM +0200, Ludovic Courtès wrote:
Toggle quote (31 lines)
> MIA 2.4.6 fails to build as of 9098745b181b3022587a35afd255f7ff1d41ac86
> presumably due to CMake shenanigans as reported here:
>
> https://issues.guix.gnu.org/46724#9
>
> Build failure looks like this:
>
> --8<---------------cut here---------------start------------->8---
> [ 13%] Building CXX object mia/core/CMakeFiles/test-core.dir/test_core_combined.cc.o
> cd /tmp/guix-build-mia-2.4.6.drv-0/build/mia/core && /gnu/store/rn75fm7adgx3pw5j8pg3bczfqq1y17lk-gcc-7.5.0/bin/c++ -DBOOST_ALL_DYN_LINK -DBOOST_ALL_NO_LIB -DBOOST_FILESYSTEM_DYN_LINK -DBOOST_FILESYSTEM_VERSION=3 -DBOOST_SYSTEM_DYN_LINK -DBOOST_UNIT_TEST_FRAMEWORK_DYN_LINK -DHAVE_CONFIG_H -I/gnu/store/n50ikpnyzdda0zklwnmqasklcrif2csg-eigen-3.3.8/include/eigen3 -I/gnu/store/c8w9z48vvx2a3q3k44ch9yn00wk1qwhb-libxml2-2.9.10/include/libxml2 -I/tmp/guix-build-mia-2.4.6.drv-0/build -I/tmp/guix-build-mia-2.4.6.drv-0/mia-2.4.6 -fpermissive -fvisibility=hidden -O2 -g -DNDEBUG -o CMakeFiles/test-core.dir/test_core_combined.cc.o -c /tmp/guix-build-mia-2.4.6.drv-0/mia-2.4.6/mia/core/test_core_combined.cc
> /tmp/guix-build-mia-2.4.6.drv-0/mia-2.4.6/addons/vtk/vtkmesh.cc: In function ‘void vtkmia::read_normals(mia::CTriangleMesh&, vtkPointData&)’:
> /tmp/guix-build-mia-2.4.6.drv-0/mia-2.4.6/addons/vtk/vtkmesh.cc:179:12: error: ‘class vtkFloatArray’ has no member named ‘GetTupleValue’; did you mean ‘GetValue’?
> normals->GetTupleValue(i, &is->x);
> ^~~~~~~~~~~~~
> GetValue
> /tmp/guix-build-mia-2.4.6.drv-0/mia-2.4.6/addons/vtk/vtkmesh.cc: In function ‘void vtkmia::read_colors(mia::CTriangleMesh&, vtkPointData&)’:
> /tmp/guix-build-mia-2.4.6.drv-0/mia-2.4.6/addons/vtk/vtkmesh.cc:211:11: error: ‘class vtkFloatArray’ has no member named ‘GetTupleValue’; did you mean ‘GetValue’?
> colors->GetTupleValue(i, &is->x);
> ^~~~~~~~~~~~~
> GetValue
> make[2]: *** [addons/vtk/CMakeFiles/mesh-io-vtkmesh-common.dir/build.make:66: addons/vtk/CMakeFiles/mesh-io-vtkmesh-common.dir/vtkmesh.cc.o] Error 1
> make[2]: Leaving directory '/tmp/guix-build-mia-2.4.6.drv-0/build'
> --8<---------------cut here---------------end--------------->8---
>
> The problem here is what we’re missing -I flags for VTK, which might be
> a CMake incompatibility issue.
>
> Thoughts?
>
> Ludo’.

Debian builds mia with vtk@7, which is the one we're missing between 6
and 9.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmCT2DcACgkQQarn3Mo9
g1E61hAAieXTjUyL/E2A3smYX6SkkUFqVgUpaYrHPO/w7/GHJl1e3JF6Z0cEyRAG
z3uIYgKX6S0aL4CDRPK9FzjQelbCrucsqPNk+1wNUcqICKR5oq44wTnx9WYkDjH6
J2F+OjAxiLk4cmnMSeFbMnFJ8OZ4uH6GB5EseOuAIZMOAvmARAWYWPJQvaBvKemZ
3tKqBrdNfYRDyHLEgGM6vGR54VGqpam5nXUGVusbxLv/opNKyDe+VKY138jsQm3g
r4+/ukjfyfpWfM75IDKOzUY0eqGqYgKPbKJuYbm7hMnFF7YIUDp8SuXMWZX2ta8p
Y+j2ei6OhgkgEhzPO+ky2XZzf1eLFYgQMgbtMuEkqBbK4gEK453ciV9ZZJXMTnLL
+Z6bzNs4Vog5QhD3rpTgFKiteJRxgmxXNzMwPMxL+qUx/7VNOPD2PKU+ZK0KYkWx
3X8KZvf9dI6fC+WUW0+HS51ni0cz7mv/TXyXaC3Syo2vhypPjLnSAob1Uvs3tq9z
f4Ki5lDPjh0rrQd8IeNrGGymQnyJUk6NUJLNtiFa/vIh1/h4EKZ2vNwe8D8Ty3ae
s8pb1RWdvJqqza2B/nLsyr3luCPbd2btan1nGm+FhGflxixQC66R6Ri8KUg1AqvJ
VVqdvje+eSz2qQVG5XcvLo1umD0VwMKLUMhHCRMY1ZkzvVgu8Xw=
=5JOA
-----END PGP SIGNATURE-----


?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 47561@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 47561
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch