(address . bug-guix@gnu.org)
Hello!
I am attempting to package this piece of software:
However I am having issues understanding exactly how to deal with its
non-standard build process.
I have attached the work I have already done to this email.
Could anyone help me understand where I am going wrong?
Thanks so much for your time (:
~vidak
@vidak@awkward.company
(define-module (gnu packages megazeux)
#:use-module (ice-9 match)
#:use-module (guix packages)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages autotools)
#:use-module (gnu packages build-tools)
#:use-module (gnu packages xiph)
#:use-module (gnu packages game-development)
#:use-module (gnu packages image)
#:use-module (gnu packages sdl)
#:use-module (gnu packages pkg-config))
(define-public megazeux
(let ((commit "eb04c509c80f42af331bb1aa0bde7b31df4dd28e")
(revision "1"))
(package
(name "megazeux")
(version (git-version "2.92f" revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/AliceLR/megazeux/")
(commit commit)))
(file-name (git-file-name name version))
(sha256
(base32
"15zbqwyi34m810njylfahgbr2w0sswqbb632vrgr9yd1aayzg9pj"))
(modules '((guix build utils)))))
(build-system gnu-build-s)
(outputs '("out" "debug"))
(arguments
`(#:tests? #f
#:modules ((guix build utils))
#:configure-flags '("--platform unix")
#:make-flags (list (string-append "prefix=" (assoc-ref %outputs "out"))
"CC=gcc")
#:phases
(modify-phases %standard-phases
(replace 'configure
(lambda* (#:key outputs (configure-flags '()) #:allow-other-keys)
(apply invoke "./config.sh" configure-flags)))
)))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
`(("libpng" ,libpng)
("libogg" ,libogg)
("libvorbis" ,libvorbis)
("sdl2" ,sdl2)))
(home-page "https://www.digitalmzx.com/")
(synopsis "The MegaZeux game creation system.")
(description
"MegaZeux is a game creation system (GCS) created by game
developer Alexis Janson in 1994. Originally a DOS program, in 2005 a
multi-platform port was released by Exophase.")
(license license:gpl2))))
megazeux