david larsson wrote 4 years ago
(address . guix-patches@gnu.org)
From 22cc953d3e663bb842d5a0b970577a3d54f6fef1 Mon Sep 17 00:00:00 2001
From: methuselah-0 <david.larsson@selfhosted.xyz>
Date: Thu, 1 Apr 2021 15:10:45 +0200
Subject: [PATCH] gnu: Add prips.
* gnu/packages/admin.scm (prips): New variable.
---
gnu/packages/admin.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)
Toggle diff (56 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index df7973395d..f6cb62a568 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -39,6 +39,7 @@
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 qblade <qblade@protonmail.com>
;;; Copyright © 2021 Hyunseok Kim <lasnesne@lagunposprasihopre.org>
+;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1019,6 +1020,39 @@ recursive runs on the generated subnets. (also
IPv6)
@end itemize\n")
(license license:bsd-3)))
+(define-public prips
+ (package
+ (name "prips")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://devel.ringlet.net/files/sys/"
+ name "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
"1a33vbl4w603mk6mm5r3vhk87fy3dfk5wdpch0yd3ncbkg3fmvqn"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags (list "CC=gcc")
+ #:phases (modify-phases
+ %standard-phases
+ (delete 'configure)
+ (delete 'check)
+ (replace 'install
+ (lambda _
+ (let*
+ ((bin-dir (string-append %output "/bin"))
+ (bin-file (string-append bin-dir "/prips")))
+ (mkdir-p bin-dir)
+ (copy-file "prips" bin-file)
+ (chmod bin-file #o700)))))))
+ (synopsis "Tool that prints the IP addresses in a given range")
+ (description "Prips can be used to print all of the IP addresses in
+ a given range. This allows the enhancement of tools only work
+ on one host at a time (e.g. whois).")
+ (home-page "https://devel.ringlet.net/sysutils/prips/")
+ (license license:gpl2)))
+
(define-public alive
(package
(name "alive")
--
2.30.2
From 22cc953d3e663bb842d5a0b970577a3d54f6fef1 Mon Sep 17 00:00:00 2001
From: methuselah-0 <david.larsson@selfhosted.xyz>
Date: Thu, 1 Apr 2021 15:10:45 +0200
Subject: [PATCH] gnu: Add prips.
* gnu/packages/admin.scm (prips): New variable.
---
gnu/packages/admin.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)
Toggle diff (54 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index df7973395d..f6cb62a568 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -39,6 +39,7 @@
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 qblade <qblade@protonmail.com>
;;; Copyright © 2021 Hyunseok Kim <lasnesne@lagunposprasihopre.org>
+;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1019,6 +1020,39 @@ recursive runs on the generated subnets. (also IPv6)
@end itemize\n")
(license license:bsd-3)))
+(define-public prips
+ (package
+ (name "prips")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://devel.ringlet.net/files/sys/"
+ name "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32 "1a33vbl4w603mk6mm5r3vhk87fy3dfk5wdpch0yd3ncbkg3fmvqn"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags (list "CC=gcc")
+ #:phases (modify-phases
+ %standard-phases
+ (delete 'configure)
+ (delete 'check)
+ (replace 'install
+ (lambda _
+ (let*
+ ((bin-dir (string-append %output "/bin"))
+ (bin-file (string-append bin-dir "/prips")))
+ (mkdir-p bin-dir)
+ (copy-file "prips" bin-file)
+ (chmod bin-file #o700)))))))
+ (synopsis "Tool that prints the IP addresses in a given range")
+ (description "Prips can be used to print all of the IP addresses in
+ a given range. This allows the enhancement of tools only work
+ on one host at a time (e.g. whois).")
+ (home-page "https://devel.ringlet.net/sysutils/prips/")
+ (license license:gpl2)))
+
(define-public alive
(package
(name "alive")
--
2.30.2