specification->package does not seem to support outputs

  • Done
  • quality assurance status badge
Details
3 participants
  • fsdfsdfsd3
  • Leo Prikler
  • Ludovic Courtès
Owner
unassigned
Submitted by
fsdfsdfsd3
Severity
normal
F
F
fsdfsdfsd3 wrote on 1 Apr 2021 05:50
(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)
2D4cPuIPCu0T9VFO7m3XPX4PEvS5BvunxLytmBfJcec6KNPURmLC50fe6PS4ObwSgS7XKOHnR0K17HFKZZlIcLNVQxaoS9O-ffDt1uLbXcY=@protonmail.com
Hello,

An example of this behavior in a guile repl is:

(use-modules (gnu packages))
(specification->package "qemu") ; works
(specification->package "qemu:doc") ; errors and closes the repl

(specification->package+output "qemu:doc") ; works as expected

Thank you!
Attachment: file
L
L
Leo Prikler wrote on 1 Apr 2021 12:19
c114f2b7b9a6acfa1b37390488ecc2b0089be340.camel@student.tugraz.at
Hello,

Am Donnerstag, den 01.04.2021, 03:50 +0000 schrieb fsdfsdfsd3:
Toggle quote (7 lines)
> Hello,
>
> An example of this behavior in a guile repl is:
>
> (use-modules (gnu packages))
> (specification->package "qemu") ; works
> (specification->package "qemu:doc") ; errors and closes the repl
Given its docstring, that's to be expected:

Return a package matching SPEC. SPEC may be a package name, or a
package name followed by an at-sign and a version number. If the
version number is not present, return the preferred newest version.

Toggle quote (1 lines)
> (specification->package+output "qemu:doc") ; works as expected
In other words, use specification->package+output ;)

Regards,
Leo
L
L
Ludovic Courtès wrote on 2 Apr 2021 09:16
control message for bug #47537
(address . control@debbugs.gnu.org)
878s6140my.fsf@gnu.org
tags 47537 notabug
close 47537
quit
F
F
fsdfsdfsd3 wrote on 14 Apr 2021 06:06
Re: bug#47537 acknowledged by developer (control message for bug #47537)
(name . 47537@debbugs.gnu.org)(address . 47537@debbugs.gnu.org)
A_iJINohE6Japa1pgrIsKKL2s2UzT2JsDiGVp2GOB2HXmogH-KMFcpGUBYCTjcwUyXeDi-Z2IYe1Rs6cp1_T8nXjmL_e8NS81Fg4Kpbsdrw=@protonmail.com
Hello,

I ended up testing my config file with nfs4 and that part did work fine. I had earlier errors unrelated to this that threw me off thinking that would not work.

To clarify then, the issue here only seems to be with the mount function in the (guix build syscalls) module. This results in a "NO route to host" error even though mount.nfs works fine on the command line.

However perhaps I am assuming that mount.nfs does not make use of nfs4 behind the scenes, even without nfs-utils installed, when it does.

Thank you!

??????? Original Message ???????
On Friday, April 2, 2021 1:17 AM, <help-debbugs@gnu.org> wrote:

Toggle quote (12 lines)
> This is an automatic notification regarding your bug report
> #47537: specification->package does not seem to support outputs,
> which was filed against the guix package.
>
> Thank you for your report, which has now been closed.
> You can view the full report at
> http://debbugs.gnu.org/cgi/bugreport.cgi?bug=47537
>
> If you require further information, please followup to 47537@debbugs.gnu.org.
>
> debbugs.gnu.org maintainers
> (administrator, GNU bugs database)
?