[PATCH 0/3] gnu: Add flask-combo-jsonapi

  • Open
  • quality assurance status badge
Details
One participant
  • david larsson
Owner
unassigned
Submitted by
david larsson
Severity
normal
D
D
david larsson wrote on 31 Mar 2021 18:13
(address . bug-guix@gnu.org)
e10cc25e003f1441a52be5bf085553ee@selfhosted.xyz
Hi!
This patch series is to add python-flask-combo-jsonapi and necessary
dependencies.

Best regards,
David
D
D
david larsson wrote on 31 Mar 2021 18:15
[PATCH 1/3] gnu: Add marshmallow-3.2.
(address . 47523@debbugs.gnu.org)
79fb2658b4331b19b63a59422dec2364@selfhosted.xyz
From 5eb6db940c379e44a95b5a64382cc867f7d3c197 Mon Sep 17 00:00:00 2001
From: methuselah-0 <david.larsson@selfhosted.xyz>
Date: Wed, 31 Mar 2021 17:30:20 +0200
Subject: [PATCH 1/3] gnu: Add marshmallow-3.2.

* gnu/packages/python-xyz.scm (python-marshmallow-3.2): New variable.
---
gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c90a89a411..872ba4b281 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -99,6 +99,7 @@
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Ellis Keny? <me@elken.dev>
;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
+;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -17122,6 +17123,31 @@ Python datatypes.")
complex datatypes to and from native Python datatypes.")
(license license:expat)))

+(define-public python-marshmallow-3.2
+ (package
+ (name "python-marshmallow")
+ (version "3.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "marshmallow" version))
+ (sha256
+ (base32
+ "1w18klwj0z9bqxj252qpj1hz8l46nl27sbc89rkajc7mln73wbws"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-dateutil" ,python-dateutil)
+ ("python-simplejson" ,python-simplejson)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytz" ,python-pytz)))
+ (home-page "https://github.com/marshmallow-code/marshmallow")
+ (synopsis "Convert complex datatypes to and from native
+Python datatypes")
+ (description "@code{marshmallow} provides a library for converting
+complex datatypes to and from native Python datatypes.")
+ (license license:expat))) ; MIT license
+
(define-public python-apispec
(package
(name "python-apispec")
--
2.30.2
D
D
david larsson wrote on 31 Mar 2021 18:17
[PATCH 2/3] gnu: Add marshmallow-jsonapi.
(address . 47523@debbugs.gnu.org)
a04eef5a835514d81ac9a64f2141c700@selfhosted.xyz
This patch adds marshmallow-jsonapi locked at version 0.22 since
flask-combo-jsonapi needs it locked to this version.

From 76d533d57337702ddd1576783fa9fabb0fbf3127 Mon Sep 17 00:00:00 2001
From: methuselah-0 <david.larsson@selfhosted.xyz>
Date: Wed, 31 Mar 2021 17:34:00 +0200
Subject: [PATCH 2/3] gnu: Add marshmallow-jsonapi.

* gnu/packages/python-xyz.scm (python-marshmallow-jsonapi-0.22): New
variable.
---
gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 872ba4b281..ae91affd13 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17148,6 +17148,37 @@ Python datatypes")
complex datatypes to and from native Python datatypes.")
(license license:expat))) ; MIT license

+(define-public python-marshmallow-jsonapi-0.22
+ (package
+ (name "python-marshmallow-jsonapi")
+ (version "0.22.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "marshmallow-jsonapi" version))
+ (sha256
+ (base32
+ "0rfnagv76f0pwvdcc0604r78nphi7a7b6d5fjga2va522lydah27"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-marshmallow" ,python-marshmallow-3.2)))
+ (native-inputs
+ `(("python-faker" ,python-faker)
+ ("python-flake8" ,python-flake8)
+ ("python-flake8-bugbear" ,python-flake8-bugbear)
+ ("python-flask" ,python-flask)
+ ("python-mock" ,python-mock)
+ ("python-pre-commit" ,python-pre-commit)
+ ("python-pytest" ,python-pytest)
+ ("python-tox" ,python-tox)))
+ (home-page
+ "https://github.com/marshmallow-code/marshmallow-jsonapi")
+ (synopsis
+ "JSON API 1.0 (https://jsonapi.org) formatting with marshmallow")
+ (description
+ "JSON API 1.0 (https://jsonapi.org) formatting with marshmallow")
+ (license license:expat))) ; MIT license
+
(define-public python-apispec
(package
(name "python-apispec")
--
2.30.2
From 76d533d57337702ddd1576783fa9fabb0fbf3127 Mon Sep 17 00:00:00 2001
From: methuselah-0 <david.larsson@selfhosted.xyz>
Date: Wed, 31 Mar 2021 17:34:00 +0200
Subject: [PATCH 2/3] gnu: Add marshmallow-jsonapi.

* gnu/packages/python-xyz.scm (python-marshmallow-jsonapi-0.22): New variable.
---
gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 872ba4b281..ae91affd13 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17148,6 +17148,37 @@ Python datatypes")
complex datatypes to and from native Python datatypes.")
(license license:expat))) ; MIT license
+(define-public python-marshmallow-jsonapi-0.22
+ (package
+ (name "python-marshmallow-jsonapi")
+ (version "0.22.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "marshmallow-jsonapi" version))
+ (sha256
+ (base32
+ "0rfnagv76f0pwvdcc0604r78nphi7a7b6d5fjga2va522lydah27"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-marshmallow" ,python-marshmallow-3.2)))
+ (native-inputs
+ `(("python-faker" ,python-faker)
+ ("python-flake8" ,python-flake8)
+ ("python-flake8-bugbear" ,python-flake8-bugbear)
+ ("python-flask" ,python-flask)
+ ("python-mock" ,python-mock)
+ ("python-pre-commit" ,python-pre-commit)
+ ("python-pytest" ,python-pytest)
+ ("python-tox" ,python-tox)))
+ (home-page
+ "https://github.com/marshmallow-code/marshmallow-jsonapi")
+ (synopsis
+ "JSON API 1.0 (https://jsonapi.org) formatting with marshmallow")
+ (description
+ "JSON API 1.0 (https://jsonapi.org) formatting with marshmallow")
+ (license license:expat))) ; MIT license
+
(define-public python-apispec
(package
(name "python-apispec")
--
2.30.2
D
D
david larsson wrote on 31 Mar 2021 18:18
[PATCH 3/3] gnu: Add flask-combo-jsonapi.
(address . 47523@debbugs.gnu.org)
5875731751423dbcf96abb560de87d77@selfhosted.xyz
From 7e1c3d4e0c52a73c2369406c9165d0fff176a831 Mon Sep 17 00:00:00 2001
From: methuselah-0 <david.larsson@selfhosted.xyz>
Date: Wed, 31 Mar 2021 17:35:36 +0200
Subject: [PATCH 3/3] gnu: Add flask-combo-jsonapi.

* gnu/packages/python-web.scm (python-flask-combo-jsonapi): New
variable.
---
gnu/packages/python-web.scm | 40 +++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c7dd18ad19..8154ae82f7 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -40,6 +40,7 @@
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Konrad Hinsen <konrad.hinsen@fastmail.net>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5894,3 +5895,42 @@ your code non-blocking and speedy.")
"Socks is a library providing core proxy (SOCKS4, SOCKS5, HTTP
tunneling)
functionality.")
(license license:asl2.0)))
+
+(define-public python-flask-combo-jsonapi
+ (package
+ (name "python-flask-combo-jsonapi")
+ (version "1.0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/AdCombo/flask-combo-jsonapi/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1ik5j4cc20q6ismpdzpb1a01wpdhm9vrnlmqzxxz2qqw6vazilna"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-flask" ,python-flask)
+ ("python-marshmallow" ,python-marshmallow-3.2)
+ ("python-marshmallow-jsonapi"
+ ,python-marshmallow-jsonapi-0.22)
+ ("python-apispec" ,python-apispec)
+ ("python-simplejson" ,python-simplejson)
+ ("python-six" ,python-six)
+ ("python-sqlalchemy" ,python-sqlalchemy)))
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-coveralls" ,python-coveralls)
+ ("python-pytest-runner" ,python-pytest-runner)
+ ("python-pytest" ,python-pytest)))
+ (home-page
+ "https://github.com/AdCombo/flask-combo-jsonapi")
+ (synopsis
+ "Flask extension to create REST web api according to JSONAPI 1.0
+ specification")
+ (description
+ "Flask extension to create REST web api according to JSONAPI 1.0
+ specification with Flask, Marshmallow and data provider
+ of your choice (SQLAlchemy, MongoDB, ...)")
+ (license license:expat))) ; MIT license
--
2.30.2
From 7e1c3d4e0c52a73c2369406c9165d0fff176a831 Mon Sep 17 00:00:00 2001
From: methuselah-0 <david.larsson@selfhosted.xyz>
Date: Wed, 31 Mar 2021 17:35:36 +0200
Subject: [PATCH 3/3] gnu: Add flask-combo-jsonapi.

* gnu/packages/python-web.scm (python-flask-combo-jsonapi): New variable.
---
gnu/packages/python-web.scm | 40 +++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c7dd18ad19..8154ae82f7 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -40,6 +40,7 @@
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Konrad Hinsen <konrad.hinsen@fastmail.net>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5894,3 +5895,42 @@ your code non-blocking and speedy.")
"Socks is a library providing core proxy (SOCKS4, SOCKS5, HTTP tunneling)
functionality.")
(license license:asl2.0)))
+
+(define-public python-flask-combo-jsonapi
+ (package
+ (name "python-flask-combo-jsonapi")
+ (version "1.0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/AdCombo/flask-combo-jsonapi/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1ik5j4cc20q6ismpdzpb1a01wpdhm9vrnlmqzxxz2qqw6vazilna"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-flask" ,python-flask)
+ ("python-marshmallow" ,python-marshmallow-3.2)
+ ("python-marshmallow-jsonapi"
+ ,python-marshmallow-jsonapi-0.22)
+ ("python-apispec" ,python-apispec)
+ ("python-simplejson" ,python-simplejson)
+ ("python-six" ,python-six)
+ ("python-sqlalchemy" ,python-sqlalchemy)))
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-coveralls" ,python-coveralls)
+ ("python-pytest-runner" ,python-pytest-runner)
+ ("python-pytest" ,python-pytest)))
+ (home-page
+ "https://github.com/AdCombo/flask-combo-jsonapi")
+ (synopsis
+ "Flask extension to create REST web api according to JSONAPI 1.0
+ specification")
+ (description
+ "Flask extension to create REST web api according to JSONAPI 1.0
+ specification with Flask, Marshmallow and data provider
+ of your choice (SQLAlchemy, MongoDB, ...)")
+ (license license:expat))) ; MIT license
--
2.30.2
?