david larsson wrote 4 years ago
(address . guix-patches@gnu.org)
From 6df0f4b43623689ba7e954174c775d37cc1f5f04 Mon Sep 17 00:00:00 2001
From: methuselah-0 <david.larsson@selfhosted.xyz>
Date: Wed, 31 Mar 2021 12:38:50 +0200
Subject: [PATCH] gnu: Add galera.
* gnu/packages/databases.scm (galera): New variable.
---
gnu/packages/databases.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
Toggle diff (48 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 130e94d535..c76daf5e70 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -48,6 +48,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1002,6 +1003,30 @@ as a drop-in replacement of MySQL.")
developed in C/C++ to MariaDB and MySQL databases.")
(license license:lgpl2.1+)))
+(define-public galera
+ (package
+ (name "galera")
+ (version "26.4.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (commit "bac8171266cb982fe013ce496d78085438c6f23e")
+ (url "https://github.com/codership/galera.git")
+ (recursive? #t)))
+ (sha256
+ (base32
"0h7s670pcasq8wzprhyxqfca2cghi62b8xz2kikb2a86wd453qil"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("check" ,check)
+ ("boost" ,boost)))
+ (inputs
+ `(("openssl" ,openssl)))
+ (home-page "https://github.com/codership/galera/")
+ (synopsis "Extension to the MariaDB database server")
+ (description
+ "Galera is a wsrep-provider that is used with MariaDB for
load-balancing and HA.")
+ (license license:gpl2)))
+
;; Don't forget to update the other postgresql packages when upgrading
this one.
(define-public postgresql-13
(package
--
2.30.2
From 6df0f4b43623689ba7e954174c775d37cc1f5f04 Mon Sep 17 00:00:00 2001
From: methuselah-0 <david.larsson@selfhosted.xyz>
Date: Wed, 31 Mar 2021 12:38:50 +0200
Subject: [PATCH] gnu: Add galera.
* gnu/packages/databases.scm (galera): New variable.
---
gnu/packages/databases.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
Toggle diff (45 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 130e94d535..c76daf5e70 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -48,6 +48,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1002,6 +1003,30 @@ as a drop-in replacement of MySQL.")
developed in C/C++ to MariaDB and MySQL databases.")
(license license:lgpl2.1+)))
+(define-public galera
+ (package
+ (name "galera")
+ (version "26.4.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (commit "bac8171266cb982fe013ce496d78085438c6f23e")
+ (url "https://github.com/codership/galera.git")
+ (recursive? #t)))
+ (sha256
+ (base32 "0h7s670pcasq8wzprhyxqfca2cghi62b8xz2kikb2a86wd453qil"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("check" ,check)
+ ("boost" ,boost)))
+ (inputs
+ `(("openssl" ,openssl)))
+ (home-page "https://github.com/codership/galera/")
+ (synopsis "Extension to the MariaDB database server")
+ (description
+ "Galera is a wsrep-provider that is used with MariaDB for load-balancing and HA.")
+ (license license:gpl2)))
+
;; Don't forget to update the other postgresql packages when upgrading this one.
(define-public postgresql-13
(package
--
2.30.2