[PATCH] gnu: Add galera.

  • Done
  • quality assurance status badge
Details
2 participants
  • david larsson
  • Ludovic Courtès
Owner
unassigned
Submitted by
david larsson
Severity
normal

Debbugs page

david larsson wrote 4 years ago
(address . guix-patches@gnu.org)
4dec479c391f2af9996786d4eae95405@selfhosted.xyz
From 6df0f4b43623689ba7e954174c775d37cc1f5f04 Mon Sep 17 00:00:00 2001
From: methuselah-0 <david.larsson@selfhosted.xyz>
Date: Wed, 31 Mar 2021 12:38:50 +0200
Subject: [PATCH] gnu: Add galera.

* gnu/packages/databases.scm (galera): New variable.
---
gnu/packages/databases.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 130e94d535..c76daf5e70 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -48,6 +48,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1002,6 +1003,30 @@ as a drop-in replacement of MySQL.")
developed in C/C++ to MariaDB and MySQL databases.")
(license license:lgpl2.1+)))

+(define-public galera
+ (package
+ (name "galera")
+ (version "26.4.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (commit "bac8171266cb982fe013ce496d78085438c6f23e")
+ (url "https://github.com/codership/galera.git")
+ (recursive? #t)))
+ (sha256
+ (base32
"0h7s670pcasq8wzprhyxqfca2cghi62b8xz2kikb2a86wd453qil"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("check" ,check)
+ ("boost" ,boost)))
+ (inputs
+ `(("openssl" ,openssl)))
+ (home-page "https://github.com/codership/galera/")
+ (synopsis "Extension to the MariaDB database server")
+ (description
+ "Galera is a wsrep-provider that is used with MariaDB for
load-balancing and HA.")
+ (license license:gpl2)))
+
;; Don't forget to update the other postgresql packages when upgrading
this one.
(define-public postgresql-13
(package
--
2.30.2
From 6df0f4b43623689ba7e954174c775d37cc1f5f04 Mon Sep 17 00:00:00 2001
From: methuselah-0 <david.larsson@selfhosted.xyz>
Date: Wed, 31 Mar 2021 12:38:50 +0200
Subject: [PATCH] gnu: Add galera.

* gnu/packages/databases.scm (galera): New variable.
---
gnu/packages/databases.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 130e94d535..c76daf5e70 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -48,6 +48,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1002,6 +1003,30 @@ as a drop-in replacement of MySQL.")
developed in C/C++ to MariaDB and MySQL databases.")
(license license:lgpl2.1+)))
+(define-public galera
+ (package
+ (name "galera")
+ (version "26.4.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (commit "bac8171266cb982fe013ce496d78085438c6f23e")
+ (url "https://github.com/codership/galera.git")
+ (recursive? #t)))
+ (sha256
+ (base32 "0h7s670pcasq8wzprhyxqfca2cghi62b8xz2kikb2a86wd453qil"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("check" ,check)
+ ("boost" ,boost)))
+ (inputs
+ `(("openssl" ,openssl)))
+ (home-page "https://github.com/codership/galera/")
+ (synopsis "Extension to the MariaDB database server")
+ (description
+ "Galera is a wsrep-provider that is used with MariaDB for load-balancing and HA.")
+ (license license:gpl2)))
+
;; Don't forget to update the other postgresql packages when upgrading this one.
(define-public postgresql-13
(package
--
2.30.2
Ludovic Courtès wrote 4 years ago
(name . david larsson)(address . david.larsson@selfhosted.xyz)(address . 47519-done@debbugs.gnu.org)
87sg408o2e.fsf@gnu.org
Hi David,

david larsson <david.larsson@selfhosted.xyz> skribis:

Toggle quote (7 lines)
> From 6df0f4b43623689ba7e954174c775d37cc1f5f04 Mon Sep 17 00:00:00 2001
> From: methuselah-0 <david.larsson@selfhosted.xyz>
> Date: Wed, 31 Mar 2021 12:38:50 +0200
> Subject: [PATCH] gnu: Add galera.
>
> * gnu/packages/databases.scm (galera): New variable.

Applied with the minor changes below.

Thanks,
Ludo’.
Toggle diff (34 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index fc0273162a..8c657e4113 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1011,21 +1011,22 @@ developed in C/C++ to MariaDB and MySQL databases.")
(method git-fetch)
(uri (git-reference
(commit "bac8171266cb982fe013ce496d78085438c6f23e")
- (url "https://github.com/codership/galera.git")
+ (url "https://github.com/codership/galera")
(recursive? #t)))
+ (file-name (git-file-name name version))
(sha256
(base32 "0h7s670pcasq8wzprhyxqfca2cghi62b8xz2kikb2a86wd453qil"))))
(build-system cmake-build-system)
- (native-inputs
+ (inputs
`(("check" ,check)
- ("boost" ,boost)))
- (inputs
- `(("openssl" ,openssl)))
+ ("boost" ,boost)
+ ("openssl" ,openssl)))
(home-page "https://github.com/codership/galera/")
(synopsis "Extension to the MariaDB database server")
(description
- "Galera is a wsrep-provider that is used with MariaDB for load-balancing and HA.")
- (license license:gpl2)))
+ "Galera is a wsrep-provider that is used with MariaDB for load-balancing
+and high-availability (HA).")
+ (license license:gpl2))) ;'COPYING' says "version 2" only
;; Don't forget to update the other postgresql packages when upgrading this one.
(define-public postgresql-13
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 47519@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 47519
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help