[PATCH] gnu: add instead

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexander Krotov
  • Leo Prikler
Owner
unassigned
Submitted by
Alexander Krotov
Severity
normal
Merged with

Debbugs page

Alexander Krotov wrote 4 years ago
(address . guix-patches@gnu.org)(name . Alexander Krotov)(address . krotov@iitp.ru)
20210330235329.792240-1-krotov@iitp.ru
* gnu/packages/games.scm (instead): New variable.
---
gnu/packages/games.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3f909aad4b..22975cf0d6 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -12379,3 +12379,34 @@ game FPS.")
implemented using ncurses user interface. An SDL graphical version is also
available.")
(license license:gpl3+)))
+
+(define-public instead
+ (package
+ (name "instead")
+ (version "3.3.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/instead-hub/instead")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "09z22i0ny3dhjhj3g1walxg5mdnr3wsx95q1f92z32cabmqkbiyc"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f))
+ (inputs `(("zlib" ,zlib)
+ ("lua" ,lua)
+ ("sdl2" ,sdl2)
+ ("sdl2-mixer" ,sdl2-mixer)
+ ("sdl2-image" ,sdl2-image)
+ ("sdl2-ttf" ,sdl2-ttf)
+ ("gtk+" ,gtk+)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (home-page "https://instead.hugeping.ru/")
+ (synopsis "Simple text adventures/visual novels engine")
+ (description "INSTEAD is an INterpreter of Simple TExt ADventure. Using
+INSTEAD you can create and play games that could be classified as a mix of
+visual novel and text quest.")
+ (license license:expat)))
--
2.31.0
Leo Prikler wrote 4 years ago
(name . Alexander Krotov)(address . krotov@iitp.ru)(address . 47508@debbugs.gnu.org)(address . control@debbugs.gnu.org)
41db15be319b0111d77e0f5b9cbd6609d7d24d69.camel@student.tugraz.at
merge 46378 47508
thanks

Hi,

as you can see, there does exist prior work on the packaging of
instead. Dmitry's patch also includes a search path among other
things, but there were some setbacks, that are discussed over there.
Work on that patch seems to have come to a halt, but it would be great
if you could try to see what could be salvaged from it.

Regards,
Leo

Am Mittwoch, den 31.03.2021, 02:53 +0300 schrieb Alexander Krotov:
Toggle quote (48 lines)
> * gnu/packages/games.scm (instead): New variable.
> ---
> gnu/packages/games.scm | 31 +++++++++++++++++++++++++++++++
> 1 file changed, 31 insertions(+)
>
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index 3f909aad4b..22975cf0d6 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -12379,3 +12379,34 @@ game FPS.")
> implemented using ncurses user interface. An SDL graphical version
> is also
> available.")
> (license license:gpl3+)))
> +
> +(define-public instead
> + (package
> + (name "instead")
> + (version "3.3.4")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/instead-hub/instead")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> "09z22i0ny3dhjhj3g1walxg5mdnr3wsx95q1f92z32cabmqkbiyc"))))
> + (build-system cmake-build-system)
> + (arguments
> + `(#:tests? #f))
> + (inputs `(("zlib" ,zlib)
> + ("lua" ,lua)
> + ("sdl2" ,sdl2)
> + ("sdl2-mixer" ,sdl2-mixer)
> + ("sdl2-image" ,sdl2-image)
> + ("sdl2-ttf" ,sdl2-ttf)
> + ("gtk+" ,gtk+)))
> + (native-inputs `(("pkg-config" ,pkg-config)))
> + (home-page "https://instead.hugeping.ru/")
> + (synopsis "Simple text adventures/visual novels engine")
> + (description "INSTEAD is an INterpreter of Simple TExt
> ADventure. Using
> +INSTEAD you can create and play games that could be classified as a
> mix of
> +visual novel and text quest.")
> + (license license:expat)))
?
Your comment

This issue is archived.

To comment on this conversation send an email to 47508@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 47508
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help