Alexander Krotov wrote 4 years ago
(address . guix-patches@gnu.org)(name . Alexander Krotov)(address . krotov@iitp.ru)
* gnu/packages/games.scm (instead): New variable.
---
gnu/packages/games.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)
Toggle diff (41 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3f909aad4b..22975cf0d6 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -12379,3 +12379,34 @@ game FPS.")
implemented using ncurses user interface. An SDL graphical version is also
available.")
(license license:gpl3+)))
+
+(define-public instead
+ (package
+ (name "instead")
+ (version "3.3.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/instead-hub/instead")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "09z22i0ny3dhjhj3g1walxg5mdnr3wsx95q1f92z32cabmqkbiyc"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f))
+ (inputs `(("zlib" ,zlib)
+ ("lua" ,lua)
+ ("sdl2" ,sdl2)
+ ("sdl2-mixer" ,sdl2-mixer)
+ ("sdl2-image" ,sdl2-image)
+ ("sdl2-ttf" ,sdl2-ttf)
+ ("gtk+" ,gtk+)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (home-page "https://instead.hugeping.ru/")
+ (synopsis "Simple text adventures/visual novels engine")
+ (description "INSTEAD is an INterpreter of Simple TExt ADventure. Using
+INSTEAD you can create and play games that could be classified as a mix of
+visual novel and text quest.")
+ (license license:expat)))
--
2.31.0