[PATCH 0/2] Have fcgiwrap log to a file.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 4 years ago
(address . guix-patches@gnu.org)
871rbw1ga2.fsf@cbaines.net
Christopher Baines (2):
gnu: services: web: Cleanup whitespace.
gnu: services: web: Have fcgiwrap log to a file.

gnu/services/web.scm | 35 ++++++++++++++++++-----------------
1 file changed, 18 insertions(+), 17 deletions(-)
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmBjmFVfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdXSxAAmQ/4l3UAVsmtfd/Gl8SYViFvKnR8Esgz
56ajd5Xu1GCmugXq/tEPLSUiZTEHVgv+et201i1Tepga18vRctXdZ4KYQsWLIB4Q
CD37aMHXFQ+xfaRDeWJbZVqYKAjQqgXN5tw7JDIis0WeIMtG4VE1BiX+jhJ8Q/6e
KzHZPiYNC1C2UWu/rI2Ah2yQfO/E8u8EM+QCSXC2mpyuTl5qA+9UuLZWd/OjdHyq
jPKNM3i7TqnhUF/CpoYTnXpTCMKLmnIK1QKnr8mL4QjExXFZUzFe8xnhF/2Fmm8d
AIHBx8I4aB/729Fpo9I8mZzjyWS18+OumcY8IBoYrXPCISj5+Yt4Nzrjz0QI9FV9
a6ge2Zj/QQ7QMMKbF73yvLz1Mhqgp54Nm5LuFguC51Dv05NVyedGjgyqo/4aMBQL
HdlY2QBp7F5WjpxelBSHYeX9OtF8Q6t2kbxscq27Q2iFXfJOQ+VOvAZUYyDSCZvW
9PrJlT5RqxUlzQIoDnNKbUFTnsZwrMHvYF68tdFZxWSWscE+FvaDSw4StCSxwyjQ
ev32W3+VCsCl2Mmx43+FP4nyZM+66L/Sr1qpeZg0Rlwz9S32nOOn/Vty1bkk7z74
kUl+HsV5KZ5IC7W1IwPCh8FGsoHHzqnRh+Fo8mpzJAVEjUWsIzLxZapOIOD5DYHs
zLJO6py94WM=
=q1Yt
-----END PGP SIGNATURE-----

Christopher Baines wrote 4 years ago
[PATCH 2/2] gnu: services: web: Have fcgiwrap log to a file.
(address . 47504@debbugs.gnu.org)
20210330213437.23503-2-mail@cbaines.net
This makes it easier to access the output.

* gnu/services/web.scm (fcgiwrap-shepherd-service): Pass #:log-file to
make-forkexec-constructor.
---
gnu/services/web.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/services/web.scm b/gnu/services/web.scm
index 1aad695c8b..bfcdfe7421 100644
--- a/gnu/services/web.scm
+++ b/gnu/services/web.scm
@@ -841,7 +841,8 @@ of index files."
(start #~(make-forkexec-constructor
'(#$(file-append package "/sbin/fcgiwrap")
"-s" #$socket)
- #:user #$user #:group #$group))
+ #:user #$user #:group #$group
+ #:log-file "/var/log/fcgiwrap.log"))
(stop #~(make-kill-destructor)))))))
(define fcgiwrap-activation
--
2.30.1
Christopher Baines wrote 4 years ago
[PATCH 1/2] gnu: services: web: Cleanup whitespace.
(address . 47504@debbugs.gnu.org)
20210330213437.23503-1-mail@cbaines.net
Replace tabs with spaces, and delete trailing whitespace.

* gnu/services/web.scm: Cleanup whitespace.
---
gnu/services/web.scm | 34 +++++++++++++++++-----------------
1 file changed, 17 insertions(+), 17 deletions(-)

Toggle diff (65 lines)
diff --git a/gnu/services/web.scm b/gnu/services/web.scm
index aa688a4328..1aad695c8b 100644
--- a/gnu/services/web.scm
+++ b/gnu/services/web.scm
@@ -840,8 +840,8 @@ of index files."
(requirement '(networking))
(start #~(make-forkexec-constructor
'(#$(file-append package "/sbin/fcgiwrap")
- "-s" #$socket)
- #:user #$user #:group #$group))
+ "-s" #$socket)
+ #:user #$user #:group #$group))
(stop #~(make-kill-destructor)))))))
(define fcgiwrap-activation
@@ -863,7 +863,7 @@ of index files."
(extensions
(list (service-extension shepherd-root-service-type
fcgiwrap-shepherd-service)
- (service-extension account-service-type
+ (service-extension account-service-type
fcgiwrap-accounts)
(service-extension activation-service-type
fcgiwrap-activation)))
@@ -1946,24 +1946,24 @@ root=/srv/gemini
(documentation "Run the agate Gemini server.")
(start (let ((agate (file-append package "/bin/agate")))
#~(make-forkexec-constructor
- (list #$agate
- "--content" #$content
- "--cert" #$cert
- "--key" #$key
- "--addr" #$@addr
+ (list #$agate
+ "--content" #$content
+ "--cert" #$cert
+ "--key" #$key
+ "--addr" #$@addr
#$@(if lang
(list "--lang" lang)
'())
- #$@(if hostname
- (list "--hostname" hostname)
- '())
- #$@(if silent? '("--silent") '())
- #$@(if serve-secret? '("--serve-secret") '())
- #$@(if log-ip? '("--log-ip") '()))
- #:user #$user #:group #$group
- #:log-file #$log-file)))
+ #$@(if hostname
+ (list "--hostname" hostname)
+ '())
+ #$@(if silent? '("--silent") '())
+ #$@(if serve-secret? '("--serve-secret") '())
+ #$@(if log-ip? '("--log-ip") '()))
+ #:user #$user #:group #$group
+ #:log-file #$log-file)))
(stop #~(make-kill-destructor)))))))
-
+
(define agate-accounts
(match-lambda
(($ <agate-configuration> _ _ _ _ _
--
2.30.1
Efraim Flashner wrote 4 years ago
Re: [bug#47504] [PATCH 0/2] Have fcgiwrap log to a file.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 47504@debbugs.gnu.org)
YGSIiUYVmKAGuUHX@3900XT
On Tue, Mar 30, 2021 at 10:29:57PM +0100, Christopher Baines wrote:
Toggle quote (8 lines)
>
> Christopher Baines (2):
> gnu: services: web: Cleanup whitespace.
> gnu: services: web: Have fcgiwrap log to a file.
>
> gnu/services/web.scm | 35 ++++++++++++++++++-----------------
> 1 file changed, 18 insertions(+), 17 deletions(-)

looks good to me. And a good excuse to remove a bunch of those pesky
tabs!

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmBkiIkACgkQQarn3Mo9
g1HjAg/+L92gPqXcLCyBDRl2sezo27lnxqAITRpkckfBYosn8chu4rT+2VGMXNFD
Rb6uNC0PCaUxfXwpEojMb07J7E7Y/nLg9uKiZhf8G2gyiWEwExvCYpBGzYecFsJP
oDW/4rMIV0iiKAMsYIYDJ+2BPX7y/F2vIVcdLvL7R6C0kaeJpz9M/t1wzqeoPQZX
6ej8inO8vso4crPdUdkzsksEr3fliPoBBe6tULCrb47p8+6huR4Cvc5TkwEu+6eF
EDuK0fkBqDk1xygwIJE35A2c6cWp4JWooj38BvIzvGXdO5iQplXIKPibyIX8icHg
AmekqJalZ/Rz5QUNTCmBv2WznnxQHjjDYPELRQjENl7IWhDRA+qvK2LIf1YtqwPS
zqMVrA563zlMSO4GH9IQDeAwbL2QlEGJ6spy6tMIrnJQ1YjBeT4GrLRqVwrLatC6
hJnUdr6q6BTNZKj4qyuqBcpf5gqhQtwKP+fLPygfE77hjVYlYVFubweokPImIG55
klTHA4bAr9t9gDsAWPJ+yeNJKaVbKXVIOowQSL97fHRO6R85I33V/w0k4UvIlL2d
aNYnp3/44pPc5ViyBcy+10VGi5yICZ+RzOegwAG8VOP1BCLiDc+Is45uSIQShOe6
AenJxPnNl7oLF/kw85SnZoY0AZ7Fbf5DZFYVeCD/4a9uF+ajTI4=
=OIer
-----END PGP SIGNATURE-----


Christopher Baines wrote 4 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 47504-done@debbugs.gnu.org)
87eefuzak4.fsf@cbaines.net
Efraim Flashner <efraim@flashner.co.il> writes:

Toggle quote (12 lines)
> On Tue, Mar 30, 2021 at 10:29:57PM +0100, Christopher Baines wrote:
>>
>> Christopher Baines (2):
>> gnu: services: web: Cleanup whitespace.
>> gnu: services: web: Have fcgiwrap log to a file.
>>
>> gnu/services/web.scm | 35 ++++++++++++++++++-----------------
>> 1 file changed, 18 insertions(+), 17 deletions(-)
>
> looks good to me. And a good excuse to remove a bunch of those pesky
> tabs!

Thanks for taking a look :) I've pushed these patches to master as of
264f7189e8fa20f4ab3da7f5e98fdd15d5eb4231.

Chris
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 47504@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 47504
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help