[PATCH] gnu: crypto++: Update to 8.5.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Ludovic Courtès
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal

Debbugs page

Leo Prikler wrote 4 years ago
(address . guix-patches@gnu.org)(address . 47470@debbugs.gnu.org)
20210329155946.19273-1-leo.prikler@student.tugraz.at
* gnu/packages/crypto.scm (crypto++): Update to 8.5.0.
[origin]: Use git-fetch and git-reference.
---
gnu/packages/crypto.scm | 15 +++++++++------
1 file changed, 9 insertions(+), 6 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 94f9cbeebf..57d417de80 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -773,15 +773,18 @@ data on your platform, so the seed itself will be as random as possible.
(define-public crypto++
(package
(name "crypto++")
- (version "8.4.0")
+ (version "8.5.0")
(source (origin
- (method url-fetch/zipbomb)
- (uri (string-append "https://cryptopp.com/cryptopp"
- (string-join (string-split version #\.) "")
- ".zip"))
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/weidai11/cryptopp")
+ (commit
+ (string-append "CRYPTOPP_"
+ (string-replace-substring version "." "_")))))
(sha256
(base32
- "16kvfm11xv7j9a3yykzysjgw38a9b7lnc5n5x5h82g395k6ybxf0"))))
+ "0in7rlazq91vfi519g9wr7bh87hii47cimxv7fmj0f88vhjaidq3"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
--
2.31.0
Ludovic Courtès wrote 4 years ago
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)
87zgydukoi.fsf@gnu.org
Hi Leo,

Leo Prikler <leo.prikler@student.tugraz.at> skribis:

Toggle quote (3 lines)
> * gnu/packages/crypto.scm (crypto++): Update to 8.5.0.
> [origin]: Use git-fetch and git-reference.

If dependents still build fine, go for it!

Thanks,
Ludo’.
Leo Prikler wrote 4 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)
89010935b05cd2bbea6aec1df78859db32b0e714.camel@student.tugraz.at
Am Montag, den 05.04.2021, 11:47 +0200 schrieb Ludovic Courtès:
Toggle quote (11 lines)
> Hi Leo,
>
> Leo Prikler <leo.prikler@student.tugraz.at> skribis:
>
> > * gnu/packages/crypto.scm (crypto++): Update to 8.5.0.
> > [origin]: Use git-fetch and git-reference.
>
> If dependents still build fine, go for it!
>
> Thanks,
> Ludo’.
Built everything locally and pushed. Hopefully the CI doesn't notice,
that I only checked amd64 :)
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 47477@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 47477
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help