(address . guix-patches@gnu.org)(name . calum)(address . calumirwin1@gmail.com)
---
gnu/packages/xdisorg.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)
Toggle diff (48 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 56ac53edec..6d936efee6 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -80,6 +80,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages bison)
#:use-module (gnu packages check)
+ #:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
#:use-module (gnu packages documentation)
#:use-module (gnu packages flex)
@@ -2788,3 +2789,33 @@ and execute @file{.desktop} files of the Application type.")
"The @command{hsetroot} command composes wallpapers for X.
This package is the fork of hsetroot by Hyriand.")
(license license:gpl2+)))
+
+(define-public wlrctl
+ (package
+ (name "wlrctl")
+ (version "0.2.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~brocellous/wlrctl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "039cxc82k7x473n6d65jray90rj35qmfdmr390zy0c7ic7vn4b78"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("cmake" ,cmake)
+ ("scdoc" ,scdoc)))
+ (inputs
+ `(("libxkbcommon" ,libxkbcommon)
+ ("wayland" ,wayland)))
+ (home-page "https://git.sr.ht/~brocellous/wlrctl")
+ (synopsis "Command line utility for wlroots automation and extensions")
+ (description
+ "wlrctl is a command line utility for miscellaneous wlroots Wayland
+extensions. At this time, wlrctl supports the foreign-toplevel-mangement
+(window/toplevel command), virtual-keyboard (keyboard command),
+and virtual-pointer (pointer command) protocols.")
+ (license license:expat)))
--
2.31.1