[PATCH] Added wlrctl to xdisorg

  • Open
  • quality assurance status badge
Details
3 participants
  • calum
  • Leo Famulari
  • Maxime Devos
Owner
unassigned
Submitted by
calum
Severity
normal
C
(address . guix-patches@gnu.org)(name . calum)(address . calumirwin1@gmail.com)
20210329105622.5812-1-calumirwin1@gmail.com
---
gnu/packages/xdisorg.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 56ac53edec..6d936efee6 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -80,6 +80,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages bison)
#:use-module (gnu packages check)
+ #:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
#:use-module (gnu packages documentation)
#:use-module (gnu packages flex)
@@ -2788,3 +2789,33 @@ and execute @file{.desktop} files of the Application type.")
"The @command{hsetroot} command composes wallpapers for X.
This package is the fork of hsetroot by Hyriand.")
(license license:gpl2+)))
+
+(define-public wlrctl
+ (package
+ (name "wlrctl")
+ (version "0.2.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~brocellous/wlrctl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "039cxc82k7x473n6d65jray90rj35qmfdmr390zy0c7ic7vn4b78"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("cmake" ,cmake)
+ ("scdoc" ,scdoc)))
+ (inputs
+ `(("libxkbcommon" ,libxkbcommon)
+ ("wayland" ,wayland)))
+ (home-page "https://git.sr.ht/~brocellous/wlrctl")
+ (synopsis "Command line utility for wlroots automation and extensions")
+ (description
+ "wlrctl is a command line utility for miscellaneous wlroots Wayland
+extensions. At this time, wlrctl supports the foreign-toplevel-mangement
+(window/toplevel command), virtual-keyboard (keyboard command),
+and virtual-pointer (pointer command) protocols.")
+ (license license:expat)))
--
2.31.1
M
M
Maxime Devos wrote on 29 Mar 2021 15:50
97eef11b9cbaeea1035fb05a2e8925c8350c085b.camel@telenet.be
Hi,

On Mon, 2021-03-29 at 23:56 +1300, calum wrote:
Toggle quote (4 lines)
> ---
> gnu/packages/xdisorg.scm | 31 +++++++++++++++++++++++++++++++
> 1 file changed, 31 insertions(+)

Please include a commit message. There are plenty of examples
in the git history to base you on. Also see section
16.6 ‘Submitting Patches’ of the manual.

Toggle quote (6 lines)
> diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
> index 56ac53edec..6d936efee6 100644
> --- a/gnu/packages/xdisorg.scm
> +++ b/gnu/packages/xdisorg.scm
> @@ -80,6 +80,7 @@

You should add a copyright line.

Toggle quote (34 lines)
> #:use-module (gnu packages base)
> #:use-module (gnu packages bison)
> #:use-module (gnu packages check)
> + #:use-module (gnu packages cmake)
> #:use-module (gnu packages compression)
> #:use-module (gnu packages documentation)
> #:use-module (gnu packages flex)
> @@ -2788,3 +2789,33 @@ and execute @file{.desktop} files of the Application type.")
> "The @command{hsetroot} command composes wallpapers for X.
> This package is the fork of hsetroot by Hyriand.")
> (license license:gpl2+)))
> +
> +(define-public wlrctl
> + (package
> + (name "wlrctl")
> + (version "0.2.1")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://git.sr.ht/~brocellous/wlrctl")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "039cxc82k7x473n6d65jray90rj35qmfdmr390zy0c7ic7vn4b78"))))
> + (build-system meson-build-system)
> + (native-inputs
> + `(("pkg-config" ,pkg-config)
> + ("cmake" ,cmake)
> + ("scdoc" ,scdoc)))
> + (inputs
> + `(("libxkbcommon" ,libxkbcommon)
> + ("wayland" ,wayland)))

If this is a wayland package, shouldn't this be in (gnu packages freedesktop)?
I'm not sure myself where it should be, but at least that's were the 'wayland'
package resides.

Toggle quote (9 lines)
> + (synopsis "Command line utility for wlroots automation and extensions")
> + (description
> + "wlrctl is a command line utility for miscellaneous wlroots Wayland
> +extensions. At this time, wlrctl supports the foreign-toplevel-mangement
> +(window/toplevel command), virtual-keyboard (keyboard command),
> +and virtual-pointer (pointer command) protocols.")
> + (license license:expat)))

The package definition seems about right to me, but I don't have time to
actually test this.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYIADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYGHbJxccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7ssfAP9Nq1jJc+yq0AE85gyzDJ4iVxor
LsGgQ6nzemUfSsdxrwEA3wvhRYasfl0/CFfOoha9DIkYkNUPW94mJuiUvQtKDwQ=
=hQ1Y
-----END PGP SIGNATURE-----


C
[PATCH v2] gnu: Add wlrctl
(address . 47465@debbugs.gnu.org)(name . calum)(address . calumirwin1@gmail.com)
20210330102955.1476-1-calumirwin1@gmail.com
* gnu/packages/xdisorg.scm (wlrctl): New variables.
---
gnu/packages/xdisorg.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 56ac53edec..200515c045 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -45,6 +45,7 @@
;;; Copyright © 2020, 2021 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
+;;; Copyright © 2021 Calum Irwin <calumirwin1@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -80,6 +81,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages bison)
#:use-module (gnu packages check)
+ #:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
#:use-module (gnu packages documentation)
#:use-module (gnu packages flex)
@@ -2788,3 +2790,33 @@ and execute @file{.desktop} files of the Application type.")
"The @command{hsetroot} command composes wallpapers for X.
This package is the fork of hsetroot by Hyriand.")
(license license:gpl2+)))
+
+(define-public wlrctl
+ (package
+ (name "wlrctl")
+ (version "0.2.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~brocellous/wlrctl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "039cxc82k7x473n6d65jray90rj35qmfdmr390zy0c7ic7vn4b78"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("cmake" ,cmake)
+ ("scdoc" ,scdoc)))
+ (inputs
+ `(("libxkbcommon" ,libxkbcommon)
+ ("wayland" ,wayland)))
+ (home-page "https://git.sr.ht/~brocellous/wlrctl")
+ (synopsis "Command line utility for wlroots automation and extensions")
+ (description
+ "wlrctl is a command line utility for miscellaneous wlroots Wayland
+extensions. At this time, wlrctl supports the foreign-toplevel-mangement
+(window/toplevel command), virtual-keyboard (keyboard command),
+and virtual-pointer (pointer command) protocols.")
+ (license license:expat)))
--
2.31.1
C
C
Calum Irwin wrote on 30 Mar 2021 12:32
Re: [bug#47465] [PATCH] Added wlrctl to xdisorg
(address . 47465@debbugs.gnu.org)(address . maximedevos@telnet.be)
CAH+jhzFWTvTpMinsjokHqo74K_Z-+DwsDE0cfUBk6MH9ZJeGmA@mail.gmail.com
freedesktop.scm seemed to be more for libraries while xdisorg was for
miscellaneous applications and there were already a number of wayland
specific applications in there (redshift-wayland, gammastep,
bemenu...)

As an aside, if you're a maintainer for the repo you may want to take
a quick look at the README and HACKING documents which mention a
doc/guix.info which looks to have been replaced with a texi file that
info doesn't support the MENU-ITEM jumping to, for example,
"Contributing" or "Building from git".

Apologies if the commit message is screwed up again. It's supposed to say:

gnu: Add wlrctl

* gnu/packages/xdisorg.scm (wlrctl): New variables.

On Tue, Mar 30, 2021 at 2:50 AM Maxime Devos <maximedevos@telenet.be> wrote:
Toggle quote (73 lines)
>
> Hi,
>
> On Mon, 2021-03-29 at 23:56 +1300, calum wrote:
> > ---
> > gnu/packages/xdisorg.scm | 31 +++++++++++++++++++++++++++++++
> > 1 file changed, 31 insertions(+)
>
> Please include a commit message. There are plenty of examples
> in the git history to base you on. Also see section
> 16.6 ‘Submitting Patches’ of the manual.
>
> > diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
> > index 56ac53edec..6d936efee6 100644
> > --- a/gnu/packages/xdisorg.scm
> > +++ b/gnu/packages/xdisorg.scm
> > @@ -80,6 +80,7 @@
>
> You should add a copyright line.
>
> > #:use-module (gnu packages base)
> > #:use-module (gnu packages bison)
> > #:use-module (gnu packages check)
> > + #:use-module (gnu packages cmake)
> > #:use-module (gnu packages compression)
> > #:use-module (gnu packages documentation)
> > #:use-module (gnu packages flex)
> > @@ -2788,3 +2789,33 @@ and execute @file{.desktop} files of the Application type.")
> > "The @command{hsetroot} command composes wallpapers for X.
> > This package is the fork of hsetroot by Hyriand.")
> > (license license:gpl2+)))
> > +
> > +(define-public wlrctl
> > + (package
> > + (name "wlrctl")
> > + (version "0.2.1")
> > + (source (origin
> > + (method git-fetch)
> > + (uri (git-reference
> > + (url "https://git.sr.ht/~brocellous/wlrctl")
> > + (commit (string-append "v" version))))
> > + (file-name (git-file-name name version))
> > + (sha256
> > + (base32
> > + "039cxc82k7x473n6d65jray90rj35qmfdmr390zy0c7ic7vn4b78"))))
> > + (build-system meson-build-system)
> > + (native-inputs
> > + `(("pkg-config" ,pkg-config)
> > + ("cmake" ,cmake)
> > + ("scdoc" ,scdoc)))
> > + (inputs
> > + `(("libxkbcommon" ,libxkbcommon)
> > + ("wayland" ,wayland)))
>
> If this is a wayland package, shouldn't this be in (gnu packages freedesktop)?
> I'm not sure myself where it should be, but at least that's were the 'wayland'
> package resides.
>
> > + (home-page "https://git.sr.ht/~brocellous/wlrctl")
> > + (synopsis "Command line utility for wlroots automation and extensions")
> > + (description
> > + "wlrctl is a command line utility for miscellaneous wlroots Wayland
> > +extensions. At this time, wlrctl supports the foreign-toplevel-mangement
> > +(window/toplevel command), virtual-keyboard (keyboard command),
> > +and virtual-pointer (pointer command) protocols.")
> > + (license license:expat)))
>
> The package definition seems about right to me, but I don't have time to
> actually test this.
>
> Greetings,
> Maxime.
>
L
L
Leo Famulari wrote on 4 Apr 2021 19:49
(name . Calum Irwin)(address . calumirwin1@gmail.com)
YGn8JyBW539YW+3N@jasmine.lan
On Tue, Mar 30, 2021 at 11:32:05PM +1300, Calum Irwin wrote:
Toggle quote (6 lines)
> As an aside, if you're a maintainer for the repo you may want to take
> a quick look at the README and HACKING documents which mention a
> doc/guix.info which looks to have been replaced with a texi file that
> info doesn't support the MENU-ITEM jumping to, for example,
> "Contributing" or "Building from git".

Do you mean that, in the Git repo, you can only find the 'doc/guix.texi'
file, and that guix.info is missing?

If so, that's expected.

'guix.info' is built from 'guix.texi', by doing `make doc/guix.info`.

You can also do, for example, `make doc/guix.html`.
C
[PATCH] gnu: Add wlrctl
(address . 47465@debbugs.gnu.org)(name . calum)(address . calumirwin1@gmail.com)
20210627042628.14292-1-calumirwin1@gmail.com
* gnu/packages/xdisorg.scm (wlrctl): New variable.
---
gnu/packages/xdisorg.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index b8c7a35a36..18f120bab5 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -48,6 +48,7 @@
;;; Copyright © 2021 Renzo Poddighe <renzo@poddighe.nl>
;;; Copyright © 2021 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2021 Niklas Eklund <niklas.eklund@posteo.net>
+;;; Copyright © 2021 Calum Irwin <calumirwin1@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -83,6 +84,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages bison)
#:use-module (gnu packages check)
+ #:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
#:use-module (gnu packages documentation)
#:use-module (gnu packages flex)
@@ -2957,3 +2959,34 @@ System. This includes such features as MouseKeys, AccessX, StickyKeys,
BounceKeys, and SlowKeys. It includes a graphical program to help with
MouseKeys-acceleration management.")
(license license:bsd-3)))
+
+(define-public wlrctl
+ (package
+ (name "wlrctl")
+ (version "0.2.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~brocellous/wlrctl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "039cxc82k7x473n6d65jray90rj35qmfdmr390zy0c7ic7vn4b78"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("cmake" ,cmake)
+ ("scdoc" ,scdoc)))
+ (inputs
+ `(("libxkbcommon" ,libxkbcommon)
+ ("wayland" ,wayland)))
+ (home-page "https://git.sr.ht/~brocellous/wlrctl")
+ (synopsis "Command line utility for wlroots automation and extensions")
+ (description
+ "wlrctl is a command line utility for miscellaneous wlroots Wayland
+extensions. At this time, wlrctl supports the foreign-toplevel-mangement
+(window/toplevel command), virtual-keyboard (keyboard command),
+and virtual-pointer (pointer command) protocols.")
+ (license license:expat)))
+
--
2.32.0
C
C
Calum Irwin wrote on 27 Jun 2021 06:30
[PATCH] Added wlrctl to xdisorg
(address . 47465@debbugs.gnu.org)
CAH+jhzGdJqS9dLNjmanqaegLyTWgqRYnzO5nfpwUiLz7_i8GCA@mail.gmail.com
I've updated the patch to no longer conflict with the latest master.
Attachment: file
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 47465@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 47465
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch