(address . guix-patches@gnu.org)(name . Alexandru-Sergiu Marton)(address . brown121407@posteo.ro)
* gnu/packages/cpp.scm (entt): New variable.
(entt-fixed-tests): New variable.
---
gnu/packages/cpp.scm | 51 +++++++++++++++++++++++++++++++++++++++++++-
1 file changed, 50 insertions(+), 1 deletion(-)
Toggle diff (75 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 2a00d3838a..449b4c1c06 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -18,7 +18,7 @@
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Milkey Mouse <milkeymouse@meme.institute>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
-
+;;; Copyright © 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -57,6 +57,7 @@
#:use-module (gnu packages curl)
#:use-module (gnu packages documentation)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libunwind)
#:use-module (gnu packages linux)
@@ -1211,3 +1212,51 @@ of reading and writing XML.")
;; incompatible with the GPL v2. Refer to the file named FLOSSE for the
;; details.
(license license:gpl2+)))
+
+;; TODO: Make public and remove the fix below when the next release comes and
+;; fixes the failing tests.
+(define entt
+ (package
+ (name "entt")
+ (version "3.6.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/skypjack/entt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "17w0gx6xah8j2d1kc6ly7a8jvkp4jspmn505w724hynlvlx1192x"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags (list "-DENTT_BUILD_TESTING=ON"
+ "-DENTT_FIND_GTEST_PACKAGE=ON"
+ "-DENTT_BUILD_DOCS=ON")))
+ (native-inputs
+ `(("googletest" ,googletest)
+ ("doxygen" ,doxygen) ; These two packages are needed for
+ ("graphviz" ,graphviz))) ; generating the documentation.
+ (synopsis "Fast and reliable entity component system (ECS)")
+ (description "EnTT is a header-only, tiny and easy to use library for game
+programming and much more written in modern C++.")
+ (home-page "https://github.com/skypjack/entt")
+ (license (list license:expat ; for the code
+ license:cc-by4.0)))) ; for the docs
+
+(define-public entt-fixed-tests
+ ;; This commit fixes two tests that are failing on the 3.6.0 version.
+ (let ((commit "14915368c7d4fa87e944cb55ffae1bb88cc6ef4c")
+ (revision "1"))
+ (package
+ (inherit entt)
+ (name "entt")
+ (version (git-version "v3.6.0" revision commit))
+ (source (origin
+ (inherit (package-source entt))
+ (uri (git-reference
+ (url "https://github.com/skypjack/entt")
+ (commit commit)))
+ (sha256
+ (base32
+ "1amlr4amj94xnmbdz94292vfkxbl92azsr5s41vcqqjmarwkkhfh")))))))
--
2.31.0